Carte controler USB /Mach3

  • Auteur de la discussion jmlwood
  • Date de début
J
jmlwood
Apprenti
19 Juin 2010
61
  • Auteur de la discussion
  • #1
Bonjour à tous,

Je viens de recevoir ma carte controler USB pour Mach3 avec un cd sauf qu'il n'y a aucune explication pour l'installation.
La carte reçue est celle ci-dessous.
1581332093313.png


J'ai tout raccorder mais il ne se passe rien.
Quelqu'un aurait il une idée?
 
gaston83
gaston83
Compagnon
17 Fev 2016
1 398
FR-71520
Bonjour,
Tu n'en dis pas assez.... qu'est-ce que tu veux en faire ? que possèdes-tu comme matériel .... moteur, alim etc....
 
J
jmlwood
Apprenti
19 Juin 2010
61
  • Auteur de la discussion
  • #3
Bonjour Gaston83,

Je possède déjà une machine et elle fonctionne avec une carte munie d'un port parallèle, j'utilise une interface type UC100 pour convertir le port // en USB car mon pc ne possède pas de port //.
J'ai construis une seconde machine et je me suis dis qu'il serait plus judicieux d'acquérir une carte USB directement afin de ne pas devoir racheter une interface de type UC100 (dérivé à environ 50€) mais je ne parviens pas à la faire communiquer avec mon pc
 
Le Prolls
Le Prolls
Compagnon
31 Déc 2012
1 723
FR-35 Rennes BZH
Bonjour,

De ma petite expérience; sur ton CD fourni tu dois avoir un dossier PLUGINS dans lequel se trouve
un fichier portant le nom de ta carte USB.

Tu copies ce fichier et le colles dans le répertoire PLUGINS de MACH3.

Au démarrage de MACH3 tu auras la possibilité de sélectionner ta carte .

Cdt.
 
J
jmlwood
Apprenti
19 Juin 2010
61
  • Auteur de la discussion
  • #5
Effectivement Le Prolls, il y en a 3:
• BL-UsbMach.dll
• RnRMotion.dll
• NVEM-NEW.dll
Je les ai tous copier dans le fichier"pluging" a la rcine de Mach3
Je les retrouve bien quand je démarre Mach3 une fenêtre de choix apparaît et il sont tous les 3 dedans .
J'ai essayé les 3 mais aucun ne fonctionnent
 
gaston83
gaston83
Compagnon
17 Fev 2016
1 398
FR-71520
Sur ma carte j'ai utilisé RnRMotion.dll et je l'ai mis dans le dossier Plugins de Mach3.
 
Le Prolls
Le Prolls
Compagnon
31 Déc 2012
1 723
FR-35 Rennes BZH
Ha oui là c'est plus embêtant...

As tu sur ta carte une LED d'activité ? elle doit s'activer à l' établissement de la connexion avec le PC.

Cdt.
 
J
jmlwood
Apprenti
19 Juin 2010
61
  • Auteur de la discussion
  • #8
Oui effectivement il y a une led et elle clignote
 
Le Prolls
Le Prolls
Compagnon
31 Déc 2012
1 723
FR-35 Rennes BZH
J'ai une carte USB un peu différente de la tienne, je vais laisser parler les membres avec la même carte que toi dont
semble faire partie @gaston83 .

Les infos ne seront que plus pertinentes...

Je suis tout de même..
 
gaston83
gaston83
Compagnon
17 Fev 2016
1 398
FR-71520
D'après ce que je vois, ta carte fait aussi driver pour les moteurs mais je ne connais pas cette carte. J'ai trouvé ça sur le net...

Il faut d'abord alimenter la carte et ensuite lancer Mach3.
 
Fichiers joints
J
jmlwood
Apprenti
19 Juin 2010
61
  • Auteur de la discussion
  • #11
Merci Gaston,

Ça y est ça communique, plus qu'a régler les pas!
J'ai installer tout ça sur un portable pour faire mes essais, je possède un pc fixe sur lequel mach3fr est installé et pilote une machine avec une carte port // DB25 + un dérivé d'une UC100 afin de communiquer en usb vu que ce pc ne possede pas de port //.
J'ai vu que sur Mach3 nous pouvons créer plusieurs profils de machine, crois tu que le fait d'avoir 2 moyens de com ça va fonctionner?
 
J
jmlwood
Apprenti
19 Juin 2010
61
  • Auteur de la discussion
  • #13
Pour que ça fonctionne j'ai tout recommencer depuis le départ en suivant la doc, miracle, ça c'est mis à bouger.
 
J
jmlwood
Apprenti
19 Juin 2010
61
  • Auteur de la discussion
  • #14
J'ai acheté ce type de module pour commander mon moteur de broche et ma pompe (lubrifiant). Je pense comprendre qu'il faut que je mette une alim 5v externe.
Ou est-ce que la sortie de la carte suffirait (signal TTL je crois) ?

ob_284f06_schema-relai.png
 
gaston83
gaston83
Compagnon
17 Fev 2016
1 398
FR-71520
Je pense comprendre qu'il faut que je mette une alim 5v externe.
Oui ... parce que ta carte de fournit pas du 5V d'après ce que je vois. Mais as-tu la doc ? Si oui, je voudrais bien la voir pour t'aider. Au pire des cas, avec une sortie Out tu peux commander un relais pour ta broche.
 
Haut