Backslash et CV

Dardar88
Compagnon
27 Avril 2011
659
  • Auteur de la discussion
  • #1
Hello
Une petite parenthese en attendant que ce topic soit immergé par d'autres plus "chaud devant" :)

j'avais tenté d'utiliser les fonctionnalités du Backslash pour des petites translations qui avaient
du jeu mais sans succes et vu aussi que ce truc n'etait pas la panacée pour pas mal d'utilisateurs
de mach3 ,accoups ,ralentissement du systeme , erreurs ,etc....
Comme mes vis a bille commencent a avoir aussi du jeu avec le temps ,meme si ce n'est pas
inquietant pour du defonçage bois mais redibitoire pour de la gravure au diamant sur laiton ,
etc... je me suis repenché sur le probleme plus serieusement.
En mode CV , je m'aperçois que la qualité de gravure du lettrage est proportionnel a la
vitesse d'execution ,les cercles sont moins finis ,et surtout les fins de rayons ne se raboutent pas
parfaitement ,ça c'est le backslash.
Pour les lettres O ,le taux d'alcoolemie est proportionnelle a la vitesse des virages , c'est
assez normal car mach3 interprete les splines en mode CV et les angles suivent aussi cette
interpretation.

Je me suis fait un petit fichier de cercles cote a cote progressifs voire doublés plus un point de centrage en gravure CN pour ensuite verifier la geometrie au compas a vis et deux pointes aiguille.

Mon big probleme etant qu'en validant l'utilitaire Backslash (X a 0.003 et Y pareil)
les moteurs bloquaient sur certains "passages" d'arc , ce qui faisait sur certains cercles
des demi cercles decallés et ovales ! alors pour du texte complet ou de la defonce spline
,ne meme pas y penser.

ça me confortait sur l'idée de cet ""utilitaire" ingerable

Je me suis énervé comme ça :smt017 :smt012 :batte:

parceque :homer:


Et que google serait un ami (en plus avec le tracking pub nouveau c'est l'ideal alzeimer)

Je me suis aligné sur tout ceux qui ont des vis bricodujnoux et pensaient regler le probleme
avec ça , ben ,...pansement sur jambe de bois et direction VAB sinon rien ,mais j'ai deja...

trois "problemes" a tester ,un par un et tous a la fois
1ier
-vitesse moteur
-acceleration moteur
-durée en ys des signaux de synchro
2ieme
gestion du cartouche config generale: gestion d'angle ,etc...
3ieme
vitesse en % backslash et valeur

test avec vitesse d'execution fichier
dans un cas comme dans l'autre , soit l'un ou l'autre des cercles ne
passe pas (du tout) , ou seulement comme d'hab a 40% du feedrate de base !!!

ça cogne dur aussi dans les vis aux changements de cadran

vraiment naze ,inexploitable ,vive les NUM de 1832, elles au moins....!!

->re et re google

et la..... je tombe sur une analyse des signaux et du backslash genereusement
realisée et mise a disposition par mr Henrik Olsson sur Henrikplace.se
C'est un finôt du signal (d'ailleurs il doit etre Finois...) et m'avait une fois
bien briffé sur un truc electronique.

http://www.henriksplace.se/cnc/mach3_output_analysis.html

Sa conclusion
Le Backslash merdoie parce que des signaux se chevauchent , et que la synchro
XYZ et bizarre dans ce mode ,un curieux "bug" du programme Mach3.

Tout aussi fin ,il s'aperçoit qu'en donnant une valeur suffisament importante dans la
configuration en ms du cartouche Shuttle , la synchro peut fonctionner.

Par defaut ,elle est configrée a 0.004 et peu de gens y touchent car on ne sait pas
trop a quoi ça sert , et meme si on change la valeur , avec un Backslash non
validé , on n'en voit pas trop les effets.

Alors ,pof , je rallonge et j'en met une cagette de ms , allez , de 0.004
je passe a 0.04...
>Et la ça marche mais ça cogne tres fort au quadrant

Alors il faut affiner , comme on dit ,"discret mais present"
-Affiner Shuttle ms ,maintenant 0.02 ,c'est pas trop mal.
- Affiner sur le % vitesse chez Backslash (50% et 100% pour cn rigide)
a 100% la correction est immediate et la vis tourne brusquement de la valeur
parametrée ,voir sur youtube ,Hoosmachine backslash
-la vitesse ,etc ...chez config moteur
-l'angle au cartouche bas gauche ,config générale (defaut 180) tester 49 deg,
ça semble pas mal.

pour le reste ,et bien, si le jeu des vis est corrigé ,que le rattrapage fonctionne
assez gentillement ,ça ne regle pas les problèmes reels de rigidité de la machine
ni de l'interpretation des splines en mode CV.Mais au moins ,même en exécutant
un programme a 60% de sa valeur ,les ronds sont des ronds et je n'ai plus d'erreur
de jeu.

Pour moi ,c'est reglé ,apres , il me faudra passer au stade de remplacement
de mes vis ou de machine ,mais ça peut attendre (tres longtemps):itm:

a table
++

t.
 
Dernière édition:
La dernière réponse à ce sujet date de plus de 6 mois
Haut