1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Choix des éléments électroniques

Discussion dans 'Machines CNC d'autoconstructeurs type portique lég' créé par Mathieu73, 17 Août 2014.

  1. Mathieu73

    Mathieu73 Nouveau

    Messages:
    3
    Inscrit:
    17 Août 2014
    Choix des éléments électroniques
    Bonjour à tous.

    Après beaucoup de temps passé à admirer votre travail, j'ai décidé de me lancer dans la fabrication d'une petite CNC à portique.
    J'ai construit la machine à partir de tiges lisses rectifiées et de douilles à billes que j'avais déjà en stock, ainsi que de tiges filetées conventionnelles. La surface usinable est d'environ 300x300x10.
    J'ai déjà en ma possession 3 NEMA 17, mais je ne sais pas vraiment quelle carte commander, avec quels drivers, ni comment connecter tout ça. J'ai quand même pas mal de notions en électronique, mais je suis spécialisé mécanique.

    Mon budget est assez serré, et vu ma structure (toute en bois), je n'ai pas besoin des matériel électronique dernier cri. Je souhaite juste avoir quelque chose assez simple à paramétrer et qui fonctionne.

    Est-ce que quelqu'un serait en mesure de m'aiguiller, ou encore mieux de me proposer un listing de tout ce dont j'aurais besoin ?

    Merci par avance.
     
  2. Mathieu73

    Mathieu73 Nouveau

    Messages:
    3
    Inscrit:
    17 Août 2014
  3. gaston48

    gaston48 Compagnon

    Messages:
    6 222
    Inscrit:
    26 Février 2008
    Localité:
    59000
    Dernière édition par un modérateur: 16 Avril 2015
  4. Mathieu73

    Mathieu73 Nouveau

    Messages:
    3
    Inscrit:
    17 Août 2014
    Choix des éléments électroniques
    Bonjour à tous.

    Voilà, après quelques mois de coté, j'ai repris mon projet de construire une petite fraiseuse CNC.
    La partie mécanique avance bien, aucun problème de ce coté.

    Mais j'ai commandé il y a peu une carte et des drivers pour mes NEMA 17, et j'ai quelques problèmes de débutant.

    Tout d'abord j'ai commandé cette carte : http://www.amazon.fr/gp/product/B00NNI4YIK?psc=1&redirect=true&ref_=oh_aui_detailpage_o03_s00
    Le tarif est raisonnable pour débuter. Je suis parti sur une connexion USB en premier lieu, puisque je n'ai pas de poste avec port // à l'atelier, je regrette un peu maintenant, puisque j'ai compris après que Mach 3 ne gérait que des ports //.
    La carte est fournie avec un logiciel de commande (plutôt bien fichu, mais toujours très laid à l'instar de Mach 3).

    Concernant les drivers, j'en ai commandé 3 comme celui-ci : http://www.amazon.fr/gp/product/B0090XB7AK?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00
    L'ensemble est plutôt bien construit, les soudures sont propres et les connecteurs sont détachables, un bon point.

    Jusque là tout va bien.
    Arrive le moment des tests.

    J'ai connecté un driver sur la carte (en X), et les connecteurs correspondent (+5, GND, DIR et STEP). J'ai alimenter mon driver en 12V (via une alimentation de PC 500W), puis connecté sur celui-ci un NEMA 17, dont les connexion sont justes (A+ A- B+ B- ).
    Pour finir j'ai branché le tout sur le PC et j'ai spécifié 200 pas par tour dans les réglages en X. Et là, rien ne se passe lorsque je déplace X via le logiciel en manuel. Enfin presque, une LED s'allume sur le driver, mais aucun signe de vie sur le moteur.

    Où peut-être le problème ? Il y a t'il d'autres réglages à faire avant de pouvoir simplement mettre en rotation un moteur ?

    Merci d'avance, je peux publier une photo dans la soirée si besoin.

    Edit : Corrigé. Seulement trois fils doivent relier le driver à la carte de commande, le GND était à virer.
     
    Dernière édition par un modérateur: 16 Avril 2015
Chargement...

Partager cette page