paramètre carte cnc drivers....

  • Auteur de la discussion wmln
  • Date de début
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #1
Bonsoir à tous,

j'ai acheté et installé dans les règles de l'art cette ensemble CNC pour un rétrofit Emco F1.
http://www.ebay.fr/itm/351945564542?_trksid=p2055119.m1438.l2649&ssPageName=STRK:MEBIDX:IT

sous tension tout semble ok au démarrage les moteurs font un petit bruit de blocage. Voyant carte CNC allumé, les 2 diodes sur drivers allumées.

Ensuite rien je n'arrive pas à faire bouger les axes sous Mach3.
J'ai remarqué que sur l’écran principal je n'ai plus le message "arrêt d'urgence activé" mais j'ai "initialisation des pilote ok".
Cependant quand je vais dans la page diagnostique sous Mach3 le petit point rouge avec arrêt d'urgence clignote.
Avez une idée de ce qui m'échappe?
Merci pour vos réponses.
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Bonjour,

Si tu désactives le bouton AU dans la configuration de Mach3 , est-ce que tu as toujours le même problème ?

Quand tu veut bouger les moteurs, les diodes rouges sur la BoB se mettent elles à briller (et le bon axe )?

Ensuite, avant de lancer un Gcode ou le cycle, il faut cliquer sur le Bouton qui clignote pour qu' il reste fixe ( AU programme )
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #3
Merci pour ta réponse ingenieu59,
en faite sur l'écran d’accueil Mach3 je n'ai pas la demande de cliquer sur AU comme j'ai pu le voir sur une autre config. C'est dans la page diagnostique que j'ai le voyant rouge qui clignote. (photo).
Je me demande si dans la notice de la carte CNC les consignes sur la config des ports est correct.
écran mach3.jpg
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Qu' est-ce que tu as dans les config des pins ?
Pour savoir d' où vient le pb, il faut le " disabled "
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Bonjour,

Dans les configs mach3 , il faut décocher L' E stop ( croix rouge ) , pour l' instant, tu n' en as pas besoin .
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #7
Super ça marche enfin presque... que je fasse X- ou X+ le déplacement ce fait dans le même sens. le moteur ne tourne que dans un sens. idem sur tout les axes.
Une idée?
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Alors, oui !!!

Toujours dans les tableaux de config , regardes bien si les DIR sont actif à 0
Regardes dans raccourcis clavier si tu as bien
pour X les touches 39 et 37
pour Y les touches 38 et 40
pour Z les touches 33 et 34
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #9
Je vais regarder ça :wink: en tout cas merci pour ton aide. me sujet n'a pas attiré les foules
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Bah, ce sont les vacances .
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #11
J'ai cela (photo) actuellement.
écran mach3 2.jpg
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Bonjour,

Essaies avec les pins suivants :
En X : 2 et 3
en Y : 4 et 5
en z : 6 et 7
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #13
avec les les pins :
En X : 2 et 3
en Y : 4 et 5
en z : 6 et 7
plus rien de marche .... galère cette histoire
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Avec ta Bob , as-tu eu une notice concernant les pins .
C' est peut-être écrit sur la petite carte , il faut la zoomer .

Reviens comme c' était avant
X 2 et 14
Y 16 et 3
Z 7 et 8

Pour être clair avec toi, la même carte, elle est partie à la poubelle .

As-tu une photo ou un dessin de ton branchement électrique ?

et, surtout, vérifies bien la configuration du clavier ( dans raccourcis clavier ).
 
Dernière édition:
E
ericT
Apprenti
3 Mar 2016
97
LORRIS
bonjour a tous , bonjour wmin
avec cette bob la config est :pin2 xpas, pin14 xdir, pin16 ypas, pin3 ydir, pin7 zpas , pin8 zdir et pin1 enable
pour le cablage c est comme sur le doc, ne pas oublier les petits ponts sur le driver entre dir- , pull- et en-
pourrais tu poster une photo de ton branchement, je pense qu il peut y avoir une erreur de ce coté là
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #18
bonjour a tous , bonjour wmin
avec cette bob la config est :pin2 xpas, pin14 xdir, pin16 ypas, pin3 ydir, pin7 zpas , pin8 zdir et pin1 enable
pour le cablage c est comme sur le doc, ne pas oublier les petits ponts sur le driver entre dir- , pull- et en-
pourrais tu poster une photo de ton branchement, je pense qu il peut y avoir une erreur de ce coté là
merci pour ta réponse, j'ai bien fais les ponts sur les drivers. demain je vais essayer ta config. Je vous tiens au courant.
Merci à tous
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
Bonjour,

Dans les panneaux de config de Mach3 , tu décoches le E-stop , tu n' en as pas besoin pour l' instant .
As-tu vérifié tes raccourcis clavier ?
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #21
bonjour, j'ai bien les mêmes Pin que toi @ericT
raccourci clavier ok @ingenieu59 meme avec un programme avec des - et des + les moteurs tournent dans le même sens. par contre en visu sur mach3 les positifs et négatifs sont respectées.

voici mes pages Mach3 en photos
pageM3170217.jpg
pageM3170217 2.jpg
pageM3170217 3.jpg
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #22
et voici mon driver un des drivers monté
driver 170217.jpg
 
E
ericT
Apprenti
3 Mar 2016
97
LORRIS
bonjour a tous, bonjour wmin
il manque un fil entre arrivée noir pull- et dir- ou en-
il faut que ces trois là soient relié
 
ingenieu59
ingenieu59
Compagnon
10 Sept 2013
3 485
cassel 59
bonjour a tous, bonjour wmin
il manque un fil entre arrivée noir pull- et dir- ou en-
il faut que ces trois là soient relié
+1 , il manque 2 ponts

Tu dois relier ensemble Pull- , Dir- et Ena - pour n' avoir qu' un seul fil qui va à ta BoB sur GND de l' axe en question .
Pareil pour tous tes axes .
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #25
genre comme ça (photo)? et niveau réglage driver j'ai mis pour 1.8
driver 170217 2.jpg
driver 170217 3.jpg
 
E
ericT
Apprenti
3 Mar 2016
97
LORRIS
oui là les trois "-" sont ensemble, c est pour ça que tu n avais pas le dir mais seulement le pas
pour le enable c etait pas grave, beaucoup de drivers fonctionnent sans
 
W
wmln
Apprenti
2 Mar 2015
144
76
  • Auteur de la discussion
  • #27
Super ça fonctionne merci beaucoup à vous deux @ingenieu59 et @ericT merci pour ce forum. Je n'aurai jamais trouvé sans votre aide. J'espère qu'a mon tour je pourrai aider d'autres personnes.
 
Haut