Commande de broche "simple" sur Mach3 avec AXBB-E

S

schum22

Compagnon
Salut à tous,

J'ai quelques questions simples sur Mach3 auxquelles je n'ai pas trouvé de réponses simples....
J'utilise une carte AXBB-E

Premier point
Je souhaite commander ma broche par un tout ou rien.
J'ai donc un relai sur une des sortie (la 11 par exemple) et je veux que Mach commande ce relai.
Tout ce que je trouve à un lien avec un variateur de fréquence.

Pour moi c'est similaire à la commande de l'arrosage par exemple, mais je n'ai encore réussi à faire marcher ça correctement.

Je précise que le reste de la machine fonctionne (commande des pas à pas sur X, Y et Z ainsi que les origines et les fins de course)

Autre point
J'utilise une carte Pokeys57E pour gérer tout mon panneau de commande (bouton + LED) tout marche plutôt bien, sauf pour le joystick.
Je cherche pouvoir régler des pourcentage de la vitesse max en mode Jog par "grand pas" comme ici (5, 25, 50%) , je ne trouve qu'un mode ou on peut faire varier cette vitesse par + ou - (Slow Jog Rate) comme sur l'interface écran (faut il créer un macro par exemple)

2022-03-28_213822.png
2022-03-28_214025.png
 
S

schum22

Compagnon
Je crois avoir compris (je n'ai pas la machine près de moi)

Est ce ça qu'il faut faire?

2022-03-28_221317.png


2022-03-28_221352.png
 
S

schum22

Compagnon
Merci pour ta réponse rapide.

Et pour ma vitesse de déplacement avec Joystick tu sais comment faire?
 
D

dh42

Compagnon
Salut,

Il te faut créer des boutons correspondant sous Machscreen, affecter tes touches de ta télécommande à ces boutons (raccourcis clavier). Les boutons devront avoir une ligne de code en basic comme suit:

SetOEMDRO(3,50)

pour un réglage à 50% par exemple.

++
David
 
S

schum22

Compagnon
J'ai fait la configuration de la commande du moteur de broche grâce à ton explication et tout est OK.

J'ai aussi mis un capteur de proximité sur la broche pour mesurer sa vitesse en temps réel, j'ai mis un disque métallique avec un manque de matière, ça marche bien mais que de 180 tours par minute jusqu'à 2000 (limite de ma machine) en dessous de 180 tours par minute Mach3 affiche zéro, pourtant on voit bien la led du capteur de proximité clignoter ainsi que celle d'entrée de la carte Axbb_e : Mach3 aurait une limite ?

Mach3 est bien configuré pour cette entrée en mode Index.
 
D

dh42

Compagnon
Salut

Cette limite de vitesse basse, je l'ai déjà vue sur un tour (270 RPM), mais je ne comprends pas pourquoi, j'avais fait une demande sur le forum CamBam a un gars qui a numérisé un tour et pour qui ça fonctionne même en tournant le mandrin à la main ... et on n'a pas trouvé pourquoi ça fonctionne pour lui et pas sur l'autre machine :smt017


++
David
 
S

schum22

Compagnon
Salut,

Nouvelle question j'ai voulu piloter le port "Enable" des drivers de mes moteurs via l'AXBB-E.

Première question : est ce vraiment nécessaire (par exemple pour la sécurité)?

Pour le test j'ai utilisé une sortie non isolé de la carte (exactement comme celles que j'utilise pour piloter tous mes "step/dir"), quand je relâche le bouton STOP de la CNC j'entends bien un clac sur mon driver, mais le moteur n'est pas fonctionnel.
2022-08-28_102229.jpg

J'ai même essayé de mettre sur "Active Low" sans succès (même comportement de "clac")

2022-08-28_101256.jpg


Evidemment si je laisse à l'air cette entrée de mon driver tout fonctionne parfaitement.

Mon driver est un CLA86T et ce câble est de ce ttype.
2022-08-28_102029.jpg

Merci d'avance pour votre avis.
 
D

dh42

Compagnon
Salut
Première question : est ce vraiment nécessaire (par exemple pour la sécurité)?

Très souvent ils ne sont pas connectés, d'ailleurs sur le schéma de branchement de l'AXBB-E ils n'y sont pas, apparemment ils utilisent la sortie O1 pour gérer le relais qui active/désactive l'alim des drivers. (ça sert de pompe de charge) et il faut que ça soit sur la sortie O1, voir chapitre 8.3 de la doc.

Je ne peux guère t'en dire plus, tout ce que je sais c'est que ça fonctionne "à l'envers", et qu'il faut alimenter les ENA pour désactiver les drivers.

quand je relâche le bouton STOP de la CNC j'entends bien un clac sur mon driver, mais le moteur n'est pas fonctionnel.

Donc la carte/Mach3 envoi bien l'info :smt017

Je n'ai rien vu dans la config générale qui pourrait gérer les ENA, il n'y a que la pompe de charge qui peut être activée ou non via le E-Stop

(dans le cas de ma BoB, les ENA ne sont pas directement activés par Mach3 via les sorties Enable, mais par la BoB, suivant qu'elle reçoit ou non le signal de la pompe de charge)

++
David
 
Dernière édition:

Sujets similaires

D
Réponses
33
Affichages
1 257
D
M4vrick
Réponses
25
Affichages
1 069
schum22
S
El Zorro
Réponses
12
Affichages
653
El Zorro
El Zorro
M4vrick
Réponses
9
Affichages
1 423
gaston48
G
L
Réponses
11
Affichages
1 852
lecoyote
L
grandioso
Réponses
7
Affichages
547
grandioso
grandioso
S
Réponses
18
Affichages
5 394
rebarbe
rebarbe
B
Réponses
3
Affichages
1 134
D
Coyote94
Réponses
45
Affichages
1 980
Père-Pendiculaire
Père-Pendiculaire
Haut