1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

décalage au démarrage des moteurs pas à pas sous MACH3

Discussion dans 'Electronique spécifique CNC' créé par Gymm CARROZ, 30 Novembre 2013.

  1. Gymm CARROZ

    Gymm CARROZ Nouveau

    Messages:
    3
    Inscrit:
    22 Janvier 2010
    Localité:
    Prauthoy - HAUTE MARNE
    décalage au démarrage des moteurs pas à pas sous MACH3
    Bonjour à tous

    Comme je n'ai jamais posté je me présente rapidement: homme de 42ans habitant l'est de la France et amateur de CNc depuis maintenant 5ans. J'ai pu construire trois machines, une petite avec des éléments d'imprimantes, une plus grosse et surtout plus costaud et enfin une encore plus grosse, bref un parcours standard.
    La dernière en date a été commencée en 2011 puis terminée cette année pour cause d'achat et de rénovation de ma maison. Le but est de fraiser du bois uniquement, aucun autre matériaux.

    Présentation de la machine N°3 (cf photos jointes - dsl pour la qualité je n'avais que mon tph portable pour les faire)

    Partie mécanique:
    -dimension machine 1500x900mm
    -structure bois essentiellement(plan de travail hydrofugé)
    -roulements à billes(de chez décathlon)
    -double motorisation en X et simple en Y et Z
    -Entraînements directs par pignon 9 dents et par chaîne (pas de 8mm) en X et Y et par vis-écrou en Z(récup sur un établi mobile)
    -Fraisage par KRESS 1050-FME


    Partie électronique (acheté chez zappautomation en 2011):
    -carte ZP5A-INT-5 axes
    -drivers PM542 / 20 à 50Vmaxi / 4.2Amaxi
    -alimentation 500W / 50V / 10A maxi
    -moteur pap SY60STH88 -3008BF / 3Nm / série 5.46V et 2.1A / parallèle 2.73V et 4.2Amaxi


    Réglages drivers et moteurs:
    -pap bipolaire série
    -drivers micropas 1/32
    -courant maxi réglé sur 2,37A

    Voilà donc mon soucis que je n'avais jamais remarqué avant mais peut-être que je n'avait pas prêté attention à cela:
    Lorsque j'enclenche les 4 moteurs par MACH3 après avoir fait un déplacement puis un désenclenchement, hormis le claquement normal se produit un décalage moteur (entre 0.1 et 0.5mm). Ce n'est pas systématique et ce n'est pas tous les moteurs en même temps.
    J'utilise le bouton E-stop de MACH3

    Un sympathique membre du forum a pu m'éclairer sur ce phénomène comme ceci: à l'alimentation des moteurs, les bobines se remettent en place en face d'un aimant ce qui est effectivement logique. Lorsque cela ne le fait pas, c'est qu'elle est déjà en face d'un aimant.
    La solution serait de démultiplier l'entrainement et donc de diviser d'autant ce décalage.

    j'avais pour ma part trouver une parade en enclenchant la sortie CURRENT HALF/FULL de MACH3 (onglet OUTUP) et là plus de décalage mais par contre à chaque chaque changement de direction un claquement se produit dans le ou les moteurs sollicités.

    Quelqu'un aurait-il une explication à me fournir SVP ?

    Merci d'avance
    Gymm

    30112013171.jpg

    30112013173.jpg
     
  2. jojo68

    jojo68 Nouveau

    Messages:
    42
    Inscrit:
    19 Novembre 2013
    Localité:
    Sainte croix en plaine, Alsace
    décalage au démarrage des moteurs pas à pas sous MACH3
    Le claquement est provoqué par la libération des moteur, dans ton cas tu utilise la totalité du courant pour arrêter les moteurs, il ne sont donc pas freinés mais bloqués.

    Je ne suis pas sur que ce soit la meilleure solution pour régler ton problème car tu sollicites beaucoup trop la mécanique et l'électronique, cela peut se régler dans les paramètre de mach3 dans l'onglet décalages.
     
  3. Gymm CARROZ

    Gymm CARROZ Nouveau

    Messages:
    3
    Inscrit:
    22 Janvier 2010
    Localité:
    Prauthoy - HAUTE MARNE
    décalage au démarrage des moteurs pas à pas sous MACH3
    Bonsoir Jojo68 et merci de me répondre.

    Peux-tu m'en dire plus STP sur ces réglages que je devrais faire alors?
     
  4. jojo68

    jojo68 Nouveau

    Messages:
    42
    Inscrit:
    19 Novembre 2013
    Localité:
    Sainte croix en plaine, Alsace
    décalage au démarrage des moteurs pas à pas sous MACH3
    Bonsoir,

    J'ai un PDF ou tu trouvera tout ça, envoie moi ton adresse mail par MP et je te joint ça, tout y est super bien expliqué :smt002
     
  5. Gymm CARROZ

    Gymm CARROZ Nouveau

    Messages:
    3
    Inscrit:
    22 Janvier 2010
    Localité:
    Prauthoy - HAUTE MARNE
Chargement...

Partager cette page