1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

'Coalition " d'un axe contre les forces alliés de ma réflexion...

Discussion dans 'Discussions générales sur la conception' créé par Wouguy, 26 Octobre 2015.

  1. Wouguy

    Wouguy Nouveau

    Messages:
    39
    Inscrit:
    19 Septembre 2015
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Bonjour !
    Pardon pour le titre l'ironie apaisse la frustration qui actuellement me submerge.....
    Donc! Je procède peu à peu à la mise à jour de chaque partie de ma cnc .
    Vien le moment des réglage du "STEP PER.." comme toujours je fait mon calcule du STEP per de base X la distance choisie / par la distance réellement parcouru et ainsi de suite en repartant à chaque fois sur les nouvelle données STEP per... Voilli voilou....axe Y ok axe Z ok
    Axe X ..... Je n'y arrive pas!
    Dès que je règle sur une distance choisie et que je règle au 0.01 prés! Si je test sur une autre distance c'est faux! Et plus la distance est longue plus l'ecard est grand ....comme si un modificateur en % était indiqué quelque par ..... J'avais soupçonné un défaut de backslach qui règle partiellement le défaut mais pas totalement ....j'en perd mon latin.....ça fait une semaine que je suis dessus pas constamment bien sur mais je ne trouve pas ..... En théorie le STEP per est de 133.3333 pour le Y on est à 136.xxxxx et le z 134.xxxxx et le x entre 126.xxx et 141.xxxx....si cela parle à quelqu'un je vous baiserez les pieds "virtuellement bien évidemment"
     
  2. HenriIV

    HenriIV Apprenti

    Messages:
    108
    Inscrit:
    12 Novembre 2014
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Bonjour,

    Dur de dire sans avoir le problème sous les yeux mais il y a tellement d'électroniques CNC qui "sautent des pas" à cause de perturbations électriques.
    Je tenterais de retirer les moteurs pas à pas , et de leur attacher un petit disque en carton avec un trait dessiné dessus pour faire un repère angulaire. Après, lancer un programme qui déplace l'axe et revient au même point. Le moteur va faire des tours dans un sens, puis dans l'autre, et doit revenir à son point de départ. Si l'index de repère ne revient pas où il était, il faut regarder le pourquoi dans l'électronique
    Pour ma part j'ai eu ce type de problème et une fois résolu (par des condensateurs de découplage corrects un peu partout, notamment) pour une valeur théorique de 133.33333 je programme cette exacte même valeur et après, au comparateur, quand je mesure le déplacement c'est pile ce que j'ai demandé. Si tu as 136 pour 133.3 ca fait quand même 2% et c'est beaucoup : tu vas bien trouver!

    bon courage,
    @+
     
  3. el patenteu

    el patenteu Compagnon

    Messages:
    2 246
    Inscrit:
    22 Août 2010
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Nul besoin de défaire les moteurs....
    Si la cn retombe pil poil sur ses originnes apres quelques déplacements c'est qu'il ny a pas de perte de pas ni de back lash.
    Il faut d'abbord éliminé les causes mécanniques,etre certain que le probleme ne vient pas de la,coupleur,pignon ou poulie désserée.
    C'est difficil de bien ajuster une cn de 1m de long en se référancant seulement sur une courte distance.
    Meme si cette courte distance est mesuré avec précision il y a de bonnes chance qu'en se raportant 100X plus grand il y est de décimales qui changent.
    Normal,la précision d'un pac n'est pas absolue.(les tolérances sont indiquée a l'endos.
    Si je mesure sur un petit bloc de 1cm Vs sur 1m,ca rapporte la moindre erreur a 100X plus.
    Maintenant si tu es sur des valeurs qui fonctionnait avant, ca devient embetant......

    Fred
     
  4. Wouguy

    Wouguy Nouveau

    Messages:
    39
    Inscrit:
    19 Septembre 2015
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    C'est un peu ça...
    Donc je retombe systématiquement sur mes pas sur le z et y pas de backslach
    Comme le x est le plus "fragile il porte le poid de l'axe z et la broche je suppose déjà une petite latence dans la réaction mais j'ai bien tout rigidifié à la main il n'y a aucun jeux ....je vien de faire une pièce test et c est de plus en plus étrange.....
    La pièce est un carré de 60/60 mm avec un trou de 30 mm au centre et des fentes en forme de crox dans chaque angles...

    La pièce est bien caré au centieme...le trou aussi mais décalé par rapport au centre sur 1mmsur l axe y...... Et les x au chaque coins son bien centré mais sur le cercle mais ne ressemble plus à des + mais à des croix chrétienne ....j'ai bien sur vérifié mon dessin rien c est correct... Une dents qui saute non plus
    ......
    Au final j avais remis à 133.3333 il y a un micro décalage mais il est regulié et au centieme alors que si je change le STEP per le décalage devien exponentielle ..... Bref je sais plus
     
  5. el patenteu

    el patenteu Compagnon

    Messages:
    2 246
    Inscrit:
    22 Août 2010
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Pour savoir si tu reviens pil poil au point de départ tu mets une fraise javelot.
    Tu descend la frais de que de 0.5mm dans la matiere ainsi ca te fais un point de référence pour bien vérifier le retour au 0.
    Aussi,si tu lance une 2e fois le meme usinnage sur la meme piece sans rien changer.......que se passe-t-il?

    Bonne chance!
    Fred
     
  6. el patenteu

    el patenteu Compagnon

    Messages:
    2 246
    Inscrit:
    22 Août 2010
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Il se peut,pas certain, mais une piste....
    Elle aurait perdue des pas ENTRE le moment ou elle terminait le carré juste avant d'entreprendre le cercle.
    Elle tombe donc en mouvement rapide,perte de pas et ensuite elle entame le cercle a vitesse d'usinnage et le fait a la perfection.
    Est-ce possible?
    C'est essentiel de pouvoir vérifié précisement l'orsqu'elle revient a 0.

    Fred
     
  7. Wouguy

    Wouguy Nouveau

    Messages:
    39
    Inscrit:
    19 Septembre 2015
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Bon je vien de gaspillé un peu de matière 3 pièce identique avec le même décalage du cercle....MAIN mes croix son correct maintenant j'ai tout remis à zero 133.3333 et pas de backslach et j'ai fait une configuration des STEP per grâce à l'outil de mach3 que je vien de découvrir.....et impeccable sauf ce décalage de un mm !
    J ai rectifier mon dxf il n'y a pas de defaut j'ai tout refait par soucis de vérification je testé demain avec un dxf propre et g'codes propres si ça continue c'est que c'est cambam qui me génère un soucis.. Lors de l'export g codes
     
  8. el patenteu

    el patenteu Compagnon

    Messages:
    2 246
    Inscrit:
    22 Août 2010
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Je serais curieu de voir ce qu'elle ferait si tu tournais TOUT ton dessin d'un quart de tour.

    Fred
     
  9. Wouguy

    Wouguy Nouveau

    Messages:
    39
    Inscrit:
    19 Septembre 2015
  10. Wouguy

    Wouguy Nouveau

    Messages:
    39
    Inscrit:
    19 Septembre 2015
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Bon après réglage remise à zero ré réglage etc etc le x est bon juste un STEP per à 133,4xxxxxx...
    Mais en faisant tout ces testé le y montre des déficience il revient à zero mais ce décalage de environs 1,5mm mais c'est ératique! Par moment oui d'autre non je veux dire apparemment sur un dessin il va ce décaler à chaque masque différent entre une poche et un contour etc....du coup je soupçonne la carte ! Ce qui n'etonnera pas je pense vu que j ai une carte chinoise avec des problèmes connue je vais tenter la modification proposé !
     
  11. el patenteu

    el patenteu Compagnon

    Messages:
    2 246
    Inscrit:
    22 Août 2010
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Ca semble etre une perte de pas,non?
    Surtout si cela se produit ENTRE les étapes,donc en déplacement rapides.
    J'essairais donc de minuer l'accélération et un peu la vitesse.
    Il se peut que tes rails se soit encrasser et que les moteurs n'arrivent plus a déplacer le portique aussi facilement.
    A vérifié...

    Fred
     
  12. Wouguy

    Wouguy Nouveau

    Messages:
    39
    Inscrit:
    19 Septembre 2015
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Tout est sur roulement! Et très fluide sans jeux ! Enfin manuel!
     
  13. JPM-1

    JPM-1 Nouveau

    Messages:
    2
    Inscrit:
    7 Décembre 2014
    'Coalition " d'un axe contre les forces alliés de ma réflexion...
    Je penche très fortement pour une perte de pas due a l’accélération
    C'est une caractéristique des moteurs pas à pas. Si le couple résistant est supérieur au couple moteur ils restent sur la position courante.
    Lors d'une mise en vitesse (accélération) l'inertie de la charge a déplacer est primordiale. C'est elle qui, ajoutée aux frottements, définit avec l’accélération le couple que doit vaincre le moteur.
    Normalement un moteur pas a pas n'est pas mis directement à la vitesse finale. On applique la mise en vitesse progressivement, souvent selon une rampe La pente de cette rampe contrôle l’accélération.
    Je ne connais pas les CNC (c'est d’ailleurs pour glaner un peu de connaissances que je consulte le forum) mais il devrait exister quelque part un paramétrage de cette rampe.
    A essayer, je pense
    Jean Pierre
     
Chargement...

Partager cette page