1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Motor & power shield pour Arduino

Discussion dans 'Electronique spécifique CNC' créé par Le Menhir 3.0, 8 Octobre 2014.

  1. Le Menhir 3.0

    Le Menhir 3.0 Nouveau

    Messages:
    2
    Inscrit:
    8 Octobre 2014
    Motor & power shield pour Arduino
    Demat / Bonjour

    Je suis actuellement en train de réaliser un banc d'essai pour mon travail, cette machines à des axes qui se déplacent comme une CNC ( :-D ça tombe bien avant d'entreprendre une licence de mécatronique (actuellement) j'étais méthodes usinage).
    Je me suis dit "finger » dans le NOZ!" Et bien non :sad:.

    Je suis allé à la "cave" de mon entreprise dégoter deux vielles imprimantes à aiguille (Je vous parle d'un temps que les moins de 20ans ne peuvent pas connaitre! ......(merci Charles :supz: )).

    Bref revenons à nos moutons.
    J'ai récupéré entre autres les moteurs pas à pas des ces imprimantes.
    MINEBA Type17PM-H103-09V (évidemment référence qui n'existe plus chez le constructeur)
    Mais il fonctionne sous 24V.

    Ayant quelles que connaissances (maigres) sur Adruino je me suis dit que j'allais les piloter avec ce ci.

    http://www.lextronic.fr/P28672-module-motor--power-shield-pour-arduino.html.

    Avant en lançant juste le bouzin sans conecté ni alimentation externe (A au fait, j'ai acheté celle ci http://www.lextronic.fr/P26863-alim-a-decoupage-15-a-24vcc--usb---90w.html)
    ni moteur, juste avec l'exemple présent dans l'IDE arduino " stepper_oneRevolution ".
    Le programme avec l'air de fonctionner ( par rapport à la led LD2 qui s'allumait et d'éteignais )

    Malheureusement en essayant de connecter tout cela. Ca n’a pas vraiment fonctionné (j'ai juste entendu des "tic-tic" dans le moteur et plus rien. Et j'ai même peur d'avoir cramé le shield ou le moteur ou peut être juste la LED du shield (ce que je préfèrerai dans le pire des cas).

    J'ai un deuxième shield et un deuxième moteur j'aimerai bien ne pas recommencer la même bêtise.

    Il y a-t ’il une procédure, quelque chose a faire pour que cela fonctionne ?
    De plus avec le programme tel quel une seul LED du shiel s’allume alors que je pense avoir compris que pour un moteur pas à pas les deux devraient fonctionner.

    Merci / Trugarez
     
    Dernière édition par un modérateur: 16 Avril 2015
  2. pinou29

    pinou29 Compagnon

    Messages:
    1 013
    Inscrit:
    18 Mars 2009
    Localité:
    Toulon ( Var )
    Motor & power shield pour Arduino
    Bonjour.
    Question bête, quelle est l'intensité consommée par le moteur ?
    2,5A maxi par canal, c'est ce que donne la doc du shield.
    Bernard.
     
  3. Le Menhir 3.0

    Le Menhir 3.0 Nouveau

    Messages:
    2
    Inscrit:
    8 Octobre 2014
    Motor & power shield pour Arduino
    Hey

    Alors déja c'est un bipolaire, ensuite au vus des moteur de la même marque ( Mineba) qu'ils fabriquent aujourd'hui qui leur resemble enormément et qui commence pas la référence "17pm-"
    c'est du max 1A.

    En fait je suis en train de me demander si je n'ai pas inversé les phases ! :cry: n'ayant aucun data sheet precis de CE moteur.
     
Chargement...

Partager cette page