1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Décalage du point d'origine

Discussion dans 'Gcode' créé par ElectroRetro, 27 Août 2014.

  1. ElectroRetro

    ElectroRetro Nouveau

    Messages:
    7
    Inscrit:
    27 Août 2014
    Décalage du point d'origine
    Bonjour,

    je suis tout nouveau, et non familier de ce monde.
    je viens de faire l'acquisition d'une petite machine que je fait tourner sous linuccnc. Je cherche à faire un truc basique pour le départ mais je bloque dès le démarrage !
    J'ai vectorisé un dessin, et ai ouvert le g-code. Je ensuite fait une pom sur chaque axe et lance la machine. Le problème est que l'origine sur le dessin est toujours la même : très éloignée du dessin lui-même. La fraiseuse parcourt donc une grande distance (la quasi totalité de la table) avant que je ne l’arrête manuellement pour éviter le drame. J'ai tenté de réduire l'échelle mais cela ne semble rien faire, en tout cas pas rapprocher le dessin du point de départ désigné par le pc.

    Si quelqu'un peut m'éclairer et à la limite me conseiller une intro bien faite et facile à comprendre, je suis preneur.
    Par avance, merci
     
  2. JLuc69

    JLuc69 Compagnon

    Messages:
    1 155
    Inscrit:
    19 Juin 2008
    Localité:
    Genas (69)
    Décalage du point d'origine
    Une fois que tu as fait les origines machines (ce que tu appelles POM) il faut faut déclarer l'origine de ton programme dans la table des origines. C'est une position par rapport à ton 0, 0, 0 machine (comprends : X, Y, Z)

    Mais il faut d'abord vérifier où se trouve ton zéro sur ton dessin. Car c'est de là que part toutes tes positions.
    Avec quoi as tu créé le G-Code ?
     
  3. ElectroRetro

    ElectroRetro Nouveau

    Messages:
    7
    Inscrit:
    27 Août 2014
    Décalage du point d'origine
    Bonjour,

    et merci pour cette réponse. J'ai effectivement réussi à décaler mon point d'origine manuellement à l'aide d'instructions...
    J'ai généré mon code via inkscape, sur la base d'un dessin n&b. Par contre un second problème se pose, la machine est très lente pour le réaliser ! Elle y va pas par pas alors que lors du test avec le logo linuxcnc, c'est bien plus rapide. Une idée sur la manière de gérer cette vitesse ?

    Merci encore,
    Bonne journée
     
  4. JLuc69

    JLuc69 Compagnon

    Messages:
    1 155
    Inscrit:
    19 Juin 2008
    Localité:
    Genas (69)
  5. ElectroRetro

    ElectroRetro Nouveau

    Messages:
    7
    Inscrit:
    27 Août 2014
Chargement...
Articles en relation
  1. speedfender
    Réponses:
    14
    Affichages:
    500

Partager cette page