1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

[RESOLU] Problème carte ERMES 501 (inversion polarite)

Discussion dans 'Electricité, variateurs, convertisseurs et moteurs' créé par totof, 24 Janvier 2015.

  1. totof

    totof Nouveau

    Messages:
    15
    Inscrit:
    24 Janvier 2015
    Localité:
    Haute Normandie
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Bonsoir tout le monde,
    Bon petit récit :
    Un soir en semaine je fini de souder ma carte de controle ERMES 501, les moteurs sont prêt a être brancher, je suis la procédure comme indiquer règle les potars, je branche et la les moteur siffle comme il faut.
    Vient le branchement au pc (prêter par un ami) la carte ne veut rien savoir aucun signal ne sort du pc. Donc je remets au lendemain pour une réinstalle complète en attendant je range tout.
    Une fois mon pc avec un disque tout propre avec juste windows dessus je lance mach3, je fais un petit montage avec un bouton poussoir pour tester le port parallèle ca fonctionne !
    Tout content de moi, je me dis, aller, je test, avant d'aller me coucher il est 2h30 du mat je rebranche tout et la le DRAME :shock: , par fatigue ou manque de concentration j'inverse mon 24v avec la masse !
    Petit flash suivi d'une odeur de cramer je débranche tout en urgence mais trop tard le mal est fait

    Visuellement pas de dégât mis a part une piste qui a fondu mais la je sais pas quoi faire comment diagnostiquer ce qui a cramer ?
    Les résistance j'a pu vérifier mais le reste je vois pas comment faire.

    Merci d'avance pour votre aide :prayer:
     
  2. MARECHE

    MARECHE Compagnon

    Messages:
    2 122
    Inscrit:
    6 Février 2011
    Localité:
    Nancy
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Bonjour,
    Ce genre de pépin pardonne rarement, tous les circuits crament en général. Il vaut mieux changer directement de carte. Teste le PC sur quelque chose pour voir si sa sortie n'a pas trop morflé. C'est lié à des diodes parasites sur les circuits intégrés qui se retrouvent dans le sens direct, d'où courants élevés et fusion des très fins fils de connexion vers les pattes.
    Salutations
     
  3. DEN

    DEN Compagnon

    Messages:
    1 433
    Inscrit:
    28 Août 2009
    Localité:
    NE-CH
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Porblème carte ERMES 501 (inversion polarite)

    Bienvenu !

    Un récit c'est bien en photo c'est mieux, (on est encore sympa, on pourrait demander un "bis" et une vidéo !) et d'autres renseignement pourraient aider, tout le monde ne connaît pas la carte ermes501 !

    Bon néanmoins après quelques recherches , j'ai trouvé de quoi il s'agit :

    http://www.selectronic.ch/carte-con...teur-pas-a-pas-cnc3ax.html?suggestion=produit

    et voici le schémas :

    http://www.ermes.free.fr/kier501.pdf

    Vu le prix du kit 77€ , je pense que ça vaut pas la peine de se casser la tête, à part à des fins didactiques. Le circuit est minimal et simpliste construit autour du vieux L297 aux performances assez réduites .... il y a des composants plus récents qui donnent de meilleures performances , j'ai plus la référence en tête , on en avait discuté sur ce forum, de plus le 297 à part être un dinosaure coûte assez cher, de mémoire autour de 10€ ...

    il semble que la carte est alimentée par 2 tensions, le 24 étant que côté puissance si seulement la tension a été inversée à cet endroit , probablement la logique est encore vivante, (circuits logiques L297 et 7409). Il semble qu'il y a pour chacun des canaux un bornier 24V, si la tension n'a été inversée que sur un des canaux, les autres devraient avoir survécu ...

    A vérifier par ordre de priorité :

    Vérifier les bobinages des moteurs pas à pas au cas où. L'inversion de tension aurait du faire partir en choux-fleur les condensateurs de 1000µF, ou les endommager fortement, les rendant court-circuitants ... (à remplacer en priorité), voir si le fusible de l'alim de 24 est encore là, si il y a 24V qui sortent de l'alim...
    Peu probable vu leur courant nominal et leur diodes internes, et la configuration, qu'il soit arrivé quoi que ce soit au IRLZ44, à tester un par un, les moteurs étant débranchés en toute fin de test ... (voir P.S.)

    Ensuite , brancher la carte (que le 9-12V qui alimente la logique), vérifier qu'il y a le 5 volt qui sort du 7805, vérifier que le 7805 n'est pas brûlant au bout de 2-3 secondes, (un circuit logique mort en court-circuit), vérifier qu'aucun des circuit logiques n'est chaud au bout de quelques secondes, si tout ok, on peut continuer le test, sinon tout débrancher, remplacer ce qui chauffe. (chauffe ça veut dire que c'est à la limite de brûler les doigts, que le 7805 soit tiède est normal, surtout si comme ici il est alimenté avec du 12v, la différence de tension fait que ...) Je l'ai déjà vu branché en direct sur du 24V sans résistance ni rien, quelle aberration, évidement le composant est à 70° pendant tout le fonctionnement.

    Une fois sur qu'il n'y a rien qui court-circuite dans la partie logique, on peut prendre son temps, brancher le port parallèle et essayer de balancer les signaux, vérifier si ça passe jusqu'aux gates de IRLZ44 ... Au voltmètre ça peut-être délicat selon la fréquence, on peut utiliser une petite led, si elle s'illumine légèrement, c'est qu'il y a du signal ... le mieux c'est l’oscilloscope ...

    (P.S.) : trois tests à effectuer pour voir si les mosfet respirent encore, tester si le drain - source ne conduit pas, ça peut se faire à l'ohm-mètre, + sur le drain - sur la source, si ça conduit c'est que c'est cuit ... tester que la diode est encore existante : brancher une pile genre 5v + sur la source et à travers une résistance (100Ohm) par exemple, le moins sur le drain, vérifier que la chute de tension est là 1.3V dans le cas présent, à l'Ohm mètre c'est pas toujours très clair, même si indicatif. Et le dernier test vérifier qu'une tension positive Gate - Source (la pile de 5V) devrait faire l'affaire ouvre le drain source ... (on peut-faire un petit circuit drain source avec une led, ou une mini ampoule de torche, pas sur que ça se voit correctement à l'ohm-mètre, mais ça pourrait).
     
  4. DEN

    DEN Compagnon

    Messages:
    1 433
    Inscrit:
    28 Août 2009
    Localité:
    NE-CH
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Tout compte fait, bien réfléchi, il est probable que la logique ait pris sa claque aussi, la masse doit être commune aux deux alims, donc le 24 aurait pu potentiellement remonter par la masse de l'alim basse tension, à voir ... faut tester complètement la logique. Faut espérer que c'est pas remonté au PC, préférer une version opto-couplée ! Ou placer une break-out board ! Afin d'éviter ce genre de problèmes, il faut protéger les circuits contre les inversions de polarités, utiliser des fiches avec détrompeur (les petites prises vertes ...)
     
  5. totof

    totof Nouveau

    Messages:
    15
    Inscrit:
    24 Janvier 2015
    Localité:
    Haute Normandie
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Merci pour vos réponses rapides.
    Dans un premier temps le pc n'a rien j'ai tester la com elle est bonne, pour les moteur aucun soucis il n'y en avait qu'un de brancher je le remplacerai dans un premier temps j'en ai acheté 4.
    Je ferais tous les tests demain matin.
    Vous m'avez dit que le 297 est un dinosaure mais j’ai pu lire de très bonne critique vis à vis de cette carte me conseillez-vous autre chose ?
    En prenant en compte que c'est ma première et amateur.

    Merci d'avance.
     
  6. DEN

    DEN Compagnon

    Messages:
    1 433
    Inscrit:
    28 Août 2009
    Localité:
    NE-CH
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    En tout premier lieu, vérifier que l'alim de 24V sort encore qqchose, en principe le fusible aurait du dégager, ou la sécurité se mettre en protection, selon la qualité de l'alim. A part si l'alim est très puissante et/ou analogique et/ou sans fusible ...

    Avant de rebrancher quoi que ce soit, remplacer les condensateurs électrolytiques de 1000µF, ils ont certainement souffert ...

    Euh, oui je cherche le fameux circuit dont on a parlé , et qu'un membre du forum a testé avec succès ... si je retrouve je ferai signe . Il faut réaliser le circuit soi-même ...

    Sinon selon le budget, d'habitude c'est la breakout board avec l'opto-isolation , et un driver séparé, de marque par moteur ...

    Et encore un step encore au-dessus, il suffit d'ouvrir un catalogue récent d'automatique industrielle (beckhoff) par exemple, et là normalement c'est l'état de l'art dans l'industrie ...
     
  7. totof

    totof Nouveau

    Messages:
    15
    Inscrit:
    24 Janvier 2015
    Localité:
    Haute Normandie
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Malheureusement j'ai rien pour faire des circuits (même si j'aiemrai bien :p ) et le budget dans les 300 €.
    Je souhaite dabord me faire la main sur une petite basique et ensuite améliorer la mécanique et l’électrique.
     
  8. DEN

    DEN Compagnon

    Messages:
    1 433
    Inscrit:
    28 Août 2009
    Localité:
    NE-CH
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Je pense que ça vaut la peine d'avoir la breakout board (au moins), ça évite en cas de fausse manœuvre de fumer le PC, après il faut voir sur soprolec (par exemple) si vous arrivez à vous en tirer au total pour moins de 300€ ... c'est possible en cas de moteur pas à pas pas trop puissants ... à voir ... sinon essayez de réparer votre carte, on vous aidera dans le domaine du possible, et au final si tout est mort dessus vous n'en serrez qu'à racheter la même ...

    Ah oui , la piste qui a grillé , il faudrait la remplacer-renforcer par un fil et de la soudure ...

    Et placer au moins un fusible par 24V de moteur pas à pas , ça isolera les problèmes ...
     
  9. DEN

    DEN Compagnon

    Messages:
    1 433
    Inscrit:
    28 Août 2009
    Localité:
    NE-CH
  10. totof

    totof Nouveau

    Messages:
    15
    Inscrit:
    24 Janvier 2015
    Localité:
    Haute Normandie
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Bonjour, merci je suis entrain de lire avec intérêt l'article cependant pour le pue que j'ai lu 3 pages) il parle de moteur bi-polaire or ceux que j'ai sont unipolaire.
    Il semblerait que les gains obtenus en changeant par un TB6600HG soit vraiment satisfaisant mais cela m'oblige a changer les moteurs.
    Si j'ai bien compris le circuit présenté sert a contrôler uniquement un seul moteur ? Ce qui m'arrangerai par la suite car je souhaiterai passer en 4axes.
     
  11. DEN

    DEN Compagnon

    Messages:
    1 433
    Inscrit:
    28 Août 2009
    Localité:
    NE-CH
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    La plus part du temps on peut tout de même câbler de l'unipolaire sur un driver prévu pour du bipolaire, plusieurs configurations sont possibles afin d'augmenter soit le couple, soit la vitesse ... sur le site de soprolec, il y a la doc sur comment effectuer le câblage dans ce cas ...

    Oui, c'est circuit intégré par moteur, d'ailleurs ce n'est pas différent de ce point de vue du L297 (sur votre carte il y en a 3) ... l'avantage du circuit présent est qu'il contient tout (logique et puissance) et avec quatre composants autour on fait tout fonctionner ... D'ailleurs je vais peut-être me le commander pour essayer ...
     
  12. totof

    totof Nouveau

    Messages:
    15
    Inscrit:
    24 Janvier 2015
    Localité:
    Haute Normandie
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    L'avantage est aussi la disparition des MOSFETs, je pense que je vais me pencher serieusement sur cette solution.
    Avez-vous des adresses pour l'insolation ?
    Par contre derrière je dois me faire une carte pour envoyer les infos via le port parallèle tout en protégeant les entrées par optocoupleur ?
     
  13. osiver

    osiver Compagnon

    Messages:
    4 106
    Inscrit:
    7 Septembre 2013
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Avant de jeter le bébé avec l'eau du bain, pourriez-vous nous poster une photo de la carte dans la zone piste cramée ?
    Et puis, est-ce que les 3 entrées de 24V étaient reliées ou une seule, pour un seul moteur ?

    Pour moi, je peux me tromper mais vu le schéma, le 24V a du être effondré immédiatement par les diodes des IRLZ, le circuit imprimé a fait fusible, la tension inversée n'a pas dépassé 2V. Donc, à part cette piste coupée, il est possible que la carte ne soit pas détruite ... :eek:
     
  14. totof

    totof Nouveau

    Messages:
    15
    Inscrit:
    24 Janvier 2015
    Localité:
    Haute Normandie
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Un seul moteur été câblé là où la piste a fait office de fusible d'ailleurs.
    Toutes les résistance de puissances sont hs ainsi que les résistance R15 à R20 (voir shcema)

    Voici la photo:
    [​IMG]
     
  15. osiver

    osiver Compagnon

    Messages:
    4 106
    Inscrit:
    7 Septembre 2013
    [RESOLU] Problème carte ERMES 501 (inversion polarite)
    Re: Problème carte ERMES 501 (inversion polarite)

    Alors, ça pas bon !
    Les potentiomètres aussi sans doute et du coup les CI, Là, c'est mort :sad:
     
Chargement...

Partager cette page