Fabrication d’un driver pour moteur pas à pas 4,5A

  • Auteur de la discussion nopxor
  • Date de début
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #1
Bonjour,

Je souhaitais essayer le récent circuit intégré TB6600HG de Toshiba.
Caractéristiques:
Courant de sortie: 4,5A
Tension d'alimentation unique: 8 à 42V
1/1, 1/2, 1/4, 1/8, et 1/16 de pas.
Fréquence max.:200kHz
Prix: environ 6€

J'ai réalisé une carte en m'inspirant du schéma cuteminds (TB6600HQ) avec quelques modifications.
Le TB6600HG n'a besoin que de quelques composants périphériques pour fonctionner.
Pas d'optocoupleurs, puisque les signaux de commande sont bufférisés par la break-board.
Je l'ai monté à plat sur la platine et muni d'un radiateur.

J'ai procédé à plusieurs test avec un moteur Nema23 (holding torque=9,8Kg.cm) en prise directe sur une vis à bille de 500mm, Ø30mm.
Alimentation par transfo, 30V DC.
Potentiomètre de réglage du courant à mi course (Vref = 1V).
Les résultats sont vraiment très satisfaisants :
Le moteur a un fonctionnement doux, un bruit agréable, un bon couple et ne chauffe pas du tout.
Le radiateur du driver est à peine tiède.
Quelque soit le mode de micro-pas choisi, les vitesses et accélérations sont impressionnantes et pas de résonances.
A titre de comparaison avec une carte à base des classiques L297 et L6203 (certes vieux de plus de 20 ans), voici les gains obtenus pour ce même moteur :
Résolution : x 8
Vitesse : x 3
Accélération : x 3
Fréquence : x 24
Test effectué avec LinuxCNC à une fréquence de 20kHz.
A noter qu’avec l’ancienne carte, le moteur est très chaud et vibre beaucoup. Le radiateur des 2 circuits L6203, avec un volume équivalent, monte à une température de 75°C.

Conclusion, je vous recommande vivement ce circuit intégré.

Drive_TB6600HG_top.jpg


Drive_TB6600HG_bot.JPG


Circuit_TB6600HG.JPG
 
Charly 57
Charly 57
Compagnon
21 Déc 2008
5 388
FR-57330 Moselle
Bonsoir
Génial tes essais. Peux tu, s'il te plait, mettre le schéma que tu as réalisé et le dessin du typon.
Il va servir à pas mal de monde pour remplacer les cartes qui ont un TB6560 capricieux !!!!

Merci d'avance
 
B
Bth
Ouvrier
2 Fev 2009
487
Besançon25
Bonjour Nopxor, bonjour à tous et à toutes,

Merci pour ce test, j'ai les réponses à toutes les questions que je me posais. Etant adepte des L297 depuis pas mal d'année. J'ai vu chez un ami des cartes chinoise!!! et c'est vrai que ça roule bien. Je vais garder ton travail en référence. Le double face simplifie bien l'implantation de ce circuit.

Bonne journée.
Bth Thierry
 
G
Guy69
Compagnon
3 Mar 2009
1 301
FR-71170
super!
et on le trouve où ce circuit?
Merci
Cordialement
Guy
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #6
Dernière édition par un modérateur:
G
Guy69
Compagnon
3 Mar 2009
1 301
FR-71170
Thank you verimuche
Guy
 
A
axe55
Apprenti
17 Jan 2013
221
Ce driver fonctionne super, je le connais bien et de plus as des protection thermiques et de cc sur les sorties. cependant les optos en entrées restent fortement conseillés, non pas pour une question de mise en forme du signal mais en protection et isolation entre PC ou carte interface.
 
wika58
wika58
Compagnon
17 Déc 2006
13 173
FR-54560 Lorraine
Très intéressant.

Et ce principe de sortir les pattes du côté cuivre et du côté composant est astucieux... :smt023
 
rddt
rddt
Ouvrier
25 Avr 2010
464
toit du Var
Bonjour a tous

@/Nopxor

Très belle réalisation, je vais m'en inspiré pour un futur projet, cependant étant pas un pro de la conception électronique pourrait tu m’apportez quelques
informations sur ta réalisation, sur ton schéma (.brd) qu es ce que le TP1?, les six résistances de 0.68 sont elles des 1Watt ou autres? pour le reste j'ai pigé.
J'ai télécharger ton fichier <carte pas à pas bipolaire TB6600HG.rar> mais je n'arrive pas a l’ouvrir avec Eagle, "Invalid data in file" aussi bien le .sch que le .brd,
J'ai la version 5.10.0 en version gratuite, es ce pour cela ?
Merci de tes réponses
++
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #11
Bonjour,

Le TP1 est juste un "test point" qui permet de souder un picot pour mesurer la tension Vref issue de la résistance ajustable qui fixe le courant moteur.
J'ai mis des résistances de 0,68Ω/1W, mais des 1/2w suffisent certainement. L'idée étant d'associer 3 résistances en parallèle pour obtenir environ 0,20Ω en NF-A et NF-B.

Comme j'ai utilisé la version 6.5 de Eagle, il y a effectivement peut-être un problème pour ouvrir les fichiers avec les versions antérieures de Eagle.
la dernière version freeware est disponible là:
https://www.cadsoftusa.com/download-eagle/freeware/?language=en

Ci-joint un dossier qui contient les fichiers en .pdf.
J'ai mis aussi un tutoriel en français sur Eagle dedans. Voir la pièce jointe step driver.rar
 
Dernière édition par un modérateur:
rddt
rddt
Ouvrier
25 Avr 2010
464
toit du Var
Re

Merci pour le lien et tes infos je vais mettre a jour Eagle.
++
 
B
Bth
Ouvrier
2 Fev 2009
487
Besançon25
Bonjour Nopxor, bonjour à tous et à toutes,

Dossier téléchargé et archivé. Je vais acheter quelques circuits et réaliser ce montage.
Merci et bonne journée.
Bth Thierry
 
R
rico74
Nouveau
26 Fev 2014
3
bonjour ,
j'ai une question de bleub... :)
j'ai récupéré des nema23 qui sont en 2.6V et 1.8A :
comment faire pour les connecter si j'alimente la carte TB6600 en 12 ou 24V ?

désolé mais j'ai beau chercher depuis quelques temps et rien trouvé sur ce genre d'info ...
merci d'avance pour votre aide
Rico
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #15
Bonjour,

Si c'est des bipolaires 4 fils, tu mesures la continuité ou la résistance entre les fils et tu les connectes comme sur ce schéma.

4-wire_stepper.jpg
 
R
rico74
Nouveau
26 Fev 2014
3
nopxor a dit:
Bonjour,

Si c'est des bipolaires 4 fils, tu mesures la continuité ou la résistance entre les fils et tu les connectes comme sur ce schéma.
merci Nopxor pour ta réponse, je me suis mal exprimé : ce sont des bipolaires.

Ce que je n'arrive pas à capter c'est comment on peut brancher des moteurs 2.6v sur un driver qui semble etre alimenté en 24V ?

ok ce n'est pas du branchement "direct" j'ai toujours eu un soucis avec les montages en source de courant constant et le calculs d'impédances.
ce qui m'a mis dedans, c'est que je pensais que les moteurs pouvaient peut-être être pilotés en PWM où l'on parle plus de tension que de courant.
mais bon, à ce que j'ai pu lire ici ou là, ça ne semble pas être la tension des moteurs qui compte mais leur inductance et le courant nominal (ici 1.8 A -et non 3.6 comme je l'avais écrit) qu'on règle sur la carte driver (qui serait 75% à ce que j'ai pu lire dans un autre post pour des moteurs quasi similaires.

d'autre part j'ai lu aussi qu'il était plutôt recommandé d'utiliser des alims non régulées pour éviter qu'elles ne se mettre en défaut ou reset sur des retours de courant avez-vous des préconisations dans ce sens ou bien on peut prendre un peu ce qu'on veut dès l'instant que le courant max soit suffisant pour 3,4,5 moteurs ?
encore merci
Rico
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #17
Ce lien explique bien l'alimentation des moteurs pas à pas.

Les moteurs sont bien alimentés en PWM et les résistances de shunt servent à mesurer le courant.
Le TB6600 adapte la modulation de la tension (et la largeur des impulsions par rapport au temps) pour que ce courant soit constant.

Comme c'est le driver lui même qui régule l'alimentation du moteur, il est inutile de lui fournir une alimentation déja "hachée".
Au contraire, un bon gros transfo, un pont redresseur avec un ou des gros condensateurs réservoirs sont plus adaptés.
L'inconvénient des gros transfos c'est le prix. Mais les transfos, c'est quasimment increvable.
Il est très rentable d'en récupérer sur des épaves.
J'ai eu la chance de trouver chez un ferrailleur des 24v/640VA Legrand.
C'est sans doutes énorme pour mon alimentation, mais il vaut mieux "en avoir sous la godasse".
Au moins celui la aura une retraite bien tranquille.
Le principal étant effectivement de pouvoir fournir la somme des courants consommés par l'ensemble des moteurs avec de la marge.

Alimentation.jpg
 
P
pierrel26
Ouvrier
13 Oct 2013
276
Drôme
Le problème avec les transfo c'est la tension max en sortie redressé
Exemple vieux transfo 220 24 volt 600 va a vide sur un réseau 240volt
10% pour le réseau 10 % pour la perte en charge x1.414(racine 2) pour la valeur crête
=24x1.1x1.1x1.414=41volts bon avec un tb6600 avec marge de plus de 10% toujours possible sur le réseau edf

Ceci dit une bonne alim a découpage marche aussi au pire il suffit de rajouter une grosse capa en sortie genre 4500 µF
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #19
Bonjour,

Peux-tu expliquer ton calcul ?
Je ne comprends pas comment les pertes peuvent majorer la tension.
Avec l'appel de courant du à la charge des moteurs,la tension aura dailleurs tendance à baisser.
En théorie on a :
24V x 1.414 = 33,94V
et la mesure effectuée à vide de 34.9V soit moins de 3% d'erreur en valeur de crête me semble cohérente.
J' admet bien sûr une éventelle fluctuation du réseau.
L'important étant aussi d'avoir une tension élevée, dans la limite U max du datasheet, pour les performances des moteurs.

pierrel26 a dit:
Ceci dit une bonne alim a découpage marche aussi au pire il suffit de rajouter une grosse capa en sortie genre 4500 µF
Certainement.

tension.jpg
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #20
Si vous êtes tentés d'acheter des TB6600 en chine, je vous conseille de lire mon intervention sur ce post.
 
P
pierrel26
Ouvrier
13 Oct 2013
276
Drôme
le réseau edf est souvent de 240 volts or les anciens transfo sont calculé avec 220 volts donc en gros 10 % de plus au secondaire
La tension au secondaire est donner en charge nominale donc à vide ou a faible charge Usortie = Un/rendement donc environ 10%
de plus. Surement moins vrai pour un 600va avec un rendement plus proche de 95%
Mais des transfo de 100 ou 150 va peuvent avoir 85 90% de rendement à vérifier au cas par cas
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #22
ok, c'est clair, merci d'avoir developpe.
 
R
rico74
Nouveau
26 Fev 2014
3
nopxor a dit:
Ce lien explique bien l'alimentation des moteurs pas à pas.

Les moteurs sont bien alimentés en PWM et les résistances de shunt servent à mesurer le courant.
Le TB6600 adapte la modulation de la tension (et la largeur des impulsions par rapport au temps) pour que ce courant soit constant.

Comme c'est le driver lui même qui régule l'alimentation du moteur, il est inutile de lui fournir une alimentation déja "hachée".
Au contraire, un bon gros transfo, un pont redresseur avec un ou des gros condensateurs réservoirs sont plus adaptés.
L'inconvénient des gros transfos c'est le prix. Mais les transfos, c'est quasiment increvable.
Il est très rentable d'en récupérer sur des épaves.
J'ai eu la chance de trouver chez un ferrailleur des 24v/640VA Legrand.
C'est sans doutes énorme pour mon alimentation, mais il vaut mieux "en avoir sous la godasse".
Au moins celui la aura une retraite bien tranquille.
Le principal étant effectivement de pouvoir fournir la somme des courants consommés par l'ensemble des moteurs avec de la marge.
hello Nopxor,
super réponse merci ça me rassure :wink:
reste plus qu'à trouver l'alim

encore merci
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #24
Bonjour,

J'ai testé un des TB6600HG acheté le 03/03/2014 chez G & C sur Ebay.
n°série: 1252GA donc fabriqué fin décembre de 2012.(la 52ème semaine)


Conditions du test:
moteur Nema 23 ref:57HY76DF02(holding torque=9.8Kg.cm)
charge : en prise directe sur vis à bille de 500 mm, Ø30 mm, pas 10 mm.
U alimentation = 26.8 V
Vref = 1.68 V donc Io (100%) = (1/3 × Vref) ÷ RNF = (1.68/3) ÷ 0.226 = 2.48 A
configuration: 1/16 de pas, soit 320 pas/mm.
génération des signaux de commande par LinuxCNC.
vitesse noix de la vis à bille: 70 mm/s
accélération: 60 mm/s²
vitesse de rotation moteur: 420 trs/mn
fréquence horloge step: 22400 Hz

Dans un premier temps le fonctionnement a l'air correct, mais à vitesse constante, on remarque comme un léger bruit de casserole.
Rien à voir avec le doux bruit des TB6600HG cru septembre 2013 (semaine 39) dont je suis ravi.
J'ai cherché à mettre en évidence ces résonnaces parasites:
A la vitesse de 16 mm/s, soit à 5120 Hz le phénomène s'amplifie.
C'est épouvantable tellement c'est saccadé.
Pire, à cette vitesse, le drive a littéralement planté plusieurs fois en coupant complètement l'alimentation du moteur.
Reset obligatoire pour repartir.

Conclusion:
Pas besoin d'oscilloscope à mémoire pour constater le bug hardware.
Merci à Mouser de fournir les bons TB6600HG et bien sûr à TOSHIBA d'avoir corrigé le tir.
Honte aux escrocs chinois. :mad:
G & C souhaitait que je leur mette 5 étoiles de feedback...
Je leur ai fait comprendre où ils pouvaient se les mettre. :smt003
 
rddt
rddt
Ouvrier
25 Avr 2010
464
toit du Var
Bonjour a tous


Merci à Mouser de fournir les bons TB6600HG et bien sûr à TOSHIBA d'avoir corrigé le tir.
Apparemment le vendeur a rectifier le tir si on croit son annonce:
"TB6600HG ZIP-25 ORIGINAL NEW GOOD QUALITY".
Nopxor, ça ma refroidie ta conclusion, du coup le suis mi-porteur de commander ces CI.

++
 
nopxor
nopxor
Compagnon
27 Mai 2010
1 412
Yvelines
  • Auteur de la discussion
  • #26
Bonjour,

Les TB6600HG vendus par G & C sont effectivement neufs, mais pas de bonne qualité, puisqu'ils écoulent le stock des composants v1 qui ont un bug hardware. sur cette photo on voit bien le n° de série 1252GA qui signifie fabriqué en décembre 2012. Or le bug n'a été corrigé qu'après aout 2013.

composants chinois G&C.jpg
 
speedfender
speedfender
Compagnon
16 Fev 2013
617
Nancy 54
Bonjour,

Je suis équipé de drivers fait à partir l297et l6203. J'ai une transmission par chaine sur ma cnc est donc le demi-pas s'avère un peu juste.. et j'ai (encore) un l6203 provenant de chine qui vient de me lacher..
Bref, tout ça pour dire que je partirai bien sur le tb6600 que vous m'avez fait découvrir :roll:
Par contre j'aurai aimé les acheter déjà fait mais avec ce que je viens de lire sur la mauvaise série je suis un peu calmé.. d'`ou ma question : est-ce que qq à acheté des drivers à base de tb6600 valides sur ebay, chez quel vendeur ?
Sinon je vais les réaliser (mais pas sur d'être financièrement gagnant.. ) je trouve le pcb de cuteminds un peu dépouillé par rapport à ce qu'on peut voir sur ebay. Il manque quoi? les optocoupleurs? si ce n'est que ça je ferais ton schéma nopxor :wink:


merci

++
 
LETARTARE
LETARTARE
Ouvrier
27 Sept 2010
498
Haute-Savoie
Bonjour,
un grand merci pour cette réalisation, ainsi que la mise en garde pour les dates de mauvaise fabrication pour ces pilotes de puissances TB6600HG.
Bien cordialement.
 
J
justind1989
Nouveau
5 Fev 2014
31
Bonjour,

nopxor -> J'aimerai également utiliser le TB6600HG. Cependant, je veux les composants avec le beug corrigé. Comment dire que 1252GA correspond à décembre 2012. Je commande toujours mes composants sur ebay, si je ne trouve pas je commande sur farnel. Pourrais-tu m'en dire plus svp ?
 
speedfender
speedfender
Compagnon
16 Fev 2013
617
Nancy 54
Bonjour,
Je viens de commander les circuits tb6600 et vais faire ton schéma si gentillement partagé ; j'ai néanmoins deux questions :

Pour quelles raisons as-tu changé les valeurs des résistances r14->r10 par rapport au schéma de cuteminds ?

Ne vaudrait-il pas mieux placer les entrées step, dir, enable, tq, latch, m1, m2, m3 à la masse plutôt que de les laisser en l'air? Où alors le composant tb6600 le fait de lui même?


merci par avance
 
Haut