Paramétrer les déplacements axes, sur mach3

  • Auteur de la discussion ISAMINE
  • Date de début
I
ISAMINE
Nouveau
Madame, Monsieur
Bonjour
Ravis de découvrir ce forum USINAGE qui traite de la CNC.
Je voudrai poser une question concernant le paramétrage de la vis sur MACH3 et si possible une adresse de tutoriel.
Il se peut que ce sujet est traité déjà mais je ne trouve pas de lien.
De profession électromécaniciens, j'ai réalisé une machine CNC avec trois vis INA modifiées en longueur.
Un tour de chacune d'elles le déplacement est égal à 10 mm.
La machine fonctionne très bien, mais le déplacement n'est pas conforme à l'échelle.
Merci de m'éclairer .
Avec tous mes respects et mes meilleurs salutation.
 
I
ISAMINE
Nouveau
Bonjour
Merci pour votre intervention
Oui c'est des vis INA (mastoc ) Quand je tourne la vis elle se déplace de 10 mm.
Entrancement directe sans courrois.
 
K
kawah2
Compagnon
fais une copie d'écran de tes paramétrages sur mach3 :wink:
 
I
ISAMINE
Nouveau
Ci joint quelques photos.
Franchement je ne sais pas où aller.
Merci

20210508_152711[1].jpg


20210508_152728[1].jpg


20210508_152755[1].jpg
 
I
ISAMINE
Nouveau
Y a même le panier à médicaments sur la photo.......!!!!!!!
 
R
Rom'
Compagnon
On ne paramètre pas directement le pas de la vis, mais le nombre de pas nécessaire pour faire 1mm de deplacement
« Steps per » dans la première photo
Il faut tenir compte des micropas du drive, de la chaîne de transmission et du pas de la vis
 
I
ISAMINE
Nouveau
Ah.....!!!

Je vais lire bien votre réponse. Je comprend vite mais il faut m'expliquer longtemps.
Donc y a des calculs (dans les reins) à faire
Je vais essayé.
Merci beaucoup
 
I
ISAMINE
Nouveau
Donc selon mon raisonnement:
Mon moteur a 200 pas tour 16 microns pas.
La vis 1 tour = 10 mm
Donc 200 X 16 microns que divise 10 mm de la vis.
Cela me donne 320 que je dois saisir dans la case que vous m'avez indiquée.
N'est ce pas ??
 
R
Rom'
Compagnon
J’ai pas refait Le calcul, mais plus d’ici sur le téléphone, ça m’a l’air cohérent. Mais en tout cas dans le cas où les moteurs sont directement en prise sur les vis
 
I
ISAMINE
Nouveau
Je descend au Garage faire un teste et vous tenir au courant.
Merci infiniment pour ces renseignements si précieux
On apprend tous les jours.
 
I
ISAMINE
Nouveau
Me revoila.
Merci pour l'info.
C'est bazar...! Sur un dessin le parameter marche très bien et sur un autre le déplacement est tellement grand la machine s'arrête avec la fin de course. Même en mettant tous les compteurs à zero la fraiseuse va jusqu'à la fin de cours.
Bon. Y a surement quelque chose qui cloche.
Je vais continuer à rechercher.
 
I
ISAMINE
Nouveau
Je posterai les photos de la bête fabriquée qu'avec du materiel de la récupe.
 
I
ISAMINE
Nouveau
Photos machine. Plateau et broche non montés encore.

20210508_170357.jpg


20210508_170435.jpg


20210508_170449.jpg
 
I
ISAMINE
Nouveau
Je vous remercie Rom' pour vos précieuses explications.
Je laisse le poste ouvert et je reviens vers vous pour vous tenir de l'avancement du paramétrage.
Merci encore une fois.
 
sebastian
sebastian
Compagnon
Bonjour isamine,
ta VàB est au pas de 10 (10mm/T) ; tu va devoir faire une calibration pour affiner la précision des déplacements si tu n'obtiens pas les bonnes cotes.
Quelles sont les unités d'échelle de ton dessin ? mm à priori…
Est-tu identique dans les paramètres de ta DAO (mm, inch… ) et du Gcode créé ? c'est à vérifier pour être identique, sinon c'est clair que tu va dépasser les limites d'usinage de ta machine.
Voilà une chaine YT interessante qui donne "les bases" de réglage de mach3 FR… et un peu plus.
Bonne visualisation et paramétrages
 
D
Doctor_itchy
Compagnon
le calcul est bon , mais 320 pas par mm ça fait une résolution pas terrible ! tu devrais soit trouver des vis a bille pas de 5mm soit voir une démultiplication via tes courroie ( ça aussi si tu a des courroie poulie , pour ton calcul elle doivent etre au meme nombre de dent chaque (poulie moteur et poulie vis identique donc transmission 1/1 ) si la poulie moteur est plus grande , moins de précision et moins de pas au mm , et inversement si la poulie coté vis est plus grande , plus de préscision et plus de pas au mm , tu peu mettre un set de poulie 1/2 par exemple , donc 20 dent moteur et 40 dent vis a bille , la tu auras 640pas moteur pour 1mm tu gagne en précision (et perd en vitesse Fmax ) ça compense le pas trop grand des vis a billes

en général on met des vis a bille 4/5mm de pas et un set courroie poulie 1/2 en réduction pour de "grande" précision et du couple d'axe :)

apres ça une calibration oui , mais il faut une référence idéalement couplé une regle linaire de dro "provisoirement" sur l'axe a calibrer et faire la mesure et calibrage :)
 
I
ISAMINE
Nouveau
Remonté du Garage et découvre votre réponse.
Merci beaucoup.
Je vais Vérifier le logiciel s'il est en inch ou en mm.
C'est géniale MACH3 en Français d'origine. Il est mieux que la version anglaise patchée.
Je vais étudier tout ça et vous tenir informé.
Merci
 
I
ISAMINE
Nouveau
Bonjour Docteur Itchy.
Merci pour vos explications. J' ai pas mal de lécture pour mon petit cerveau.
Donc je vois qu'il y a beaucoup de choses à revoir. La CNC un ocean de découvertes.
Je fais ça pour le plaisir après tant d'années d'électromécanique et de l'électronique.
Je débute.
 
D
Doctor_itchy
Compagnon
ha la cnc , c'est ultra pratique mais il faut bien tout vérifier et calibrer avant , sinon forçément ça va coincer quelque part ( sauf coup de bol ^^ )

oui il faut aussi bien vérifier que tout est en mm , si ta machine est en mm et que ton code est en inch forçément :/ (et inversement ^^ )
 
sebastian
sebastian
Compagnon
Pour la Calibration (et mesure de concordances des cotes de déplacement / dessin), à défaut de vérifier avec un pied à coulisse digital… tu peux déjà simplement scotcher une lame de cutter sur la platine du Z et calibrer avec un réglet au 1/2mm ; tu dessine par exemple un carré de 100x100 (mm) ou + et tu vérifie la dimension ; tu rentre les valeurs obtenues et tu re-calibre pour vérifier au final.
(ça donne parfois 2 à 3 décimales après la virgule… suivant la précision de la VàB et de la bonne géométrie de sa machine)…
Je crois que c'est bien expliqué dans les vidéos que je t'ai donné :wink: mais ça fait quelques temps que je n'y suis plus allé…
 
Dernière édition:
I
ISAMINE
Nouveau
Merci Roms'
Merci Doctor Itchy
Merci Sebastian et Stef1204;

Je crois tout est en ordre. Je vais prendre le temps pour monter le plateau et lancer un dessin d'Arabesque pour l'essai.
Merci pour votre concours.
Je reviendrai pour d'autres questions car le chemin de la CNC est long et semé d'embuches ( je parle pour moi).
 
dh42
dh42
Compagnon
Salut,

Pour la calibration avec pied à coulisse.

ça peut t'intéresser aussi

++
David
 
Dernière édition:
I
ISAMINE
Nouveau
Bonjour à toute l'équipe.
Voilà je suis de retour. Le plateau est installé et mis à 0
Mais, mais !
Tous fonctionne bien simplement les moteur X et Y ronronnent un peu on dirait les douilles à billes sont grippées.
La carte CNC est une NVCNC 4 axe
Le Driver est un DM 860T Programmé sur 1600
Moteur PHYTRON RSS-66-200-5-E RSS662005E 5A STEPPER MOTOR

Merci pour votre aide. Je reste à votre disposition pour toute autre question.
 
Fred69
Fred69
Compagnon
Sur tes photos je ne vois pas de vis au pas de 10 mm ?
 
Dernière édition:
I
ISAMINE
Nouveau
Merci Fred69 pour votre réflexion
Je vais poster une photo des vis.
ce sont des vis INA
Ci joint la photo du model

20210518_130217[1].jpg
 
sebastian
sebastian
Compagnon
Tous fonctionne bien simplement les moteur X et Y ronronnent un peu on dirait les douilles à billes sont grippées.
Bonjour,
il faudrait que tu précise mieux ton constat ;
• si les moteurs "ronronnent" c'est un prb de réglage des pas ou micro-pas… d'une alimentation sous dimensionnée… bref un calage électronique.
• si les douilles coincent… il faut les graisser (mais je ne vois pas de graisseurs sur ce type de patins SBR à carcasse ouverte)
mais il y a visiblement une vis de pré-contrainte / charge des patins ; il faut agir sur cette vis en la serrant petit à petit jusqu'à obtenir un glissement fluide sans jeu.
Dans le 2e cas, si tu désaccouple le moteur de la VàB, le mouvement du chariot est libre à la main ? ou ça coince qqpart ?
As-tu vérifié la parfaite géométrie de ta machine ?
 
D
Doctor_itchy
Compagnon
idem , si ta un doute tu démonte les moteur des vis tu fait tourné les moteur a vide (avec un code via le controleur pas a la mains ) si il sont silencieux (enfin juste un petit bruit de pas a pas ) c'est pas ça si il font un bruit bizzard et fort , soit trop de courant dans les bobines donc diminue le courant jusque a ce que le bruit soit moins fort , soit le driver est malade ou le moteur a moitié griller

et tourne les vis a bille a la mains sans le moteur , ça doit tourné fluide sans point dur et sans effort sur toute la course !
 

Sujets similaires

brice40516
Réponses
5
Affichages
2 395
brice40516
brice40516
Haut