modification du probe z

v tec
Compagnon
6 Janvier 2012
2 062
  • Auteur de la discussion
  • #1
bonjour voici mon code actuel de probe


POSPALPX = GETOEMDRO(1010)
POSPALPY = GETOEMDRO(1011)
VPALP = GETOEMDRO(1060)
HPALPEUR = GETOEMDRO(1040)
HSURFACE = GETOEMDRO(1050)
NOUVEAUZ = HPALPEUR-HSURFACE
HSECU = GETOEMDRO(1051)
Code"g00 g53 z-5"
While ismoving()
sleep(100)
Wend
REFCOMBINATION(4)
While ismoving()
sleep(100)
Wend
Code"g00 g53 x-5 y-5"
While ismoving()
sleep(100)
Wend
REFCOMBINATION(8)
While ismoving()
sleep(100)
Wend
REFCOMBINATION(2)
While ismoving()
sleep(100)
Wend
Code"g00 g53 x-5 y-5"
REFCOMBINATION(1)
While ismoving()
sleep(100)
Wend
CODE "G00 G53 Z"& HSECU
While ISMOVING()
Wend
CODE "G00 G53 X"& POSPALPX &" Y"& POSPALPY
While ISMOVING()
Wend
CODE "G00 G53 Z"& HSECU
CODE "G31 Z-200 F"& VPALP
While ISMOVING()
Wend
SLEEP(250)
ZPALP2 = GETVAR(2002)
SLEEP(250)
CODE "G01 Z"& ZPALP2 & "f" & VPALP
While ISMOVING()
sleep(100)
Wend
ZMACHPALP=getoemdro(85)
While ISMOVING()
sleep(100)
Wend
SETOEMDRO(802,NOUVEAUZ)
SLEEP(250)
CODE "G00g53 Z" & hsecu
While ISMOVING()
Wend
CODE "g00g53x-250y-250"
While ISMOVING()
Wend
setoemdro(158,zmachpalp-getoemdro(1040)-0.1)
domenu(1,5)
While ISMOVING()
Wend
Exit Sub



j'aimerais que apres le referencement de x et y, l'axe parte en coordonnées -5 pour vraiment se degager du capteur


mais je n y arrive pas, il ne tient pas compte des lignes
 
v tec
Compagnon
6 Janvier 2012
2 062
  • Auteur de la discussion
  • #6
à non là c etait sur ma fraiseuse, lors du degagement de l axe il devait être trop limite, et parfois il me fesait pas les axes suivants


mon robot qui tournait avec mach3, fait dodo depuis un moment, je l'ai remplacé par une vrai etiquetteuse lineaire
 
v tec
Compagnon
6 Janvier 2012
2 062
  • Auteur de la discussion
  • #7
mais j'ai aussi depuis fabriquer une machine complete, qui dose, met une pompe,et vis la pompe

on va la tester à la rentrée
 
dh42
Compagnon
4 Septembre 2009
5 269
Près de St Etienne (42)
Salut,

à non là c etait sur ma fraiseuse, lors du degagement de l axe il devait être trop limite, et parfois il me fesait pas les axes suivants
Dans Mach3, je n'ai jamais trouvé une option qui permettrait de définir de combien reculer après le homing. Je viens par contre d'installer un SmoothStepper et lui par contre, il a cette option dans ses réglages. (on peut même définir séparément vitesse d'approche et vitesse de retour après homing)

note aussi que si tu utilise la dernière version de Mach3 (3.043.066) il y a un certains nombres de bug connus, et justement avec le homing (mais également la pause et les macros ... des macros qui fonctionnent parfaitement sur toutes les versions de mach, plante sur la 066)

sur le site de Warp9 (le fabricant du smoothstepper) ils disent qu'avant toutes chose il faut installer la version précédente (3.043.062) car la dernière est trop buguée.

++
David
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut