ELEKSMAKER A3-Pro 2.5W comment lancé ma premiere gravure ? ? ?

  • Auteur de la discussion LOMA
  • Date de début
L
LOMA
Nouveau
11 Avr 2019
8
  • Auteur de la discussion
  • #1
Bonjour à Tous,
je viens de faire l'acquisition d'une ELEKSMAKER A3-Pro 2.5W;
elle est montée.
j'ai téléchargé le logiciel "CAM V3.1" pour faire qqs essais...
et là les premières incompréhensions arrivent.
- Ouverture du port série = Ok
- Déplacement droit, gauche, haut, bas en utilisant les bt => Ok
- j'ouvre une image simple ( pentagone)
- je click sur "Start" .... j'ai tout les gcodes qui s'affichent mais rien qui bouge physiquement ..
qu'est ce que j'ai loupé ? ?

Je sias que ce logiciel n'est pas top, mais la premiere étape, c'est de valider le fonctionnement de ma machine

Par avance, merci ! !
Olivier..

screenshot.jpg
 
0
01power
Ouvrier
24 Sept 2017
321
01600
Salut,

Si tu arrives a piloté ta machine avec des commandes déplacement et allumage du laser, mais que quand tu envoies un élément il se passe rien, c'est a 90% le logiciel actuel

personnellement j'utilise : lite fire "engraver master" l'éditeur est diy8000
La je suis suis sur mon tél et j'ai pas le lien dans mon sujet sur le sel je recherchais justement un logiciel. C'EST un logiciel moins polyvalent et moins d'édition possible mais plus de contrôle de conversion éléments vers gcode
Et tu peux importé pas mal de format, importé un gcode et tout exporté en gcode(d'autres ne le font pas, ils ne font que l'envoi vers ta graveuse)

Par contre soit j'ai pas trouvé soit il n'y a pas de possibilité d'ajouter des macro pré et post gravure, donc obligé d'exporter en gcode, édité avec un notepad ( ou équivalent) dans les fichiers gcode avant de le réimporter

Si non il y a ugs (Universal gcode sender) il gère les macro mais pas ou peu de fonctions type conversion vers gcode, on nécessite java mais également très stable
 
L
LOMA
Nouveau
11 Avr 2019
8
  • Auteur de la discussion
  • #3
Merci pour toues ses infos. je vais regarder ça...
 
L
LOMA
Nouveau
11 Avr 2019
8
  • Auteur de la discussion
  • #4
Rebonjour

j'ai testé "engraver master" et c'est pour l'instant le plus fonctionnel ( on vois souvent parler de BenBox, mais le laser ne s'allume pas )
par contre sur "engraver master" ( a partir d'un DXF généré par Solidworks) lorsque je fait une répétition d'impression, il y a bien une répétition, mais décalée ( pas sur le m^me tracée) et pas toujours en X defois en Y. c'est pas tres clair.
Je continue mes recherches..
merci
 
0
01power
Ouvrier
24 Sept 2017
321
01600
Pour ton problème de répétabilité, (décalage) c'est un problème non logiciel

C'est soit les drivers qui sont réglés trop faible,
soit les courois sont mal tendu
Soit tes chariot ont trop de jeu entre roues et rails

PS avec ma nouvelle structure j'ai une répétabilité parfaite , testé sur 20 cycles
 
L
LOMA
Nouveau
11 Avr 2019
8
  • Auteur de la discussion
  • #6
Merci, mais je pense pas que ca soit mecanique.. c est pas un petit decalage, c est carrément la piece qui est refaite a cote. De 20mm a 100m a côté (ou au dessus) tu utilises quoi comme soft utilitaire ?
Merci
 
Dernière édition:
0
01power
Ouvrier
24 Sept 2017
321
01600
Salut, en quel format importé tu dans engraver master

Personnellement, j'importe en dxf réaliser sur inkscape puis je l'exporte en .NC affin de pouvoir ajouter des commandes début et fin du gcode (surtout les commandes M8 et M9)

Et ça me permet de contrôler qu'en fin de gcode j'ai les lignes
M5
G1 X0 Y0
C'est le retour au point d'origine de ta gravure

Dans la section gcode j'ai créé un sujet sur un site "NCweaver" de mémoire, ça te permet de corriger ton gcode avec un apperçus très rapide
Tu clique sur une ligne du code tu vois la correspondance, et inversement
Perso c'est incontournable car il manque des segments en convertissant les dxf
 
0
01power
Ouvrier
24 Sept 2017
321
01600
Je te donnerai un test de calibration en .NC ce soir, il est fiable a 100%, et facile a mesuré pour vérifier les proportions et l'équerrage
 
L
LOMA
Nouveau
11 Avr 2019
8
  • Auteur de la discussion
  • #9
Bonjour, Déja, merci de suivre et de m'aider.
J'importe un fichier DXF ( un rectangle de 90x20mm) fraichement créé avec solidWorks.
- Quand je clique sur 'start' le rectangle est bien tracé..
- Quand je reclique sur 'start' le rectangle est bien tracé et par dessus le premier. ==> logique

- maintenant, dan sle champs repeats je mets '2' :
- le premier se trace normalement et le deuxieme se décale de 10 mm au moins

j'ai enregistré le gcode de repeat_1 et repeat_2 se sont exactement les m^me !
ce qui me semble logique c'est bien "engraver master " qui lance deux fois le gerber.
( a croire qu 'il lance le second trop vite...)

Voici le gcode généré :

;Export By diy8000.taobao.com
S400
G0 F2010
M5
G92 X0 Y0
G21
G90
M5
G0 F2010
S1000
M5
G0 X90.0000 Y0.0000
M3
G1 X0.0000 Y0.0000
G1 X0.0000 Y20.0000
G1 X90.0000 Y20.0000
G1 X90.0000 Y0.0000
M5
G0 X0 Y0


TIENS DONC ! !
la derniere ligne c'est G0 et non G1 ?
Par avance merci.
 
0
01power
Ouvrier
24 Sept 2017
321
01600
Je ne sais pas a quoi correspond G0
Pour moi c'est un déplacement donc ça devrait être G1

G92 (identifiie la position actuelle comme étant l'origine)
S (vitesse ou dans notre cas la puissance du laser)
F c'est la(vitesse de déplacement)

Ce qui est le plus étrange du fais que c'est un rectangle, c'est qu'il débute pas par ta position d'origine (x0 y0)

il permet de testé rapidement équerrage entre les axes X et Y, à l'origine je l'ai fais 5 fois plus gros, car plus c'est gros, plus on peu faire un réglage fin, mais, ça reviens au même, la diagonal doit faire 50mm pour ce test

Et mon g code

S500
G0 F2000
M05
G92 X0 Y0 Z0
G21
G90
M3
G1 X30 Y0
G1 X30 Y40
G1 X0 Y40
G1 X0 Y0
G1 X30 Y40
M5
G1 X30 Y0
M3
G1 X0 Y40
M5
M05
G1 X0 Y0

edit G0 est un mouvement rapide et G1 un mouvement linéaire

le lien vers tou les Gcode
https://reprap.org/wiki/G-code/fr
 
L
LOMA
Nouveau
11 Avr 2019
8
  • Auteur de la discussion
  • #11
Apres 1h de recherche j'ai trouvé une solution...
Comme tu l'as remarqué c'est "particulier de déplacer la tête avant de commencer ! , mais ca je n'y peut rien c'est pas moi qui génére le gCode..
mais m^me avec cette particularité les boucles devrait fonctionner..
Et ben non car la dernière ligne
"G0 X0 Y0", n'est pas interprétés par la machine. donc le laser s'aretait à la derniere position.
et au cycle suivant c'est décalé.....

pour corrigé le pb je replace par
G1 X0.0000 Y0.0000
el la je peux générer x passage ca découpe !
( 10 passages à 80% dans du balsa de 4mm)
Merci !
 
Dernière édition:
0
01power
Ouvrier
24 Sept 2017
321
01600
Je ne m'attendais pas à ça pour solutionner
 
Gand'
Gand'
Apprenti
22 Mai 2016
90
Vercors
Avec ma machine et LASERWeb4, j'utilise

G0 X0Y0

pour faire le homing, et ça fonctionne très bien ! (Mais encore une fois, le soft d'Eleksmaker n'a pas très bonne presse)
 
0
01power
Ouvrier
24 Sept 2017
321
01600
Avez vous mis a jour les firmware grbl sur vos arduino ?
 
L
LOMA
Nouveau
11 Avr 2019
8
  • Auteur de la discussion
  • #15
Avez vous mis a jour les firmware grbl sur vos arduino ?
Suite à l'impossibilité d'utiliser le soft "CAM V3.1" j'ai suivi les conseils d'utiliser Bembox, pour cela il a fallu maj le Firmware de la machine.
- puis avec Bembox, j'ai aussi eu des pb le pilotage du LASER ne fonctionnais pas ! !

"01power m'a conseillé d'utiliser "engraver master " j'ai du remetre a jour le FirmWare , par contre de quelle version s'agit il ???? on en trouve un peut partout, mais on ne sais pas quel est cellui à utiliser.

si t'as un lien je suis preneur !

merci
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut