Choix du réglage des switchs des Drivers HSS86

  • Auteur de la discussion Charly85
  • Date de début
C

Charly85

Nouveau
Bonjour je vous sollicites car je cherche à comprendre le réglage optimum des switchs de mes cartes HSS86 (boucle fermée).
Actuellement ils sont en réglage par défaut soit 400 microsteps.
Est-ce que si j'augmente cette valeur je vais avoir une meilleur précision?
Y a t-il une concordance entre les microsteps et les valeurs 1/4, 1/8..... ?

1658131046154.png

1658131164334.png



Je suis à reprendre mes réglages moteurs dans Mach3.

Ci dessous les réglages générés avec la calibration automatique des axes. Ils sont déconnant.....
Il met impossible de modifier les valeurs en Steps, Velocity .....
1658130532941.png

1658130711153.png


En lisant sur le forum j'ai vu qu'il pouvait y avoir un verrouillage. Je ne vois rien la dessus sur mon soft mach3.
Lorsque je rentre une nouvelle valeur et fait ENTRER il efface ma valeur pour la remplacer par 0.
J'ai tester de rentrer les valeurs et de passer de cases en cases avec la TABULATION, la les valeurs sont tjrs inscrites mais los de l'appui sur ENTRER il refait le même changement en y indiquant 0.
J'ai essayé en changeant la screen mais toujours le même résultat.

Avez-vous déjà eu ce problème?
 
B

Boris_25

Ouvrier
Pour les drivers HSS86, normalement tu as plusieurs possibilités, multiples de 200 ou multiples de 1000. Perso j'utilise les multiples de 1000.
Tout dépend du pas de ta vis?
La notion de vitesse entre aussi en ligne de compte, plus le pas est petits, plus il faut de puls, donc une fréquence importante!
Un réglage à 800 est souvent largement suffisant.
 
Squal112

Squal112

Ouvrier
Bonjour @Charly85

Tout cela se calcul pour les paramètres d'axes dans Mach3.
Tu peux également utiliser le paramétrage automatique des axes (un simple comparateur fixé sur la table et c'est gagné).

En augmentant le nombre de micro pas, tu augmente la résolution des tes axes.
La précision elle est surtout liée à la mécanique de tes axes (vis trap, à billes, glissières, moteurs...) et de ta machine.
Voici 2 fichiers qui te permettrons de mieux comprendre et de paramétrer correctement tes drives et ton Mach3.

Le fichier StepperCalc de ALENZ te permettra de bien cerner la différence de résolution entre le choix de tel ou tel réglages de micro pas.
Quand au Max Step Frequency, il est indispensable pour bien régler la fréquence de ton controlleur Mach3 afin que les tu ne perde pas d'impulsions de commande à haute vitesse.
 

Fichiers joints

  • Max Step Frequency.xlsx
    11.9 KB · Affichages: 8
  • StepperCalc_ALENZ_rev1.xls
    32.5 KB · Affichages: 8
dh42

dh42

Compagnon
Salut,
Lorsque je rentre une nouvelle valeur et fait ENTRER il efface ma valeur pour la remplacer par 0.

Ça me fait la même chose si je tente de faire les réglages moteur alors que la machine n'est pas connectée (controleur en Ethernet)

++
David
 
C

Charly85

Nouveau
Bonjour Merci de votre retour,

J'ai fait le test connecté et non connecté et le résultat reste le même.
Je vais relancer l'installation du soft.

Merci à vous.
 
C

Charly85

Nouveau
Bonsoir,

Mon axe X et Z sont sur des moteurs PAS à PAS Hybride.
l'axe X: Carte HSS86 et Moteur 86HSE4N-BC38
l'axe Z: Carte HSS57 et Moteur 57HSE2N-D25

Mon axe Y est avec servomoteur
Marque AXOR ref: SAX-130-L-3.20/24-XX-04-PP-00
Codeur ELTRA ref: EH30M500S5N6X3PR1
Carte GECKODRIVE ref: G320X

Mes vis à bille ont un pas de 5mm.

Merci,
 
dh42

dh42

Compagnon
tu parles des moteurs, des drivers de puissance (HSS... et G320X), mais pas de la carte d'axe, autrement dit de la carte de commande, ce qui est connecté au PC en USB ou Ethernet, donc entre le PC et les drivers.

++
David
 
C

Charly85

Nouveau
Lol, erreur de compréhension, désolé.
La carte est une carte USB
1658432661862.png
Une carte pour débuter.
 
dh42

dh42

Compagnon
Ok, c'est une Bitsensor Rnr 2.0 .... en principe ça ne pose pas de problème particulier à l'insta ; tu as bien mis le plugin de la carte dans le dossier Plugins de mach3 ? ... la carte est-elle bien reconnue ?

++
David
 
C

Charly85

Nouveau
Bonjour,
Oui la carte fonctionnait correctement avant mais en voulant modifier mes réglages moteurs je me suis aperçu qu'il mettait impossible d’entrer de nouvelles valeurs.
Après avoir cherché et testé différentes choses j'ai refait l'installation complète.
Pour le plantage je m'interroge s'il n'a pas été généré par une auto-calibration des axes. Au moment du changement de steps. A voir si le soft me refait ceci dans le temps.

Remarque pour cette carte: Défaut de parasites au moment de mettre le VFD en marche, mais défaut intermittent.

J'ai isolé ma carte de mon châssis d'armoire en mettant des entretoises et de la visserie nylon. Ceci pour séparer le GND de mon 24V DC et celui de mon VFD.
Lorsque ceux-ci étaient regroupés des interférences stoppaient ma carte.
Pour séparer mes GND j'ai dû intégrer un relais en plus pour le pilotage de mon VFD. Ainsi le GND de ma carte de pilotage Bitsensor, pilote mon relais extérieur et une fois celui-ci fermé il autorise la mise en marche de mon VFD avec son propre signal généré.

Depuis cette modification plus aucun plantage.
 

Sujets similaires

Haut