1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

panne visulesta 2

Discussion dans 'Heidenhain' créé par anfassen, 18 Septembre 2011.

  1. anfassen

    anfassen Nouveau

    Messages:
    19
    Inscrit:
    17 Septembre 2011
    Localité:
    Nord du Loiret
    panne visulesta 2
    Bonjour,
    Pouvez vous m'aider.J'ai changé la pile sauvegarde.maintenant je peux lire le déplacement de la régle que dans un sens.En sens contraire,rien n'est corrigé".peut être un paramètre mal rentré.Merci de votre aide.
     
  2. topal2003

    topal2003 Ouvrier

    Messages:
    408
    Inscrit:
    3 Octobre 2008
    Localité:
    NIEVRE 58
    panne visulesta 2
    Salut,

    si tu fait

    P701P et enter

    il se passe quoi ?

    as tu donne la bonne resolution de tes regle en P971

    qu'as tu mis en P974 ?

    PAT
     
  3. anfassen

    anfassen Nouveau

    Messages:
    19
    Inscrit:
    17 Septembre 2011
    Localité:
    Nord du Loiret
    panne visulesta 2
    BONjour,

    Merci pour votre réponse,c'est gentil.Oui, j'ai bien fait attention de réinitialiser avec le paramétre P701.ce qui m'a supprimé le message E4.Maintenant tout s'affiche correctement.Les autres paramétres et particulièrement le P974 sont OK.Je les ai vérifié avec une personne du forum,qui a le même appareil.(Grand merci à lui).
    Le problême est toujours que je mesure que dans un sens de la régle.l'autre sens n'agit nullement.je pense que la panne est hardware.Je cherche certains composants à changer,Z80 CTC ou peut être P8254.Je sais, c'est un vieil appareil, mais il était trés précis et pratique.
    salutations à vous.
     
  4. topal2003

    topal2003 Ouvrier

    Messages:
    408
    Inscrit:
    3 Octobre 2008
    Localité:
    NIEVRE 58
    panne visulesta 2
    Salut,

    pourquoi changer le Z80 (ton processeur),il n'est pas en cause c'est sur, quand au PIA je suis pas sur non plus que une fois changé ton appareil fonctionne

    tu as changer les accus car ils etaient hs, mais avant ta visu fonctionnée ?

    si tu compte les pieces ci-dessus ne sont pas hs, mais c'est les meme pieces qui te servent au decompte, je penche plus pour un probleme de soft

    ta bien le bon type de regles de memorise, tes sur ?

    PAT
     
  5. anfassen

    anfassen Nouveau

    Messages:
    19
    Inscrit:
    17 Septembre 2011
    Localité:
    Nord du Loiret
    panne visulesta 2
    Bonjour Topal,
    C'est gentil de me répondre.Les régles sont les mêmes,rien de changé.Avant que la pile soit changée,j'avais ce problême.Compte corectement,dans un sens,mais ne décompte pas dans l'autre.le soft est sur Eprom.Cela me parait peut probable.
    Je ne change pas le µprocesseur,mais seulement le CTC,counter timer circuit.(family du standard Z80,le fameux 8 bits des années 80).Je pense sincérement à une panne hard.
    De toute façon ,j'ai tout essayé, j'attends ces CI...Il faut les trouver...
    Merci encore,si vous pouvez m'apporter quelques lumiéres.
    @+
     
  6. topal2003

    topal2003 Ouvrier

    Messages:
    408
    Inscrit:
    3 Octobre 2008
    Localité:
    NIEVRE 58
    panne visulesta 2
    Salut,

    les donnees en eprom ne sont pas garantie a vie, il ne faut pas l'oublier, de plus il suffit qu'une perturbation exterieur plus importante qu'a l'abitude (parasite sur la ligne de donees) et ca suffit a changer d'un bit de donnee pour changer le soft, meme si sur ce genre d'eprom il faut une tension de programmation entre 24 et 27 volt si je me rappel bien

    tu as raison de toute facon si tu as tout fait de taper dans le hard, mais comme ca as tu regarde les signaux A et B qui entre sur le timer, rien que pour voir si tu as bien des deux signaux dephasé

    tu peu faire une photo de l'interieur ?

    tu est vraiment sur du parametre 974 ?

    PAT
     
  7. anfassen

    anfassen Nouveau

    Messages:
    19
    Inscrit:
    17 Septembre 2011
    Localité:
    Nord du Loiret
    panne visulesta 2
    Bonjour Topal,

    Je confirme,aprés avoir changé ces deux Circuits Z80 CTC et 8254,tour revient dans l'autre.Mes régles mesurent bien correctement dans les deux sens.Le seul problême constaté et malgré le changement de la pile est la perte des paramétres.
    pourquoi...cependant,cela se produit assez rarement,peut être une fois sur 10.Alors je re-rentre P971 et 974.
    Merci encore de votre aide.
    @+
     
Chargement...
Articles en relation
  1. damy
    Réponses:
    4
    Affichages:
    377
  2. damy
    Réponses:
    6
    Affichages:
    1 049
  3. CBZ911
    Réponses:
    6
    Affichages:
    991
  4. Y2J0304
    Réponses:
    2
    Affichages:
    1 178

Partager cette page