station soudage WTCP-S Weller - le fer ne régule plus

  • Auteur de la discussion Claudy56
  • Date de début
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #1
bonjour,
Je profite de l'occasion pour vous souhaiter une super année 2013 !
Voici mon problème: je viens d'acquérir une station Weller WTCP-S, une des meilleures (du vieux mais de bon :) )à ce que j'ai pu lire sur le sujet (occasion sur le boncoin). Je viens de l'essayer. Le fer chauffe au rouge :mad: et impossible de faire coller la soudure sur la panne. La panne (d'origine) me semble en (très) mauvais état. J'ai lu la documentation sur le sujet et le système Magnastat propre à Weller assure la régulation. Ce type de régulation serait fortement tributaire de la qualité de la panne.
Questions: la panne peut elle être la seula cause du problème ? Dans la la négative, que dois-je vérifier ? Le fer ayant surchauffé, cela a-t-il pu occasionner d'autres dégâts à vérifier ? Où puis-je trouver les pièces de rechange (nb: j'habite en Belgique) ?
Merci pour votre aide,
Claudy
http://img845.imageshack.us/img845/2069/newimgp8184.jpg
 
Dernière édition par un modérateur:
B
Barbidou
Compagnon
1 Nov 2012
605
Yvelines
Tu peux trouver des pièces de rechange Weller chez Radiospares...

A priori, Tu as de bonnes chances pour qu'une panne neuve arrange le problème, ces pannes comportent un capteur de température qui sert à la régulation. Si la panne est morte, le fer ne régule plus et peut alors chauffer sans limitation.

Reste à savoir si le fer a résisté à la surchauffe et qu démontage que tu lui a fait subir.

Nicolas
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #3
Merci pour ta réponse. En observant bien la pointe de la panne, j'ai l'impression que le fer a dû tomber car l'extrémité de la panne est déformée et cela m'étonnerait que cette déformation soit d'origine. Pour le démontage du fer, je l'ai fait avec précaution mais c'est un démontage... Toutes les soudures ont l'air en bon état et il n'y a pas de dégâts apparents (pas de traces de brûlure sur les composants et les connexions).
Le capteur se trouve-t-il dans la panne ou est-ce la composition même de la panne qui permet la régulation de température.
Ce que je peux dire suite au démontage, à part le fait qu'il n'y a pas de dégâts apparents : l'aimant permanent est toujours opérationnel, la partie en contact avec la panne coulisse bien dans le fourreau, la partie en contact avec la panne n'a pas l'air oxydée, le ressort n'est pas cassé, il y a un condensateur qui a l'air extérieurement en bon état mais je ne sais pas comment le tester.
A+
 
M
moissan
Compagnon
13 Mar 2012
11 794
FR-16 angouleme
je ne connais pas par coeur les reference weller

leur systeme classique etait une pastille de matiere dans la panne ayant un point de curie a la temperature de regulation ... quand c'est trop froid l'aimant mobile est attiré ... quand c'est trop chaud l'aimant mobile revient

donc pour changer de temperature il faut changer de panne

mais weller fait aussi des fer avec thermostat electronique , donc panne sans pastille a temperature de curie ... si on monte une panne pour thermostat electronique sur un fer a aimant ça ne chauffe jamais
 
Jope004
Jope004
Compagnon
15 Fev 2010
1 553
FR-95 Marines
moissan a dit:
je ne connais pas par coeur les reference weller

leur systeme classique etait une pastille de matiere dans la panne ayant un point de curie a la temperature de regulation ... quand c'est trop froid l'aimant mobile est attiré ... quand c'est trop chaud l'aimant mobile revient

donc pour changer de temperature il faut changer de panne

mais weller fait aussi des fer avec thermostat electronique , donc panne sans pastille a temperature de curie ... si on monte une panne pour thermostat electronique sur un fer a aimant ça ne chauffe jamais
Bonjour,
Il y a deux systèmes de régulation sur ces postes Weller.
Certain font appel à une pastille calibrée en température à l'arrière de la panne. La température de régulation est alors fixe et le socle ne comporte pas de réglage.
D'autres font appel à une vraie sonde de température dans le fer, et il y a un réglage sur le socle.
Voir ici un avis sur cette panne : http://www.abcelectronique.com/forum/showthread.php?t=73460
 
Dernière édition par un modérateur:
f6bqi
f6bqi
Compagnon
26 Sept 2008
821
FR-81150
Bonsoir,
Un test simple:
on dévisse le tube de maintien de la panne.
en essayant de sortir ou de rentrer la panne de son logement, on doit sentir une légère attraction de l'aimant.
sur le fond de la panne, doit être inscrit un chiffre qui correspond à la température de régulation (normalement 7)
Si l'on tente de faire coller un petit morceau de métal avec le fond de la panne, il se passe rien (normal).

Le circuit électrique de ce modèle est extrêmement simple.
Circuit primaire: le secteur, 1 inter, 1 fusible et le primaire du transfo (le tout en série).
Circuit secondaire: le 24V ~ 1 fil sur la résistance chauffante le retour sur le "Magnastat" (l'inter piloté par la panne)
le 2 eme fil du "Magnastat " retourne sur le fil restant du transfo. Le condo est un antiparasite en // sur le contact du"Magnastat".
Pour vérifier celui ci, le contact est visible sous son petit capot transparent (contact fermé à froid et en présence de la panne).
Vérifier le fonctionnement avec un Ohmmètre.
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #7
bonsoir,
sur base de vos conseils et en relisant le principe du Magnastat, je me suis dit que si je retire la panne et que j'appuie sur la partie en contact avec la panne (extrémité de l'aimant), le switch devrait se couper - même effet que la répulsion de l'aimant qui provoque la coupure du circuit d'alimentation de la résistance.
J'ai procédé au test et le fer chauffe toujours aussi fort. Pas de bol donc, puisque le problème se situerait au niveau du switch et à mon avis, c'est pas donné... :cry:

Par contre, sur le forum dont le lien a été fourni par Jope004, on parle aussi de la possibilité d'avoir le condensateur HS. Comment le tester ? Si ce n'est qu'un anti-parasites, il ne devrait pas influencer le fonctionnement du switch (?). J'ai mesuré la résistance entre les bornes du condensateur et il est en court circuit (conductivité Max.) :?:

J'ai poursuivi mes tests en retirant le fourreau et en faisant faire un mouvement court de va et vient à la panne, quand la panne quitte l'aimant, j'entends un cliquetis au niveau du switch et en y regardant bien, je vois un mouvement au centre du switch. Il ne serait donc pas collé et fonctionnerait apparemment correctement. J'ai mesuré la résistance entre les bornes du swtich et elle varie de 1.3 ohms (circuit fermé, la panne est en contact avec l'aimant) à 2.6 ohms (contact ouvert, la panne quitte l'aimant).
Je penche donc pour le condo défectueux mais ma mesure est-elle adaptée (mesure de résistance entre les bornes) ?
Merci pour votre aide,
Claudy
 
Jope004
Jope004
Compagnon
15 Fev 2010
1 553
FR-95 Marines
Claudy56 a dit:
bonsoir,
sur base de vos conseils et en relisant le principe du Magnastat, je me suis dit que si je retire la panne et que j'appuie sur la partie en contact avec la panne (extrémité de l'aimant), le switch devrait se couper - même effet que la répulsion de l'aimant qui provoque la coupure du circuit d'alimentation de la résistance.
J'ai procédé au test et le fer chauffe toujours aussi fort. Pas de bol donc, puisque le problème se situerait au niveau du switch et à mon avis, c'est pas donné... :cry:

Par contre, sur le forum dont le lien a été fourni par Jope004, on parle aussi de la possibilité d'avoir le condensateur HS. Comment le tester ? Si ce n'est qu'un anti-parasites, il ne devrait pas influencer le fonctionnement du switch (?). J'ai mesuré la résistance entre les bornes du condensateur et il est en court circuit (conductivité Max.) :?:

J'ai poursuivi mes tests en retirant le fourreau et en faisant faire un mouvement court de va et vient à la panne, quand la panne quitte l'aimant, j'entends un cliquetis au niveau du switch et en y regardant bien, je vois un mouvement au centre du switch. Il ne serait donc pas collé et fonctionnerait apparemment correctement. J'ai mesuré la résistance entre les bornes du swtich et elle varie de 1.3 ohms (circuit fermé, la panne est en contact avec l'aimant) à 2.6 ohms (contact ouvert, la panne quitte l'aimant).
Je penche donc pour le condo défectueux mais ma mesure est-elle adaptée (mesure de résistance entre les bornes) ?
Merci pour votre aide,
Claudy
Bonsoir,
Si vous avez mesuré au niveau du connecteur, fer débranché du socle, la mesure me parait valable. Je trouve juste curieux les deux valeurs mesurées : 1.3 et 2.6 ohms. Le condensateur serait en court-circuit !
En fait, je n'avais jamais vu de condensateur HS dont la résistance soit aussi faible (qq ohms).
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #9
J'ai fait la mesure au niveau des bornes du fil de la résistance dont le circuit est ouvert/fermé par le switch (fil rouge, demain je posterai une photo plus nette). La résistance mesurée entre les bornes du condensateur est pratiquement nulle (!). Si je mets la position buzzer sur mon multimètre, j'entends le sifflement.
merci pour vos réponses,
A+
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
821
FR-81150
Couper une patte du condo et refaire un essai. pour moi le condo est HS.
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #11
bonsoir,
j'ai coupé la patte du condo. Il n'est pas en court circuit. Il n'est donc pas responsable du problème. C'est déjà ça.

Partant de cette constatation, j'ai regardé d'un peu plus près le switch (très près même car pas évident, à la loupe à vrai dire !). La partie centrale est mobile et provoque un cliquetis qui donne à penser que le switch est OK .Cependant, cette partie centrale doit entraîner une barrette (assez flexible) qui a à ses extrémités les contacts et là, à mon avis, les contacts sont collés (pas de mouvement aux extrémités). J'ai mesuré les résistances aux bornes mêmes du switch et je n'ai pas de coupure de circuit quand la panne est écartée de l'aimant.
Comment parvenir à décoller ces contacts. Tout parait scellé... Je crois que je suis finalement bon pour un remplacement, si j'en trouve en pièce de rechange...
Votre avis ?
A+
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #13
bonsoir,
qu'entendez-vous par "contrôle sur la table". En fait je confirme que les contacts ne sont pas libérés en l'absence de la panne. il y a un mouvement dans l'axe mais la lame comprenant les contacts ne bouge aux extrémités.
Je pensais effectivement forer 2 trous au regard des contacts et commencer par injecter un nettoyant de contact en spray, laisser agir et puis essayer de décoller les contacts mais ce ne sera pas évident du tout.
Avez-vous "sauvé" votre swtich ? A quoi dois-je particulièrement faire attention. Je suppose que la désolidarisation des contacts n'est pas aisée du tout, on doit déformer la lame et à partir de là, le switch ne fonctionne plus ou n'est plus fiable.
Merci pour le tuyau Farnell. Ce n'est pas donné. J'ai payé la station 70 euros avec les frais de port, je vais devoir remettre au moins la moitié car la panne est à remplacer... :mad:
nb: je ne comprends pas pourquoi le switch est "enfermé" de la sorte, protection contre la chaleur ? A moins que ce soit le maillon faible de l'appareil, ce qui permet à Weller d'assurer un certain chiffre d'affaire avec les pièces détachées...
A+
 
F
f6tem
Compagnon
16 Fev 2011
629
Bsr
tu peux trouver ces pièces détachées également chez Selectronic.fr
le magnastat était la référence pro pour les labos avant la version avec sonde de température intégrée à la panne, bonne fiabilité. comme l'a indiqué Michel 6BQI le chiffre frappé à l'arrière de la panne (6,7,8) définit la température d'opération. Les composants à montage de surface ont réclamé, après les années 1980, une régulation plus souple et plus précise avec sonde intégrée et réglage continu de T.
La fiabilité du magnastat est vraiment bonne mais si le fer a été utilisé tous les jours pendant 8h, les contacts finalement se collent et la réparation est quasi impossible par disparition de surface de contact. Ce qu'indiquerait aussi l'étât de la panne, bouffée par l'additif soudure. le condensateur est là juste pour amortir l'appel de courant à l'enclenchement de la régulation par effet Curie.
mauvaise pioche apparemment... Cdlt jacques
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
821
FR-81150
Bjr 6tem

Sur table, veut dire démonter l’élément "Magnastat" en le dissociant de l'élément chauffant et vérifier en rapprochant la panne que le contact s’effectue correctement.
Pour récupérer les contacts, il faut y aller doucement pour les décoller et ensuite les polir en espérant que les cratères ne sont pas trop importants.
Ici le Weller est utilisé régulièrement depuis 35 ans mais pas comme au pro ou c’était 8H/jour.
La panne DOIT être maintenue propre et étamée. L'éponge est indispensable .Il ne faut surtout pas la limer ou la gratter
Remettre ce fer en état est un investissement sur le long terme.
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #16
bonjour,
merci pour votre aide. Je vais essayer de récupérer le switch. Si pas possible, j'investirai. Je vous tiendrai au courant.
A+
 
A
Artagnant
Nouveau
15 Nov 2016
4
Bonjour

Je viens de lire par hasard ce sujet et pour ceux qui utilise ce fer et qui sont confronté à genre de problème (qui coute cher à chaque fois qu'il faut changer le switch!) j'ai développé une solution qui garantie la presque inusabilité du switch.
Il s'agit d'une petite carte relais que l'on place dans le boitier du fer et d'un fil (en silicone pour résister a la chaleur) à rajouter entre le fer et le boitier.

Pour ceux que cela peut intéresser contactez moi et je vous communiquerais le schéma et les infos pour la réalistion et gratuitement cela va sans dire!!

Cordialement
Artagnant
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #18
bonjour Artagnant,
très curieusement le fer est resté en l'état depuis tout ce temps (qui passe trop vite !). Je n'ai donc pas fait de frais depuis. De ce fait, ta solution m'intéresse !
nb: faut-il quand même remplacé le switch avant de faire la modification ?
Merci pour ton aide !
Claudy,
 
A
Artagnant
Nouveau
15 Nov 2016
4
Bonsoir Claudy


Je ne pensais pas avoir une demande si rapide mais tant mieux!!
Il faut changer le switch s'il est HS c'est indispensable car il est la base du système (voir plus bas).
Le problème de ce pauvre switch c'est qu'il doit avec ces tout petits contact commuter 2A!!
Ayant eu le même pb et vu le prix de l’engin (au alentour de 45 euros) j'ai décidé de le faire seconder par un relais de puissance.
Il faut ajouter un fil et une petite carte comportant, 1 relais, 1 pont de diode, une diode et une capacité de 100nF.

Ce système fonctionne depuis des années sans soucis.
Ci joint les différents schémas fais à main levé a l'époque et une photo du dit fer, il s'agissait d'un modèle à 2 fils avec sortie sur le coté que j'ai modifié avec sortie sur prise 3 broches Socapex.
Le relais doit être un modèle 24V avec un contact travail pouvant supporter au moins 5A alternatif, s'il a plusieurs contacts on peut les mettre en parallèle.

Voila si vous avez des questions n'hésitez pas.
Nota: J'ai un switch d'occasion (qui fonctionne) que je peux vous le céder pour 15 euros port inclus en lettre avec suivie (il n'a aucune obligation!)

Cordialement
Artagnant Voir la pièce jointe Schéma Carte Relais pour Weller Magnastat.pdf
Copie de Weller Magnastat Modifié 001.jpg
 
osiver
osiver
Compagnon
7 Sept 2013
12 219
Ça m'inspire une idée d'application pour un arduino nano ou un pic.
Sans aucune modification du fer lui-même.
Le principe est le suivant. L'arduino surveille, par exemple 10 fois par seconde, la résistance vue par les fils d'alimentation du fer (ou le courant en envoyant le 24V). Si le circuit est ouvert, le fer ne demande pas de chauffe. On ne lui en envoie pas. Si le switch est fermé (résistance faible) il y a demande, on envoie la tension de 24V. Dès que l'on détecte le circuit ouvert, on coupe le 24V. Déjà le switch n'a plus que la moitié du boulot, l'ouverture.
Mais comme on l'a tous constaté, le fer passe une bonne partie de son temps au repos sur son support et on entend régulièrement le "clic" du switch (10S de chauffe, 20s de refroidissement).
L'arduino peut alors calculer le temps (ou nombre de cycles de 1/10s) de chauffe et couper juste avant l'ouverture. Avec l'inertie du corps de chauffe, la chaleur atteindra la panne un peu plus tard (j'ai testé, le délai possible est d'environ 1s) et l'ouverture du switch se fera sans courant. Si 1/2s plus tard, le switch n'est pas ouvert, c'est qu'il y a de la demande (soudure en cours) le 24V est appliqué jusqu'à ouverture du switch. L'arduino est en mode apprentissage permanent. Il applique le temps de chauffe du cycle précédent moins epsilon et s'il constate que ce n'est pas assez, il l'augmente de ce qui a manqué. Le travail d'ouverture du switch est réduit de 90% au moins.
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #21
bonsoir Artagnan,
merci pour le schéma ! Je vais essayer de réaliser le circuit. Depuis le temps, j'ai sans doute perdu la main...
Le switch d'occasion m'intéresse. Je vous ai envoyé mon adresse mail en message privé (ce sera plus simple de communiquer par mail pour ce genre d'échange).
Pour les frais d'envoi: attention, j'habite en Belgique mais j'ai une solution pour limiter les frais d'envoi.
Cordialement,
Claudy,
 
D
ducran lapoigne
Compagnon
6 Mar 2010
519
belgique (du sud)
plus simple: un schéma tiré d' une revue d' électronique

weller10.jpg
 
C
Claudy56
Apprenti
27 Fev 2010
188
Huissignies - Belgique
  • Auteur de la discussion
  • #23
Un tout grand merci pour votre aide. A tout hasard, en Belgique, quel est le meilleur moyen pour se procurer les composants ?
Cordialement,
Claudy,
 
A
Artagnant
Nouveau
15 Nov 2016
4
Cette solution à triac me parait excellente de plus elle doit pouvoir s'intégrer dans le manche du fer et s'affranchir d'un fil supplémentaire à condition que l'on puisse s'affranchir d'une self pour filtrer les parasites engendré par le triac;
On peut commencer par rajouter 100nf en série avec 100 Ohms en // sur le triac et voir si cela suffit pour s'affranchir de la self.

Artagnant
 
osiver
osiver
Compagnon
7 Sept 2013
12 219
La self de la résistance du corps de chauffe ne doit pas péter bien loin :wink:
 
A
Artagnant
Nouveau
15 Nov 2016
4
Cette solution à triac me parait excellente de plus elle doit pouvoir s'intégrer dans le manche du fer et s'affranchir d'un fil supplémentaire à condition que l'on puisse s'affranchir d'une self pour filtrer les parasites engendré par le triac;
On peut commencer par rajouter 100nf en série avec 100 Ohms en // sur le triac et voir si cela suffit pour s'affranchir de la self.

Artagnant
Bonjour

J’ai fais des essais avec le triac cela fonctionne parfaitement par compte impossible de l’intégrer dans le manche car il chauffe trop ainsi que la résistance de commande, 2 watts pour le triac en mode ON qui atteint la température de 70°C et cela à l’air libre.

Une fois tout cela enfermé dans le manche et quand le fer sera chaud j’ai bien peur que le triac rende l’âme rapidement !

Pour le triac il faut utiliser un modèle à gate sensible et augmenter la R à 560 ohms

Par compte pas besoin d’antiparasitage je n’ai rien constaté sur ma radio il est possible que la self du transfo les absorbe.

Les 2 solutions sont donc bonne

Artagnant
 
D
ducran lapoigne
Compagnon
6 Mar 2010
519
belgique (du sud)
le triac préconisé dans la revue est un TIC236 (source: elektor juillet/aout 2014)

il est dans le manche

Antoine
 
J
jungleboogy
Nouveau
20 Fev 2018
7
bonjour
j'ecris sur ce forum car a mon grand desespoir j'ai acheté d'occasion le fer wtcp-s
je l'essaye,ça marche nickel
2 semaines plus tard,je commence un vrai boulot et là,au bout de 5 mn ça chauffe plus
il est en super etat,les pannes sont neuves
je l'ai demonté et tout est super clean
quand je le demonte et que je touche un peu a tout ça remarche 5mn et ça recommence,il chauffe plus....
j'ai les boules!!!
qqun a t'il un conseil
merci
 
osiver
osiver
Compagnon
7 Sept 2013
12 219
Probablement le contact magnétique commandé par la panne magnastat. :???:
 
Haut