Probleme decrochage arrondi

  • Auteur de la discussion molotov
  • Date de début
M
molotov
Nouveau
31 Jan 2016
5
  • Auteur de la discussion
  • #1
Bonjour,

J'utilise une fraiseuse CNC Stepcraft avec une électronique arduino (Uno + cnc shield + A4988).

Pour compiler en gcode mon fichier STL j'utilise pycam et Universal Gcode sender pour envoyer vers la machine.

Tout fonctionne bien mis a part un décrochage dans les arrondis (voit photo). J'ai vérifié la machine et ne trouve pas de jeu pouvant expliauer cela. Visuellement sur pycam et Gcode Sender ces décrochages n'apparaissent pas.

mini_1601310522147220813936936.jpg

Voyez vous ce que cela peut etre?

Merci du coup de main.

Laurent
 
M
molotov
Nouveau
31 Jan 2016
5
  • Auteur de la discussion
  • #2
Bonjour,

Malheureusement ma question n'a pas l'air de déchaîner les passions.
Personne n'a jamais eu ce type de souci sur sa machine? Je précise que ce probleme n’apparaît qu'avec les arrondis (j'ai testé les ronds et les ovales c'est pareil), un décrochage qui est symétrique par rapport au centre de la pièce.
Sur les carrés et triangles aucun souci...
 
Dodore
Dodore
Compagnon
27 Oct 2008
16 318
F-69400 villefranche sur saone
C'est souvent un probleme de jeu , soit de la vis soit des supports
Sur les CN il y a des parametres à modifier, dans une certaine limite
Pour verifier ces réglages tu peux essayer de faire des tests
Par exemple tu mets un comparateur en contact avec ton chariot et tu fais un deplacement de 1mm dans le sens des + ( plus) tu regles ton comparateur a zero et tu refais un deplaçement de 1mm dans le sens - (moins)
Si ton comparateur affiche une valeur differante, c'est comme je le disais un probleme de jeu
Par contre comment il se regle ou bien comment il se parametre ... Je ne sais pas
Il me semble qu'il y a déjà eu une discution sur ce sujet
C'est ici
Je l'ai trouvé en faisant une recherche avec les mots " rond oval "
https://www.usinages.com/search/856714/?q=Rond+oval
 
Dernière édition:
fred03800
fred03800
Compagnon
19 Mai 2009
543
quel est le diamètre de ton rond ?
je vient de regarder sur Google les CNC Stepcraft, c'est du petit, les guidage x et x sont réglable, il sont réglé avec une contrainte ?
la transmission, c'est du vis à bille ou trapézoïdal ?

Déjà ça ne ressemble pas à une perte de pas!
donc les 2 autre possibilités: logiciel ou souplesse/jeu structure/transmission
 
M
molotov
Nouveau
31 Jan 2016
5
  • Auteur de la discussion
  • #5
Bonjour,

Merci de vos retours.
Le rond fait 80 de diametre. Les guidages sont trapezoidaux et sont regles avec une contrainte.
En montant une pointe d'ecriture le probleme reste le meme. De plus le decrochage ne se produit pas lors d'un changement de direction.
On voit bien les moteurs tourner pour faire ce decrochage donc je penche de plus en plus pour un probleme au niveau du logiciel.
Je vais tenter de récupérer un Gcode de rond fait sous Slic3r pour mon imprimante 3D et de l'injecter avec Gcode sender pour vérifier le résultat sur la fraiseuse.

Je vais également faire le test avec le comparateur pour écarter tout probleme mécanique.

Merci de votre aide et merci pour les liens.
 
fred03800
fred03800
Compagnon
19 Mai 2009
543
Effectivement, si tu vois tes moteurs faire les décrochements, utilise un autre logiciel pour créer tes Gcode.
Courage, encore quelque teste et tu vas y arriver.
 
E
el patenteu
Compagnon
22 Août 2010
2 246
Si tu soupconne que ca vienne du soft alors essai ceci,fais pivoter ton dessin de 90 degré et relance l'usinnage pour voir si le probleme a pivoter de 90 degré lui aussi.
 
Dodore
Dodore
Compagnon
27 Oct 2008
16 318
F-69400 villefranche sur saone
Si tu penses que c'est tout générateur de programma ou ton logiciel
Je pense qu'il est possible de faire la programmation d'un cercle en manuel pour voir ce qui se passe
 
M
molotov
Nouveau
31 Jan 2016
5
  • Auteur de la discussion
  • #9
Très bonne idée de faire pivoter la forme.
Mais pourquoi n'y ais-je pas pensé?

J'essaierai aussi le Gcode d'un rond en manuel et via un autre logicel, je serai fixé.
Je teste tout ça ce week end et je vous fais un retour.

Merci a tous.
 
E
el patenteu
Compagnon
22 Août 2010
2 246
C'est simplement parce que tu n'as pas encore assez eu de problemes avec les cnc.......inquietes toi pas,ca va venir.:lol:
 
M
molotov
Nouveau
31 Jan 2016
5
  • Auteur de la discussion
  • #11
Bonjour,

Désolé d'avoir mis aussi longtemps pour vous faire un retour. J'ai du rendre la machine a son propriétaire donc ça n'a pas facilité les tests.
Le probleme est résolu, en essayant un autre logiciel en démo j'ai refait le même défaut. Ca m'a permis de comprendre que cela venait du paramètre des arrêtes dans Pycam. En changeant pour "au plus rapide" et non plus "exact" les arrondis sont bons.

Merci de votre aide qui m'a donné de bonnes idées de tests.

@+
 
Haut