Plantage tour Somab 300 sur entrées clavier

zapa40
Nouveau
31 Juillet 2019
5
  • Auteur de la discussion
  • #1
Bonjour, j'ai un tour Somab 300 et très régulièrement quand je tape au clavier les cotes ou séquences d'usinage l'écran affiche des tas de symboles et tout est bloqué, je suis obligé de couper le courant et recommencer jusqu'à ce que ça marche des fois au 10 ème essai...
Avez vous une idée de ce que cela peut être.
j'ai nettoyé toutes les cartes et connexions rs232 mais rien n'y fait.
Sur ce tour le clavier a déjà été changé.
Merci de votre aide
 
FB29
Compagnon
1 Novembre 2013
7 771
FR-29 Brest
Bonjour,

Plantage du logiciel pour une cause matérielle puisque ça marchait avant. Le calculateur a un composant faible ... pour le trouver c'est une autre histoire ...

D'abord vérifier les tensions d'alimentation 5 V, 12 V, -12 V ... si la machine est un peu ancienne un condensateur de filtrage peut jouer des tours ... la mémoire aussi peut poser problème.

Attention aux fausses manips ! Une pointe de touche qui dérape et fait un court-circuit lors d'une mesure et c'est mort !

Photos du calculateur ?

Cordialement,
FB29
 
zapa40
Nouveau
31 Juillet 2019
5
  • Auteur de la discussion
  • #3
Merci pour ces indications mais ce n'est pas une erreur de manip car cela arrive 9/10 au moment de l'initialisation et donc avant d'avoir mis la puissance et les autres fois c'est au changement de séquence quand on utilise le clavier numérique et donc les mouvements sont arrêtés.
J'ai mis les photos de l'armoire et du pupitre ainsi que la carte process, je suppose que c'est le calculateur car c'est cette carte qui est reliée au pupitre
Cordialement

Resize of P1070600.JPG


Resize of P1070598.JPG


Resize of P1070599.JPG
 
FB29
Compagnon
1 Novembre 2013
7 771
FR-29 Brest
ce n'est pas une erreur de manip
Je faisais allusion à d'éventuelles erreurs de manipulations en faisant les mesures électriques ... mais je vois que les points d'alimentations sont bien accessibles sur la face avant ... donc il n'y a pas de risque à mesurer les tensions à ce niveau là ...

J'avais peut-être lu un peu vite, je voyais surtout un problème au démarrage ... si ça démarre correctement et que la panne ne se produit qu'à la frappe de valeurs numériques, on pourrait penser que le clavier envoi des caractères erronés qui sont mal interprétés par le calculateur (?) ... en principe le logiciel devrait rejeter les caractères erronés mais on ne sait jamais ... il peut y avoir une faille dans le logiciel ... dans ce cas ce pourrait être le clavier le fautif ... ou l'électronique entre le clavier et la liaison RS232 la cas échéant (?)

Le problème est bien celui là => des erreurs uniquement à la frappe clavier numérique ?

Cordialement,
FB29
 
zapa40
Nouveau
31 Juillet 2019
5
  • Auteur de la discussion
  • #5
Systématiquement c'est une frappe sur le clavier numérique, j'ai vérifié la RS232 qui est en bon état mais je pensais également au clavier car visiblement il a déjà été changé (tour acheté d'occasion et il y a un clavier de plus dans le lot, j'ai essaye de mettre ce clavier et le problème est le même, peut être les 2 sont HS)
Cordialement
 
FB29
Compagnon
1 Novembre 2013
7 771
FR-29 Brest
Pour le moment je ne vois pas d'autre explication que l'envoi de codes ou de séquences de codes erronés par le clavier (ou l'électronique qui est derrière) qui causent le plantage du logiciel puisque il n'y a que dans ces conditions que la panne arrive ... le reste du temps le calculateur utilise bien toutes les ressources et ne se plante pas ...

Tu devrais changer le titre qui n'est pas très racoleur pour attirer les dépanneurs ... je mettrais bien quelque chose comme "Plantage tour Somab 300 sur entrées clavier" ... utiliser le bouton "Outils de la discussion" en haut à droite de ton premier message.

Cordialement,
FB29
 
Haut