Advertisements

Installation de cambam 1.0 sous linuxcnc

speedfender
speedfender
Compagnon
16 Février 2013
547
Nancy 54
  • Auteur de la discussion
  • #1
Bonjour, après avoir passé quelques heures à installer cambam1.0 sur linux, j'ai fais une petite fiche explicative destinée aux nouveaux utilisateurs de Linux ; ceux qui l'utilisent grâce à linuxcnc.. il s'agit d'un pas à pas ayant principalement recours à l'interface graphique

Pour commencer, voici le lien vers la pages de téléchargement de cambam pour linux :


http://cambam.info/ref/ref.linux




I Installation



Pour installer Cambam1.0 sur linux, il faut intervenir sur trois fichiers (disponibles sur la page redirigée par le précédant lien)


. Il faut s'assurer que mono 'Framework dependencies' est installé

. Ensuite il faut extraire 'CamBam binaries' dans notre répertoire personnel de linux

. et enfin il faut extraire le dossier système de Cambam dans le dossier .config présent dans notre répertoire personnel. ( Ctrl-h pour afficher les fichiers et dossiers cachés dans l'interface graphique)




Liens directs



-CamBam binaries


32 bits -http://www.cambam.co.uk/downloads/dw/CamBam1.0-mono-alpha12b-32bit.tgz


ou 64 bits -http://www.cambam.co.uk/downloads/dw/CamBam1.0-mono-alpha12b-64bit.tgz



- CamBam system folders

http://www.cambam.co.uk/downloads/dw/CamBam1.0-mono.system.tgz



- mono framework

http://www.mono-project.com/download/#download-lin





I Installation


Cambam binaries



Pour ma part je l'ai Telecharger cambam1.0 en 32bits et l'ai ouvert avec le gestionnaire d'archives (par défaut, sqeeze)

[div=none][div=none][div=none]
[/div][/div][/div]



Il faut extraire ce dossier dans votre dossier personnel, portant votre nom

Cliquez sur action>extract

[div=none][div=none][div=none]
[/div][/div][/div]


Selectionnez votre dossier à gauche, le mien s'appele renaud, en surbrillance à gauche, puis Extract en bas a droite

[div=none][div=none][div=none]
[/div][/div][/div]

Fermer squeeze


CamBam system folders


Cambam1.0 est maintenant télécharger et extrait au bon emplacement

Maintenant ils nous faut télécharger le dossier système de CamBam (Cambam System folders)



Après avoir cliqué sur le lien vers 'cambam system folder ' ; même déroulement :

[div=none][div=none][div=none]
[/div][/div][/div]

Ouvrir avec Squeeze, puis, OK



Cliquez sur Action>Extraire


Il faut l'extraire dans le dossier personnel, dans le dossier .config


Pour cela, faites un clic droit dans la zone blanche de votre dossier personnel, et cochez

'affichez les fichiers cachés' / ' show hidden files '

Double cliquez ensuite sur le dossier .config pour entrer dedans et enfin, cliquez sur 'Extraire', en haut à droite, puis 'Fermer' :


Si jamais vous souhaitez vérifier que le fichier a bien été extrait dans le répertoire .config de votre dossier personnel, allez dans votre dossier personnel avec le gestionnaire de fichiers, clique dans la zone blanche et appuyer simultanément sur les touches CTRL et H (ou clic doit et cochez afficher les fichiers cachés). Les fichiers et dossiers cachés apparaiteront.

Vous pourrez alors cliquer sur le dossier .config et constater que le dossier CamBam plus 1.0 y est présent.

[div=none][div=none][div=none]
[/div][/div][/div]

Mono Framework Dépendancies




Il est recommandé d'installer Mono Framework 4.6 ou plus.


Pour ce faire ouvrez la console/le terminal


Le plus simple à mes yeux est d'installer le package complet de mono, en utilisant la console pour l'installer.

Pour ce faire, je pense qu'il vaut mieux commencer par supprimer l'ancienne version de mono-runtime et ensuite faire cette installation complete.



On lance la console

[div=none][div=none][div=none][div=none][div=none]
[/div][/div][/div][/div][/div]

Il faut d'abord se connecter en mode root avec ' su ' ou ' sudo su ' puis entrer votre mot de passe

[div=none][div=none][div=none][div=none][div=none]
[/div][/div][/div][/div][/div]

Maintenant que l'on est en mode root, on va commencer par faire une mise à jour du system, avec :


' apt-get update '

on valide

[div=none][div=none][div=none][div=none][div=none]
[/div][/div][/div][/div][/div]


la liste des paquets étant faite, on met à jour avec :

' apt-get upgrade '


on valide

[div=none][div=none][div=none][div=none][div=none]
[/div][/div][/div][/div][/div]



maintenant on peut supprimer mono-runtime avec :

' apt-get remove mono-runtime '




Ici il n'était pas installé, donc il n'a pas été supprimé



Comme conseillé dans la console, je supprime aussi ' cli-common ' avec :

' apt-get autoremove '

[div=none][div=none][div=none][div=none]
[/div][/div][/div][/div]

Maintenant nous pouvons installer le package complet de mono avec :

' apt-get install mono-complete '

Touche O pour oui puis validez






L'installation est terminée !





Si vous souhaitez installer uniquement les librairies recquises, vous pouvez saisir les commandes suivantes, une à une


sudo apt-get install mono-runtime
sudo apt-get install libmono-system-windows-forms4.0-cil
sudo apt-get install libmono-system-web4.0-cil
sudo apt-get install libmono-system-design4.0-cil
sudo apt-get install libmono-system-numerics4.0-cil
Bien entendu, si vous a fallut vous connecter en mode root précédement, il faudra saisir les expressions précédantes sans ecrire ' sudo '




II Lancement de CamBam1.0

Avec CamBam1,0 un fichier ' cambam.sh' a été créé dans le but de nous dispenser d'utiliser la console pour lancer CamBam :) Utilisons le


Pour se faire, ouvrez le gestionnaire de fichier, allez dans votre répertoire, ouvrez le dossier Cambam1,0

[div=none][div=none][div=none][div=none][div=none]
[/div][/div][/div][/div][/div]



Ce dossier contient le fichier nomé cambam.sh


Cliquez dessus, Cambam1,0 démarre

[div=none][div=none][div=none][div=none][div=none]
[/div][/div][/div][/div][/div]

N'ayant pas la clef de licence, je ne peux pas montrer comment l'installer..

J'espère que ce pas à pas est complet et qu'il serra utile à quelques uns..

 
Dernière édition:
Advertisements
speedfender
speedfender
Compagnon
16 Février 2013
547
Nancy 54
  • Auteur de la discussion
  • #2
Dh42 me fait savoir qu'il faut ajouter une dépendance pour permettre à certains plugins écris en VB de fonctionner sous cambam

pour ceci, il vous faut à nouveau ouvrir un terminal et y entrer la commande suivante:

sudo apt-get install libmono-microsoft-visualbasic10.0-ci
 
ingenieu59
ingenieu59
Compagnon
10 Septembre 2013
3 415
cassel 59
Bonjour,

les explications sont très claires et précises .
ça va en aider plus d' un .

Merci à toi d' avoir fait ce tuto .
 
La dernière réponse à ce sujet date de plus de 6 mois
Advertisements
Haut