Erreur G71 sur mori seiki

Bruno Del Pinatcho !
Nouveau
15 Octobre 2017
2
  • Auteur de la discussion
  • #1
Bonjour,
Voilà je Travail sur un tour Mori Seiki SL25 armoire Fanuc.
Je fais un essai de programme pour utiliser un perçage, un dressage, un chariotage extérieur et un alésage. Tout ceci en utilisant un G72 un G71 et un G70.
j'ai d’abord essayé avec un simple programme avec un seul outil sans le G70.
Apres maintes essais, il fonctionne.
Mais lorsque je veux faire un peu plus complexe, j'ai un code erreur: 64.
J'ai regardé dans le manuel d'entretien ou il est marqué tous les codes erreur.
Mais je ne trouve pas 64.
J'ai bien 63 et 65 mais pas 64.

Voici d'abord le programme qui fonctionne:

&HE:%
:0003
(PROJET PROG MISE AU CARRE 1)
(T4 R1.2)
N10 G96 S240
N20 G50 S3500
N30 G00 T404 M04
N40 X200. Z200. M08
N50 X154. Z154.
N60 G72 W2 R2
N70 G72 P80 Q110 U0 W0 F.35
N80 G00 Z152.
N90 G01 Z150.
N100 X0
N110 G00 Z152.
N120 G00 X154. Z154.
N130 G71 U2 R2
N140 G71 P150 Q170 U0 W0 F.35
N150 G00 X100.
N160 G01 Z100.
N170 X154.
N180 G00 X250. Z400. T400
N190 M09
N200 M01
N210 M30

%

Et voici celui qui me pose problème:

&HE :%
:0003
(PROJET PROG MISE AU CARRE AVEC PERCAGE ET ALESAGE)
(CH0.5)
BLOC N220 ERREUR 64
(T4 T2 T7 T9 R1.2 - T11 F40)
N10 G97 S796
N20 G00 T1111 M03
N30 X0 Z200. M08
N40 Z170.
N50 G01 Z-3.F.1
N60 G00 Z170.
N70 X250. Z300. T1100
N80 M09
N90 M05
N100 M01
N110 G96 S240
N120 G50 S3500
N130 G00 T404 M04
N140 X200. Z200. M08
N150 X154. Z156.
N160 G72 W2 R2
N170 G72 P180 Q190 U0 W.1 F.35
N180 G00 Z150.
N190 G01 X35. F.2
N200 G00 X154. Z151.
N210 G71 U2 R2
N220 G71 P230 Q260 U.25 W.1 F.35
N230 G00 X97. Z151.
N240 G01 X100. Z149.5 F.2
N250 Z100.
N260 X154.
N270 G00 X250. Z400. T400
N280 M09
N290 M01
N300 G96 S200
N310 G50 S3500
N320 G00 T707 M04
N330 X40. Z152. M08
N340 G71 U1 R.5
N350 G71 P360 Q390 U-.25 W.1 F.25
N360 G00 X53. Z151.
N370 G01 X50. Z149.5
N380 Z50. F.2
N390 X39.
N400 G00 Z170.
N410 X250. Z300. T700
N420 M09
N430 M01
N440 G96 S200
N450 G50 S3500
N460 G00 T909 M04
N470 X40. Z152. M08
N480 G70 P360 Q390
N490 G00 Z170.
N500 X250. Z300. T900
N510 M09
N520 M01
N530 G96 S260
N540 G50 S3500
N550 G00 T202 M04
N560 X154. Z156. M08
N580 G00 Z154.
N590 G70 P230 Q260
N600 G00 X154. Z156.
N610 X250. Z400. T200
N620 M09
N630 M01
N640 M30

%

Alors voilà, quelqu'un peut t'il m'aider? Car là je vois pas pourquoi le programme ne marche pas à la ligne 220.
Merci, et un peu de copréhension, je suis nouveau sur le forum.
Merci d'avance
 
JLuc69
Compagnon
19 Juin 2008
1 313
Genas (69)
Je pense que c'est un problème de type de cycle.
Sur le premier bloc (appelé par P..), si tu mets les deux axes (X et Z) tu passes en type II alors qu'avec un seul axe (X) tu restes en type I.
Je ne peux pas te dire s'il y a un paramètre machine à modifier, mais sur notre MORI SEIKI, le type II ne marche pas non plus.
Je n'ai pas cherché plus loin, parce que le type II n'est intéressant que si tu dois faire l'ébauche avec des "poches", ce qui est rare.
 
Bruno Del Pinatcho !
Nouveau
15 Octobre 2017
2
  • Auteur de la discussion
  • #3
Merci Jluc69!
J'ai essayé avec une légère modification. Et tout le programme fonctionne parfaitement.
Je l'ai écris sous la forme de type I. Et en effet ma machine ne doit pas gérer le type II.
Mais l’essentiel c'est que maintenant j'ai une base pour faire des pièces similaires.
Je pense que ça me permettra de gagner un temps fou, et cela m'évite d'attendre les programmes iso en FAO.
Merci encore pour l'explication nette et précise.
 
hatem0008
Nouveau
30 Novembre 2013
6
Le probleme est en première ligne N220 il faut metre que le valeur de X Exp (N220 G0X151;
N230 .....)ET le valeur de Z déjà marque
Jai travaille sur mori seki et a un autre probleme lorsque tu fait en cycle de finition elle donne un alarme si tu fait G3 puis G2 en deux ligne
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut