Debut difficile avec Linux CNC

  • Auteur de la discussion wanfr
  • Date de début
S
speedjf37
Compagnon
Bonsoir,

Les réglages du courant moteur et des micros pas se font sur le driver.
Il faut évidemment que les paramètres du logiciel correspondent et que les vitesses soient compatibles.

Photos du driver et des réglages svp

JF
 
vincentimes
vincentimes
Nouveau
bonjour, je vais faire le maximum! Merci!
20160323_143332.jpg
20160323_143339.jpg
20160323_143514.jpg
20160323_143524.jpg
20160323_143537.jpg
20160323_143544.jpg
20160323_143552.jpg
20160323_143548.jpg
 
vincentimes
vincentimes
Nouveau
Bonjour, j'avais joint un message aux photos mais il a disparu.
Je disais donc: Merci de votre aide, je vais un maximum pour vous donner les infos!
Merci
 
V
vres
Compagnon
Des moteurs Hyper-coupleux alimentés au maximum avec une résolution de au 1/2 pas et en plus à vide, ça ne doit pas être joli à entendre.
Je suis à peine surpris qu'il fassent n'importe quoi. Un moteur Pas à Pas a besoin de travailler en charge.
Refais des essais en augmentant la résolution et en baissant le courant et si possible poste nous une vidéo.
 
Dernière édition:
vincentimes
vincentimes
Nouveau
salut, non il tourne bien sans bruit bizare. je vais faire une video.
tu veux dire quoi par augmenter la résolution?
pour le demi pas je pige pas. j'ai régler mes driver sur 400puls/tr et mon soft sur 200puls/tr ce qui me fait 1 impulsion / un demi pas soit 0.9°? c'est ça?
Merci
 
V
vres
Compagnon
Bon je ne connais pas LinuxCNC mais ton paramétrages :
- Pour la résolution pourquoi tu ne mets pas la même résolution sur LinuxCNC que sur tes drivers? Tu peux mettre ta résolution sur 1600 ou 2000 tu auras une rotation plus fluide.
- Une vitesse 25mm/s c'est vraiment peu.
- Pour l'accélération il faudrait entre 300 et 500 si tu veux des mouvements homogènes. Avec 40 tu va avoir des courbes saccadées.
- Pourquoi avoir pris des moteur si coupleux sur une méchante vis de 4 ? il fallait au contraire un moteur avec un couple de 1 ou 2Nm mais qui puisse tourner vite ! Heureusement tu as des driver qui acceptent une tension d'alimentation élevée.

Il y a aussi un paramètre dont on ne parle pas souvent, que tu indiques, et qui est très important c'est l'inertie. Plus tu as d'inertie est mon ton moteur sera dynamique.
 
Dernière édition:
vincentimes
vincentimes
Nouveau
ok je prend note, merci. La vidéo est en upload. en fait j'ai une machine type A4 d'école avec l’électronique des années bissextiles. mon projet plustard et de motorisé une vrai machine digne de ce nom. Voila pourquoi j'ai choisi un tel kit. en attendant j'adapte sur la petite machine. Je suis tourneur fraiseur classique/soudeur/monteur et boulot j'ai tout ce qu'on peut avoir besoin pour faire une machine, il me faut juste le temps et l'argent, donc ca prend du temps mais je finirais bien par y arriver.
Merci
la video sera disponible a ce lien dans une 20ene de minutes:
@+
 
Dernière édition:
V
vres
Compagnon
"Veuillez vous connecter pour regarder cette vidéo"
Tu peux modifier ?

Sur Stepconf, je vois 200step/rev et 4 microstepping cela voudrait dire 800 microsteps/rev ???
 
V
vres
Compagnon
les impulsions ne sont pas régulières, a oscilloscope ca ne doit pas être joli.
C'est peut être tes réglages de timings qui ne sont pas bons, mais je ne peut pas t'aider la dessus.
 
vincentimes
vincentimes
Nouveau
Tu peux modifier ?

Sur Stepconf, je vois 200step/rev et 4 microstepping cela voudrait dire 800 microsteps/rev ???

je n'en ai aucune idée, je suis tres novice pour le moment. j'ai recopier ce qu'on fait les autres et c'est bof bof pour le moment! demain je vais essayer ce que tu m'a dit au post #36.
Merci
 
S
speedjf37
Compagnon
Bonjour,

Les drivers sont réglés sur 400 pas / tour soit 1/2 pas pour un moteur de 200 pas/tours

Avec Driver Microstepping 4 LinuxCNC génère 2 fois plus de micro pas que nécessaire
4 impulsions pour un pas alors qu'il en faut 2 en 1/2 pas la vitesse imposée au moteur est doublée donc 50mm/s soit 3000tr/mn
c'est surement cela qui fait décrocher les moteurs


La conf devrait :
Motor step revolution 200 OK
Driver Microstepping 2 (en accord avec le driver) A MODIFIER
Puley (rappord de réduction si poulie) 1 1 (pas de réduction) OK

Leadscreew pitch (pas de la vis à bille) 4 ? généralement 5 ou 10 mm/tour
(pour l'instant pas trop important puisque pas monté mais sert à convertir les déplacements (jog) en step )

Maximum Velocity 25mm/s (25 X 60 = 1500mm/minute) OK
Maximum Acceleration 40 mm/s² (a tester sur des déplacement un peu long on doit entendre l’accélération)

edit:
avec les flèches la vitesse de jog (145mm/mn affichage écran) réglable curseur
avec shift flèches la vitesse de jog = vitesse max (1500 mm/mn affichage écran) figé paramètres


JF
 
Dernière édition:
V
vres
Compagnon
je n'en ai aucune idée, je suis tres novice pour le moment. j'ai recopier ce qu'on fait les autres et c'est bof bof pour le moment! demain je vais essayer ce que tu m'a dit au post #36.
Merci

La rotation de tes moteurs est irréguliére, il faut déjà que tu résolves ce problème, ce n'ai pas un problème de paramétrage de moteur.
 
carlos78
carlos78
Compagnon
Salut,

- Sur les photos plus haut je vois que le latency test donne un max jitter de 644 745ns. Cette valeur est beaucoup trop élevée. Au dela de 100 000ns il y a un problême de compatibilité du PC avec LinuxCNC. C'est souvent un problême liée à la carte graphique utilisée.
Cette valeur doit être reportée ensuite en la majorant un peu dans la case Base Period Maximum Jitter (c'est le but du test de latence). La valeur de 45 000ns est fausse et trompe LinuxCNC sur les capacités temps réel du PC.
- Ton driver est un DM860A. Ses paramètres devraient être nettement inférieurs aux paramètres utilisés. Sur le tableau des "steppers drive timing" , on voit que pour un DM860H on a Step time et step space de 1500ns, direction hold de 8000ns , direction setup de 5000ns. Ces valeurs sont quasiment identiques pour tous les leadshine.
- Le blocage des moteurs vient sans doute comme le fait remarquer Speedjf37 d'une erreur dans le paramétrage du ratio des steps.
Sur la photo du driver on voit que les switchs 5,6,7 et 8 sont sur ON = valeurs en 1/2pas = 400 pas par tour du moteur. Avec une vis au pas de 4mm, on devrait avoir un axis/scale de 100 pas/mm.
Ce n'est pas le cas car dans le paramétrage de tes 3 axes, il y a un ratio de 4 qui trompe LinuxCNC d'ou un axis scale faux de 200pas/mm.
Le résultat est que la vitesse du moteur est doublée, ce n'est plus une vitesse de 25mm/s, mais une vitesse de 50mm/s. Ceci équivaut à une rotation de 750tr/mn probablement trop importante pour tes moteurs ...
- L'accéleration pourrait être augmentée et l'intensité du courant dans les moteurs réduite ...
 
Dernière édition:
vincentimes
vincentimes
Nouveau
Salut,

- Sur les photos plus haut je vois que le latency test donne un max jitter de 644 745ns. Cette valeur est beaucoup trop élevée. Au dela de 100 000ns il y a un problême de compatibilité du PC avec LinuxCNC. C'est souvent un problême liée à la carte graphique utilisée.
Cette valeur doit être reportée ensuite en la majorant un peu dans la case Base Period Maximum Jitter (c'est le but du test de latence). La valeur de 45 000ns est fausse et trompe LinuxCNC sur les capacités temps réel du PC. je met quelle valeur ducoup?
- Ton driver est un DM860A. Ses paramètres devraient être nettement inférieurs aux paramètres utilisés. Sur le tableau des "steppers drive timing" , on voit que pour un DM860H on a Step time et step space de 1500ns, direction hold de 8000ns , direction setup de 5000ns. Ces valeurs sont quasiment identiques pour tous les leadshine.Je test donc les valeurs que me cite?
- Le blocage des moteurs vient sans doute comme le fait remarquer Speedjf37 d'une erreur dans le paramétrage du ratio des steps.
Sur la photo du driver on voit que les switchs 5,6,7 et 8 sont sur ON = valeurs en 1/2pas = 400 pas par tour du moteur. Avec une vis au pas de 4mm, on devrait avoir un axis/scale de 100 pas/mm.
Ce n'est pas le cas car dans le paramétrage de tes 3 axes, il y a un ratio de 4 qui trompe LinuxCNC d'ou un axis scale faux de 200pas/mm.
Le résultat est que la vitesse du moteur est doublée, ce n'est plus une vitesse de 25mm/s, mais une vitesse de 50mm/s. Ceci équivaut à une rotation de 750tr/mn probablement trop importante pour tes moteurs ... Je comprend (enfin je crois) je dois modifié quoi au juste? sur le driver ou dans les setting?
- L'accéleration pourrait être augmentée et l'intensité du courant dans les moteurs réduite ...

En tout cas, merci pour votre aide.
Demain j'aurais le temps dans l'apres midi de faire quelques test. ou ce soir...
MERCI!!!
 
vincentimes
vincentimes
Nouveau
bonjour, je viens de faire plein de test et toujours pareil, avec les relages suivant les moteur ne decrochent plus.
Jai essaye ton idée CNCserv et ca ne donne rien.
Carlos, si je descend les valeurs Step time/step space/direction hold de 8000ns , direction setup de 5000ns, il ne se passe plus rien, mes moteurs ne tourent plus.
j
Capture d'écran - 25032016 - 17:41:54.png
 
V
vres
Compagnon
Sur les photos plus haut je vois que le latency test donne un max jitter de 644 745ns. Cette valeur est beaucoup trop élevée. Au dela de 100 000ns il y a un problême de compatibilité du PC avec LinuxCNC. C'est souvent un problême liée à la carte graphique utilisée.
Cette valeur doit être reportée ensuite en la majorant un peu dans la case Base Period Maximum Jitter (c'est le but du test de latence). La valeur de 45 000ns est fausse et trompe LinuxCNC sur les capacités temps réel du PC.

As tu exploré cette piste ?
 
vincentimes
vincentimes
Nouveau
salut.
Je ne sais pas trop quoi faire.... Je recherche des mise a jour pour ma CG? Depuis l’installation le pc me demande faire une 60ene de mise a jour mais il me semble avoir lu qu'il ne fallait pas les faire quand ont utilisait linuxcnc.
J'ai baisser la valeur à 15 000ns hier avant de faire de tous mes tests.
 
carlos78
carlos78
Compagnon
:wink: Dans tes réglages moteur, tu "triches" 2 fois et tu retombes sur tes pattes à savoir un axis scale de 100 pas/mm : ton moteur tourne maintenant à 450tr/mn ce qui est plus raisonnable
--> Si ton driver est toujours en 1/2 (400 step/tour), normalement on met motor steps per revolution à 200 et driver microstepping à 2.
Perso, je testerais en 1/4 ou en 1/8 pour avoir un fonctionnement plus doux.

"Carlos, si je descend les valeurs Step time/step space/direction hold de 8000ns , direction setup de 5000ns, il ne se passe plus rien, mes moteurs ne tourent plus."
Attention, le tableau donne pour un DM860H Step time et step space de 1500ns (pas 8000ns).
Pour les paramètres du driver, je ne connais pas l'impact réel des valeurs. Il est difficile de trouver des infos pour un DM860A. J'ai rien trouvé.
Dans le doute reste avec les valeurs standards de LinuxCNC proposés par stepconf pour un driver "autre" (step time et step space = 5000ns, direction hold et direction setup = 20000ns). Elles ne seront pas optimisées, mais elles devraient permettre le fonctionnement des moteurs. :wink: C'est les valeurs que j'utilise sur une config à base de drivers très basiques (HY-DIV268N).

:-D Pour le latency test, j'ai eu la chance d'avoir une config PC qui tourne à moins de 4000ns (ce qui est très bon). Avec ce paramètre + les paramètres du driver par défaut, stepconf me calcule une période de base de 25000ns.
Si ton temps de latence devient un problême (perte de pas), il faudra probablement changer ta carte graphique.
 
vincentimes
vincentimes
Nouveau
:wink: Dans tes réglages moteur, tu "triches" 2 fois et tu retombes sur tes pattes à savoir un axis scale de 100 pas/mm : ton moteur tourne maintenant à 450tr/mn ce qui est plus raisonnable
--> Si ton driver est toujours en 1/2 (400 step/tour), normalement on met motor steps per revolution à 200 et driver microstepping à 2.
Perso, je testerais en 1/4 ou en 1/8 pour avoir un fonctionnement plus doux.
Donc je me met à 800 sur le driver , 400 en revolution et 2 en microstep?

"Carlos, si je descend les valeurs Step time/step space/direction hold de 8000ns , direction setup de 5000ns, il ne se passe plus rien, mes moteurs ne tourent plus."
Attention, le tableau donne pour un DM860H Step time et step space de 1500ns (pas 8000ns). Oui oui j'ai bien respecter tes conseils 1500/1500 et 8000.
Pour les paramètres du driver, je ne connais pas l'impact réel des valeurs. Il est difficile de trouver des infos pour un DM860A. J'ai rien trouvé. Je te remercie pour tes recherches!
Dans le doute reste avec les valeurs standards de LinuxCNC proposés par stepconf pour un driver "autre" (step time et step space = 5000ns, direction hold et direction setup = 20000ns). Elles ne seront pas optimisées, mais elles devraient permettre le fonctionnement des moteurs. :wink: C'est les valeurs que j'utilise sur une config à base de drivers très basiques (HY-DIV268N). Ca marche je vais essayer dessuiste.

:-D Pour le latency test, j'ai eu la chance d'avoir une config PC qui tourne à moins de 4000ns (ce qui est très bon). Avec ce paramètre + les paramètres du driver par défaut, stepconf me calcule une période de base de 25000ns.
Si ton temps de latence devient un problême (perte de pas), il faudra probablement changer ta carte graphique. Ok , c'est une CG integrée a la CM, au pire jen trouve une a 30€ plus compatible que celle ci.

Que pensez-vous des mise à jour de Linux, je peux les faire sans crainte?
Encore merci pour votre aide.
je vais vous faire une nouvelle video pour entendre le moteur, il tourne mais ont sent a intervalle régulier que la fréquence change.

@+
 
carlos78
carlos78
Compagnon
Heu ... 200 en revolution est une constante qui caractérise ton moteur, ça ne dépend pas des réglages sur le driver.
800 sur le driver = 200 en révolution et 4 en microstep
1600 sur le driver = 200 en revolution et 8 en microstep
etc ...
Les mises à jour Linux ne devraient pas être un problème.
 
vincentimes
vincentimes
Nouveau
salut

ok ok, je suis devant là. en 800 / 200 de rev et 2 de microstep ca marche plutôt bien, tres peut de "raté"
en 800 /200 /4 le moteur decroche quasiment dessuite.

Merci

je vais passer au montage sur la machine afin de regler les pas de mes vis.
 
V
vres
Compagnon
ok ok, je suis devant là. en 800 / 200 de rev et 2 de microstep ca marche plutôt bien, tres peut de "raté"
en 800 /200 /4 le moteur decroche quasiment dessuite.

C'est un peu normal car en faisant ça tu fais tourner ton moteur 2 fois plus vite.
 
V
vres
Compagnon
Je ne sais pas si c'est du a la vidéo ou a mes oreilles, mais la rotation ne semble pas régulière, c'est surement ce qui ne va pas.
 
vincentimes
vincentimes
Nouveau
oui c'est ça le moteur tourne mais ont entend un sursaut a intervalle régulier. que faire?
Mystère!
Moteur Axe Z en place.

Merci
 
vincentimes
vincentimes
Nouveau
salut
en attendant un autre pc mieux compatible j'ai monté mes moteur sur ma machine.
il m'a fallu changer le pas de la vis de 4 a 2 dans les axes et mes distances ont l'air bonnes ( au réglé).
Je ne sais pas trop comment marche une CN, le survol en cour sur num720 remonte plus que tres loin.
je ne pige pas pourquoi je ne peux pas aller plus loin que les limites mis dans stepconf AVANT d'avoir fait les POM.

J'ai une question, je suis en train d'apprendre a dessiné sur catia, mais apres avec quoi transformé le plan en Gcode pour linux cnc?

Merci pour votre aide! Le projet avance!
 
carlos78
carlos78
Compagnon
Salut,
:wink: on adapte pas les paramètres pour que les distances soient bonnes ... on met les bons paramètres et on a les bonnes distances.

Sur CATIA il y a un module usinage qui permet de générer le gcode à partir d'une pièce en 3D. Pour moi c'est CAMBAM.
on trouve des tutos CATIA comme celui-ci
 
Dernière édition:

Sujets similaires

M
Réponses
2
Affichages
773
bendu73
bendu73
01power
Réponses
3
Affichages
9 288
01power
01power
T
Réponses
6
Affichages
2 305
T
Haut