Branchement probe digitizer arduino/Bcnc

  • Auteur de la discussion Nessa
  • Date de début
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #1
Bonjour à tous,

Veuillez m'excuser si je ne suis pas dans la bonne thématique.

J'ai acheter ce produit, un 3D digitizer,
https://cnc-plus.de/en/Router-Acces....html?XTCsid=05aea8a4e1996ea9d1d8149b8e6575b5
Je l'ai branché à mon Arduino.
Les branchements sont les suivants : le brun et le bleu qui correspondent respectivement au +10-30V et à la masse, sont branchés à l'alimentation, car le Arduino ne donne que du 5V. Le fil noir qui correspond au palpeur, est branché sur le pin A5 de l'Arduino.
Après branchement, la led du probe s'allume et s'éteint au contact de la pièce. Jusque là tout va bien.

Mais quand je passe à l'auto-nivelage, via le logiciel BCNC, cela ne fonctionne pas. C'est comme si le probe était constamment en contact, car l'auto-nivelage s'arrête immédiatement.
Pouvez-vous m'aider à faire fonctionner ce probe correctement.
Merci.
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Bonjour Nessa

Quel potentiel as-tu sur la pin A5 lorsque la sonde ne touche rien du tout?
Si c'est 0v., il faut inverser le signal avec la commande GRBL:

$6=1

C'est expliqué ici.

Cordialement
jpbbricole
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #3
Bonjour,
Merci pour votre réponse. Mais j'ai déjà essayer cette option. Rien ne change.
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Quelle version de GRBL as-tu?
Quels sont les potentiels sur A5, la sonde au repos et la sonde en contact?
 
osiver
osiver
Compagnon
7 Sept 2013
12 024
Il y a un document, notice avec ?
J'ai regardé vite fait le site, pas de téléchargement ... :cry:
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #6
Merci pour vos réponses.
Il y a un document, notice avec ?
J'ai regardé vite fait le site, pas de téléchargement ... :cry:
Non il n'y ni notice, ni autre doc qui pourrait m'aiguiller.

Quelle version de GRBL as-tu?
Quels sont les potentiels sur A5, la sonde au repos et la sonde en contact?
J'ai utilisé les versions GRBL est 1.0 et la V0.9. Le résultat est le même.
Pour ce qui est des potentiels sur A5, je ne sais pas à quoi cela correspond. Comment pourrais-je le calculer?

En fait je fais la même manipulation sur Bcnc, en auto-nivelage, avec une pince croco sur la broche, une autre sur l'aluminium qui entoure ma pièce, et ça marche parfaitement, sans rien configurer.
Dans ce cas là, mécaniquement parlant le système du probe et le même que celui des pinces croco, si je ne me trompe pas, c'est une histoire de contact.
Donc je comprend pas d'où vient le problème.
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #7
Voici le montage que j'avais utilisé pour les pinces crocos.
systeme croco.jpg
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Bonsoir Nessa
En fait je fais la même manipulation sur Bcnc, en auto-nivelage, avec une pince croco sur la broche, une autre sur l'aluminium qui entoure ma pièce, et ça marche parfaitement, sans rien configurer.
Ça c'est la façon standard de procéder avec GRBL.
Ton schéma n'est pas tout à fait juste ta sonde est sur D6 au lieu de A5 :sad:
Comment pourrais-je le calculer?
Avec un voltmètre sur A5, tu verras, avec la méthode standard, sans que la sonde touche tu trouvera 5V. et quand elle touche 0V.
Les branchements sont les suivants : le brun et le bleu qui correspondent respectivement au +10-30V et à la masse
Quelle valeur de tension as-tu mise ? Perso, je mettrai 5V.

Cordialement
jpbbricole
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #10
Merci encore vos réponses

Ton schéma n'est pas tout à fait juste ta sonde est sur D6 au lieu de A5 :sad:
En effet je ne l'ai pas précisé, mais j'avais bien changé en A5. Et comme je l'ai écrit précédemment je n'ai eu aucun problème avec ce système (pince croco + aluminium), cela a très bien fonctionné.

Quelle valeur de tension as-tu mise ? Perso, je mettrai 5V
Sur du 5V, le probe que j'ai acheté ne s'allume carrément pas. Il a vraiment besoin d'une tension entre 10 et 30V.
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Et donc quelle tensions sur A5 lors des 2 états de la sonde ?
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #12
J'ai fait un branchement identique à la photo du schéma électrique que j'ai posté précédemment. Mis à part que sur mon probe j'ai un fil brun (+10VDC-30VDC) qui est relié au plus de la pile de 9V, pour sur alimentation.
Je lance le scan, via Bcnc, le probe ne fonctionne pas. Mais quand je touche (avec mes doigts) la liaison qui relie le pin A5, le condensateur et le fil noir du probe, le probe fonctionne.
Ceci m'amène à penser que cela ne vient pas d'un problème de paramétrage du logiciel mais bien d'un problème électrique.
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Est-ce que la masse (GND ou - de la pile) de l'alimentation du probe est connecté avec le GND de l'Arduino ?
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #15
Est-ce que la masse (GND ou - de la pile) de l'alimentation du probe est connecté avec le GND de l'Arduino ?
Oui la masse (fil bleu du probe) est relié au GND de l'Arduino et au - de la pile
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 249
Corsier-sur-Vevey (Vaud)
Il reste plus que la mesure au voltmètre pour comprendre. Ce qui m'intrigue c'est le fait de toucher et ça fonctionne ! C'est typique d'une mauvaise masse.
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #17
Qu'est ce que vous entendez par mauvaise masse?
Pour ce soir je m'arrête là, mais je reviendrai demain à la charge avec un voltmètre! :-D

En tout cas merci beaucoup pour le temps que vous avez passé à m'apporter votre aide. :wink:
 
osiver
osiver
Compagnon
7 Sept 2013
12 024
On ne sait pas si la sonde a une sortie PNP ou NPN. :eek:
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #19
On ne sait pas si la sonde a une sortie PNP ou NPN. :eek:
Bonsoir, merci pour votre réponse. En effet, je ne sais pas si la sortie est PNP ou NPN, ce n'est pas précisé sur le site.
Peut-on le tester?
 
osiver
osiver
Compagnon
7 Sept 2013
12 024
Oui avec un multimètre en mode ohmmètre gamme 2KOMEGAou moins.
Le commun du multimètre relié à la masse, le cordon + à la sortie de la sonde.
Si c'est NPN, la sortie est reliée (résistance très faible) à la masse lorsque la sonde est activée, en l'air = résistance très grande lorsque la sonde n'est pas activée.
Pour une sortie PNP, on teste avec le + du multimètre au + de l'alimentation de la sonde, le commun à la sortie.
Lorsque la sonde est activée, la sortie doit être reliée au + (résistance faible) et en l'air lorsque la sonde n'est pas activée.

Autre méthode :
On place une résistance (4,7kOMEGA) entre le + de l'alim et la sortie. On mesure avec le multimètre (tension DC) entre masse et sortie.
Pour une sortie NPN, la tension doit être <1V lorsque la sonde est activée et égale à la tension d'alimentation lorsque la sonde n'est pas activée.
Pour une sortie PNP, la résistance est branchée entre la masse et la sortie. Quand la sonde est activée, la tension doit être presque égale à l'alimentation et à 0V pour la sonde non activée 8-)
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #21
Oui avec un multimètre en mode ohmmètre gamme 2KOMEGAou moins.
Le commun du multimètre relié à la masse, le cordon + à la sortie de la sonde.
Si c'est NPN, la sortie est reliée (résistance très faible) à la masse lorsque la sonde est activée, en l'air = résistance très grande lorsque la sonde n'est pas activée.
Pour une sortie PNP, on teste avec le + du multimètre au + de l'alimentation de la sonde, le commun à la sortie.
Lorsque la sonde est activée, la sortie doit être reliée au + (résistance faible) et en l'air lorsque la sonde n'est pas activée.

Autre méthode :
On place une résistance (4,7kOMEGA) entre le + de l'alim et la sortie. On mesure avec le multimètre (tension DC) entre masse et sortie.
Pour une sortie NPN, la tension doit être <1V lorsque la sonde est activée et égale à la tension d'alimentation lorsque la sonde n'est pas activée.
Pour une sortie PNP, la résistance est branchée entre la masse et la sortie. Quand la sonde est activée, la tension doit être presque égale à l'alimentation et à 0V pour la sonde non activée 8-)
Bonsoir.
J'ai enfin trouvé les information sur le capteur.
C'est un capteur inductif TS12-02P-2.
Je vous donne le lien des caractéristiques
https://datasheet.octopart.com/TS12-02P-2-Highly-Electric-datasheet-17574692.pdf
C'est un PNP NO output (normally open).
J'ai vu l'image du circuit électrique correspondant, mais au vu de mes faibles connaissances en électricité, je ne comprend pas tout.
Pourriez-vous m'expliquer avec des mots, à quoi correspond exactement le branchement (par exemple les différents composants utilisés pour le montage) en bas à gauche sur la page 2 du lien.
Merci
 
S
speedjf37
Compagnon
15 Oct 2009
2 224
indre et loire
Bonsoir,

Un essai d'explication !

PNP transitor monté comme un contact sur le +
La charge se place entre la sortie et le -

NPN transitor monté comme un contact sur le -
La charge se place entre la sortie et le +

NO normalement ouvert au repos la charge n'est pas alimentée
NC normalement clos au repos la charge est alimentée

Mais il peut y avoir incompatibilité en le montage du capteur (PNP/NPN) et le circuit d'entrée commandé par un + ou par un -.
Ceci peut être résolu par une résistance de tirage ou par un montage inverseur .

JF
 
osiver
osiver
Compagnon
7 Sept 2013
12 024
C'est un PNP NO output (normally open).
Non, normally close, le dernier 2 de la référence :wink:
Pourriez-vous m'expliquer avec des mots, à quoi correspond exactement le branchement (par exemple les différents composants utilisés pour le montage) en bas à gauche sur la page 2 du lien
Dans le schéma ci-dessous et en suivant ce que vous indiquez avoir fait, le fil marron (1) est au plus de la pile 9V. Le fil bleu (3) est au moins de la pile 9V ET au GND de l'arduino. Le fil noir (2) est à l'entrée de l'arduino.

STOP! Ne branchez rien et lisez la suite.

Fonctionnement :
1 - si le capteurest activé la sortie 2 est en l'air = comme si le fil était coupé
2 - si le capteur n'est pas excité, le fil noir est relié au fil marron
Ce sont deux cas défavorables voire dangereux pour l'arduino. Premièrement Load n'existe pas MAIS l'entrée de l'arduino a sans doute une résistance de pull-up entre son entrée et le +5V de l'alimentation de l'arduino. Du coup, dans le cas 1, la sortie qui devrait être à 0V tirée par la charge (load) se trouve au +5V par la résistance de pull-up. Le signal d'entrée est faussement à 1 au lieu de 0
Deuxièmement, dans le cas 2, la sortie est amenée au +9V mais l'arduino ne supporte pas plus de 5V sur son entrée, vous avez de bonnes chances de griller l'entrée :cry:
Screenshot_2019-02-28 Description - TS12-02P-2-Highly-Electric-datasheet-17574692 pdf.png
 
Dernière édition:
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #24
Bonsoir,

Déjà merci à tous pour votre aide et vos explications.
J'ai enfin réussi le montage. Je vous ai fait un dessin car cela sera probablement plus clair que des mots.
Si vous avez une question n'hésitez pas.:wink:
Et encore merci:-D osiver speedjf37 jpbbricole Hubert86

montage.png
 
H
Hubert86
Compagnon
29 Nov 2017
577
La tu nous a fait un diviseur de tension, mais une question la résistance de droite c'est une résistance fixe ou un potentiomètre. 2 eme question est ce que ça fonctionne? la tension que tu appelle adaptateur secteur qu'elle valeur? et quel tension en sortie capteur?
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #26
Oui, en effet je communiquais également sur le forum Arduino et une personne m'a conseillé de faire ça, un pont diviseur.
Quand à la question sur la résistance fixe ou potentiomètre, je ne suis pas sure. C'est les deux mêmes résistances 10Khoms chacune ( avec des traits marron, noir, orange, et un or fin).
L'adaptateur secteur délivre une tension de sortie de 9V et 500 mA.
Et la réponse à la grande question : OUI ça FONCTIONNE :smt038:roxxx::7dance:
 
N
Nessa
Nouveau
27 Août 2013
26
  • Auteur de la discussion
  • #27
VIVE LA COLLABORATION ET VIVE L ENTRAIDE !!!!
 
H
Hubert86
Compagnon
29 Nov 2017
577
D’accord ton pont diviseur diminue par 2 ta tension donc tu es dans les normes Arduino, je pense que ta tension sortie est conditionné par ta tension d'alime, mais pour en être sure faudrait un contrôleur.
 
Sujets similaires Forum Date
Discussions générales sur la conception
Electricité, variateurs, convertisseurs et moteurs
Electricité, variateurs, convertisseurs et moteurs
Electricité, variateurs, convertisseurs et moteurs
Electricité, variateurs, convertisseurs et moteurs
Electricité, variateurs, convertisseurs et moteurs
Electricité, variateurs, convertisseurs et moteurs
Electronique spécifique CNC
Informatique (Hors usinage)
Bricolage (Hors usinage)
Machines laser
Machines laser
Electricité, variateurs, convertisseurs et moteurs
Electricité, variateurs, convertisseurs et moteurs
Electricité, variateurs, convertisseurs et moteurs
Haut