Premiere utilisation arduino + easydriver + moteur PaP

vibram
Compagnon
15 Mars 2014
3 446
FR-74
  • Auteur de la discussion
  • #1
Bonjour à tous et joyeuse pâque !

Je commence tout juste à utiliser l'ensrmble arduino + easydriver + moteur PaP car j'en avais dans une caisse
Le postulat: je n'ai aucune connaissance en électronique ni électricité
Pour débuter je me contente donc de reproduire des schémas simples pour comprendre les grands principes
Je me suis donc lancé la dedans
https://www.sparkfun.com/tutorials/400

Cependant cela ne fonctionne pas.
J'ai pris la tension (terme exact?) au bornes pwr in et grd de mon easy driver et j'ai 4.15 ce qui me semble correct
En revenche j'ai 0.02 sur les pin A+/- et 0.01 surB+/- de ma carte easy driver
Je suppose que le problème vient de la?
les soudures ne sont pas parfaites mais je n'ai pas limpression qu'il y ait de court circuit pour autant...
A noter que la LED 5v du driver est allumée lorsque l'alim est branchée
Bref je bloque un peu. Merci pour votre aide !
 
Dernière édition:
Didier-CN
Ouvrier
26 Mai 2014
257
Lyon
Le câblage n'a pas l'air brouillon, et autant qu'on peu en juger conforme aux indications de sparkfun, qui m'ont l'air correctes à 1° vue.

1° problème: l'alimentation se fait via une prise USB. Il y a fort à parier qu'elle est insuffisante pour le moteur. La tension risque de s'effondrer dès que le moteur va consommer. 4,15V, c'est déjà bas.

Il faut alimenter l'Arduino par sa prise jack (7 à 12V), la carte va générer du 5V.

Avant de mettre sous tension, identifier à l'ohmmètre les bobinages du moteur. Connecter ensuite le moteur en fonction de cela: 1 bobinage sur les bornes A, l'autre sur les bornes B. Ça a peu d'importance pour un test à vide.

Il serait bon d'en savoir un peu plus sur le moteur. A-t-il une étiquette?
 
gégé62
Compagnon
26 Février 2013
2 517
Harnes (Pas de Calais)
bonjour,
je démarre moi aussi en ce moment avec ce genre de manip Arduino+moteur PAP
Moteur PAP à 4 fils, en principe c'est donc du pipolaire, c'est à dire 2 bobines indépendantes (disposées à 90°) que l'on alimente tour à tour, et en inversant une fois sur deux le sens de l'alim.
As-tu déja bien repéré tes bobines à l'ohm-mètre ? la disposition que tu montres semble logique, mais c'est si facile de tester.

Au niveau du programme, ce serait étonnant qu'il y ait un bug, mais je suis étonné qu'il n'y ait pas un "delayMicroseconds(xxx)" entre la commande
digitalWrite(steppin, LOW) et
digitalWrite(steppin, HIGH), tout comme il y en a un après la mise à HIGH.
 
vibram
Compagnon
15 Mars 2014
3 446
FR-74
  • Auteur de la discussion
  • #7
Merci pour vos reponse
J'ai conservé le meme branchement en alim externe, j'ai presque 12v à l'entrée du driver mais toujours 0 en sortie
Je me demande si je n'ai pas brulé qqch avec mes soudures de bourin...
Je vais regarder sur internet pour savoir comment on teste le bobinage. Je n'ai aucune inscription sur les moteurs malheureusement
 
Didier-CN
Ouvrier
26 Mai 2014
257
Lyon
Je vais regarder sur internet pour savoir comment on teste le bobinage.
Ne pas prendre mal cette remarque, mais bricoler de l'électricité/ électronique sans avoir de notion aussi basique et en se basant sur internet, c'est un peu comme essayer de piloter un avion après avoir joué à un jeu vidéo.

Pour ne pas perdre trop de temps et ne pas faire de dégâts (voire se mettre en danger), il vaut mieux se faire accompagner par un ami (du vrai monde, pas de fesse-bouc). On pourra éventuellement aider, mais ça ne sera pas simple.

http://edusofad.com/www/demo/wscp-4011/demo/q1s307.php

Débrancher obligatoirement le moteur.

Quand la résistance sera infinie, c'est que la mesure sera faite entre 2 pôles de 2 bobinages différents. Quand elle sera faible, c'est que ce sera les 2 pôles d'un même bobinage.

Si on ne trouve que des résistances basses dans tous les cas de figure, le moteur est en court-circuit.

Si on trouve toujours l'infini, c'est que les bobinages sont coupés.

Et si on met les doigts, on mesure la résistance du corps humain dans les cas où on devrait trouver une résistance infinie.
 
vibram
Compagnon
15 Mars 2014
3 446
FR-74
  • Auteur de la discussion
  • #9
J'ai de très vagues restes de l'école ainsi que l'aide ponctuelle de mon père.
Je pense avoir réussi a identifier les deux bobinages (la valeur passait de 0 à X selon les bornes choisies, j'en conclue que la meme bobine était lorsque la valeur devenait X

Je ne prends pas mal cette remqrque. C'est juste que quand on est issu d'un monde totalement différent, ce n'est pas évident de trouver les personnes qui ont les compétences et l'envie d'aider. Résultat j'essaie de me débrouiller par moi même...

Je vais tester avec mon autre driver, histoire de...
 
vibram
Compagnon
15 Mars 2014
3 446
FR-74
Eureka.
Donc c'est donc bien le driver qui ne fonctionne pas correctement. Ca ne m'etonne qu'a moitié car je n'avais qu'un enorme fer à souder, pas du tout adapté à mon utilisation...
Je vais voir pour acheter un fer un peu mieux et essayer de reprendre les éléments du driver defaillant.
Merci pour le coup de main, j'ai appris de nouvelles choses !
 
Didier-CN
Ouvrier
26 Mai 2014
257
Lyon
Un petit lien pour la soudure:
http://www.sonelec-musique.com/electronique_bases_tutoriel_soudure.html

Fred, on ne peut simplement pas comparer planter un clou et se frotter à l'électricité et l'électronique. D'une part, il y a quand même un minimum de bases théoriques à assimiler, d'autre part avec un marteau et un clou, on ne risque que son doigt (ou si on est prévoyant, celui du disciple :-D). Avec l'électricité ou l'électronique, les conséquences peuvent être plus lourdes.
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut