Aide Ecran LCD I2C 20x4

  • Auteur de la discussion Nono.60
  • Date de début
Nono.60
Nono.60
Ouvrier
30 Avr 2010
293
Meru (60)
  • Auteur de la discussion
  • #1
Bonjour tous le monde,
J'ai suivi avec grand intérêt le post de Precis84 au sujet de son écran LCD I2C,
par contre moi mon problème actuellement, c'est que je l'ai brancher sur 2 Uno et une mega 2560
et j'ai lancer un scan pour connaitre l'adresse et rien, y t'il quelque chose de spécial à faire.
merci pour vos réponses,
bonne journée à vous,
WP_20170116_001.jpg
WP_20170116_002.jpg
si quelqu'un a une idée, l’écran est neuf je l'ai reçu samedi.:cry:
 
J
jjdu33
Compagnon
2 Jan 2013
1 153
F-33
bjr,

tu t es planté dans tes connections :

i2c_03.png

bonne bricole

jj
 
pinou29
pinou29
Compagnon
18 Mar 2009
2 877
Toulon ( Var )
Bonjour.
Je ne connais pas cet afficheur d'où ma question sûrement ridicule mais il n'y a pas de réglage de contraste sur ces modèles ?
Bernard.
 
G
gaston48
Compagnon
26 Fev 2008
9 633
59000
mais il n'y a pas de réglage de contraste sur ces modèles
Très bonne remarque au contraire, moi aussi je pensais qu'il ne marchait pas et en fait tout était illisible car
le réglage du contraste était saturé.
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Je ne connais pas cet afficheur d'où ma question sûrement ridicule mais il n'y a pas de réglage de contraste sur ces modèles ?
Oui, Excellent réflexion, je me suis fait avoir une fois et j'ai perdu pas mal de temps:smt038
C'est la vis
upload_2017-1-17_12-10-23.png


Cordialement
jpbbricole
 
Nono.60
Nono.60
Ouvrier
30 Avr 2010
293
Meru (60)
  • Auteur de la discussion
  • #8
bonsoir tous le monde,
Je rentre du boulot et je vois qu'il y a du monde sur le coup,
donc pour répondre aux questions, d’après mes recherche sur le net
c'est un PCF8574AT et l'adresse devrait être 0x3F.
mais quand je lance un I2C scan, j'ai rien dans le moniteur série
pour info j'ai commander en même temps un module I2C pour monter sur un LCD 16x2
et le scan me trouve l'adresse 0x27.
je poste les photos du dos de l’écran, du réglage contraste, et d'un téléchargement de programme,
dans l'attente de vous lire bonne soirée.

WP_20170117_001.jpg
WP_20170117_002.jpg
WP_20170117_004.jpg
 
jpbbricole
jpbbricole
Compagnon
26 Mai 2016
2 248
Corsier-sur-Vevey (Vaud)
Salut Nono.60

Au vu de tout ça, je ferais un test des soudures, avec une loupe, des fois qu'ily en aurait une défectueuse, voire un court-circuit. Après ça, il ne reste, pour moi, plus que mettre ton affichage à la poubelle ou si tu as le courage, changer l'interface i2C, j'ai bien l'impression que c'est là qu'est le problème.

Cordialement
jpbbricole
 
P
Precis84
Compagnon
7 Déc 2008
2 169
Bonsoir
Tu pourrais éventuellement essayer la connexion A4 et A5 pour l'I2C ?
claude
 
C
chris.maximilien
Nouveau
13 Nov 2017
43
La Rochelle
Je reprends ce post qui date un peu, mais ça peut toujours servir à quelqu'un d'avoir une solution.

Pour avoir déjà bien galéré sur ces écrans, il peut être bien de demander au programme de chercher au delà de 127. Je me suis déjà fait avoir... Si on demande 250 on trouve parfois le capteur...

Sinon à coup sur c'est la librairie qu'il faut changer à condition d'avoir bien vérifié les connections!

Salut.
 
Nono.60
Nono.60
Ouvrier
30 Avr 2010
293
Meru (60)
  • Auteur de la discussion
  • #12
Bonsoir
chris.maximilien merci pour ce détérrage de post,
mais après plusieurs recherches, c'est l'ecran que j'avais commander qui avait un problème.
il a été remplacer, j'ai fait un scan pour trouver l'adresse et depuis plus de problèmes.
mais je note quand meme , on ne sais jamais peu etre qu'un jour j'en aurai besoin.
Cordialement. :smt039
 
C
chris.maximilien
Nouveau
13 Nov 2017
43
La Rochelle
OK, content que le problème soit résolu.

Pour info, cette astuce fonctionne sur tous les capteurs I2C.

A bientôt.
 
Haut