Courbes à la place d'angles droits

  • Auteur de la discussion Seb K
  • Date de début
S
Seb K
Nouveau
5 Avr 2019
34
  • Auteur de la discussion
  • #1
Bonjour,

J'ai mis à niveau une petite commande numérique UPA Vario avec une nouvelle electronique. Remplacement de la carte mère d'origine par des drivers DM542 chinois ainsi qu'une BOB //
J'ai réussi à récuperer la plupart des fonctionnalités de la machine et elle fonctionne plutôt bien mais ...
Certains angles de mes usinages sortent abitrairement en courbe notemment les coins mais pas que.
Comme une illustration est parfois plus parlante que de longs discours j'ai ajouté en PJ le petit jeu des différence :) ainsi que le fichier G-code généré par freecad.
Quelqu'un peut il m'expliquer ce phénomène ?

Merci d'avance
IMG_20200127_074238.jpg
gmoccapy.png
 
Fichiers joints
vax
vax
Modérateur
5 Mar 2008
7 943
Guipavas (près de Brest)
Ajoute un G61 (trajectoire exacte, avec arrêt aux changements) dans ton entête pour voir si cela change quelques chose.
Tu vas perdre en vitesse mais si cela résout ton problème tu pourras remplacer par un G64 Px.xx qui autorisera une erreur de parcours de x.xx pour améliorer la vitesse de trajectoire en arrondissant (au maximum de x.xx) ton parcours.
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 992
FR-28360
Bonjour,
Houla ! Ce choix entre bousiller les angles vif ou avoir une machine qui broute me surprend toujours.
Le g-code est tout à fait correct :
1580116934049.png


Tu dois avoir des accélérations très faibles.
 
vax
vax
Modérateur
5 Mar 2008
7 943
Guipavas (près de Brest)
Le g-code est tout à fait correct :
Je veux bien que tu m'éclaircisses, je suis étonné de ne pas trouver dans ce que je vois du Gcode (la copie d'écran) d'ordre définissant la politique de trajectoires...
De ma petite expérience, si je ne colle pas un G64 P... mes trajectoires sont assez "smooth" :wink:

Mais encore une fois, je ne prétend pas avoir LA méthode idéale (j'en apprend encore tous les jours...).
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 992
FR-28360
A ma connaissance, le G64 n'existe que sur LinuxCNC ou Mach3 qui reprend le même pilotage.
 
S
Seb K
Nouveau
5 Avr 2019
34
  • Auteur de la discussion
  • #6
Super, merci beaucoup pour cette réponse rapide. J'ai fais le test ça fonctionne impeccable. Me reste à voir comment implémenter le G61 automatiquement dans freecad.
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 992
FR-28360
Plus le accélérations sont faible et plus les arc de lissage sont grands.
 
S
Seb K
Nouveau
5 Avr 2019
34
  • Auteur de la discussion
  • #9
que je dois configurer dans le fichier .ini ?
 
AndersFaust
AndersFaust
Ouvrier
1 Août 2019
456
Ca tombe bien, je viens d'avoir le même soucis

Lors de la première passe en fraise de 6mm, j'ai eu de jolies courbes à certains endroits

IMG_20200131_135400.jpg


du coup après quand la fraise de 1mm pour les finition passe ... il reste de ilots :wink: non mais oh!

Bref j'utilise aussi LinuxCNC et j'ai lu ca


Comme disait @vax il semblerait que ce soit liée a la tolérance de trajectoire, qui permet de ne pas trop altéré la vitesse dans certaines courbes agressives, et les options sont:

Soit tu passes tout en G61 et tu aura des chemin nets (avec perte brutale de vitesse)
Ou alors tu reste en G64, mais tu réduit la tolérance G64 Px.xxx

Moi je m'en vais regarder dans mon SolidCAM si je peut pas directement le régler pour les coupes à venir, pas envie d'y penser à chaque fois.
 
Dernière édition:
Haut