1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Forcer la carte graphique en mode VESA

Discussion dans 'EMC2 / LinuxCNC' créé par telson, 26 Mars 2015.

  1. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
    Forcer la carte graphique en mode VESA
    Bonjour,

    Après moultes recherches, je me permets de vous demander si quelqu'un pourrait m'aiguiller?

    Je souhaiterais passer ma carte graphique en mode VESA et selon les informations sur ce site :

    http://www.civade.com/post/2011/10/12/Astuces-et-configurations-pour-Ubuntu-10.04-avec-EMC2

    il faut dans les options de démarrage du noyau courant, enlever l'utilisation du mode VESA pour le mode texte du noyau (vous savez, 50 lignes par page en mode texte).

    Pour ce faire, editer grub.cfg et ajouter 'nomodeset' en option de kernel.

    Mais impossible de trouver la ligne : linux /boot/.... ro quiet splash". Greeeee????

    Quelqu'un pourrait t'il me donner la syntaxe exacte de la ligne à modifier et la syntaxe exacte après modification s'il vous plaît.

    Merci par avance.

    J'utilise LinuxCNC 2.6 (Debian Wheezy LinuxCNC), source : http://www.linuxcnc.org/index.php/english/download

    Merci par avance.
     
    Dernière édition par un modérateur: 16 Avril 2015
  2. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
    Forcer la carte graphique en mode VESA
    heu...............décidément je galère !!

    Lorsque j'ouvre un terminal admin, je saisi mon mdp.....puis je saisi : sudo vi /boot/grub/grub.cfg

    Le ficher s'ouvre avec un jolie rectangle vert mais il m'est impossible de modifier le fichier !!!????

    houlalalalalalala !!!!

    doit on :

    - - Supprimer « quiet splash --» avec la touche de retour backspace, et inscrire « nomodeset xforcevesa ». Attention à laisser un espace entre nomodeset et xforcevesa .

    - - sur la ligne "linux /boot/.... ro quiet splash" de la permière entrée bootable, ajouter nomodeset à la fin

    Merci par avance.
     
  3. jblb72

    jblb72 Apprenti

    Messages:
    102
    Inscrit:
    12 Février 2010
    Localité:
    Le Mans, ou presque
    Forcer la carte graphique en mode VESA
    Bonjour,
    Tu travail avec quelle version de linuxCNC ? parce que dans ce que tu cite il y a du changement dans les dernieres versions.
     
  4. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
    Forcer la carte graphique en mode VESA
    bonjour,

    J'utilise LinuxCNC 2.6 (Debian Wheezy LinuxCNC) téléchargé ici : http://www.linuxcnc.org/index.php/english/download

    Pas facile les débuts mais je m'accroche.....Mes moteurs tournent, c'est déjà ça.....

    Mais avant d'aller plus loin dans les investissements je préférerai avoir quelque chose de bien configuré. Car sans ça, je doute que le résultat final soit au rendez vous avec des pertes de pas et autres misères du genre....

    Merci par avance.
     
    Dernière édition par un modérateur: 16 Avril 2015
  5. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
    Forcer la carte graphique en mode VESA
    Bon et bien je n'y arrive toujours pas !!!

    Et ce même en suivant les instructions du WiKi au paragraphe : 5. Display Issues, 5.1. Using Vesa Drivers : http://wiki.linuxcnc.org/cgi-bin/wiki.pl?TroubleShooting

    Dès les premières instructions : sudo service gdm stop

    Je me retrouve avec un message d'erreur :

    gdm unrecognized service

    Et pourtant je fais comme indiqué sur le WiKi :
    1. CTRL + ALT + F1
    2. je rentre mon login
    3. je rentre mon mot de passe
    j’obtiens le message suivant :

    Last login : ........... CEST 2015 on tty1
    Linux debian 3.4-9-rtai-686-pae #1 SMP PREEMPT Debian 3.4.55-4linuxcnc i686

    the programs included .......blablabla......, to the extent permitted by apllicable law

    A l'écran s'affiche alors : monutilisateur@debian:~$

    c'est à ce moment que je saisie les commandes : sudo service gdm stop et que j'obtiens le message d'erreur gdm unrecognized service

    J'ai également essayé avec sudo service xdm stop et sudo service kdm stop...............Mais sans succés !!

    Quelqu'un pourrait t'il me sortir de ce mauvais pas?

    Merci par avance.
     
  6. jblb72

    jblb72 Apprenti

    Messages:
    102
    Inscrit:
    12 Février 2010
    Localité:
    Le Mans, ou presque
    Forcer la carte graphique en mode VESA
    Bonjour,
    je n'ai pas de Debian Wheezy LinuxCNC sous la main mais je crois que gdm a tété abandonné et que maintenant c'est lightdm qui est sur les distros debain.
    teste donc « sudo service lightdm stop » en lieu et place de « sudo service gdm stop »

    Après tu suis le lien que tu donnais.
     
  7. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
    Forcer la carte graphique en mode VESA
    Ha bon ok.....Incroyable mais cela vient de fonctionner.....elle sort d'où cette commande ??

    Par contre : sudo Xorg -configure --> number of created screens does not match number of detected devices. configuration failes. Server terminated with error (2). Closing log file.

    Et donc forcément la commande suivante : sudo mv ~/xorg.conf.new /etc/X11/xorg.conf -->mv: impossible d'évaluer <</home/telson/xorg.conf.new>> : Aucun fichier ou dossier de ce type.

    HIHAaaaaaaaaaaaaaaaaaaaaaaaaaa !!!
     
  8. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
    Forcer la carte graphique en mode VESA
    Re revoici avec des nouvelles :

    Lorsque je crée un fichier : xorg.conf et que je place dans : section "Device" sous Driver "vesa", au redémarrage j'ai un écran noir avec un petit curseur blanc et c'est tout!!!!

    ça marche pas en fait.

    voici mon fichier modifié :

    Est ce normal d'avoir 3 Section "Monitor"

    Est ce normal d'avoir 3 Section "Device"
     
  9. jblb72

    jblb72 Apprenti

    Messages:
    102
    Inscrit:
    12 Février 2010
    Localité:
    Le Mans, ou presque
    Forcer la carte graphique en mode VESA
    bon j'ai une connexion en carton jusqu’à mardi ou mercredi. je te répondrai plus tard mais tu semble être sur la bonne voie
     
  10. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
  11. jblb72

    jblb72 Apprenti

    Messages:
    102
    Inscrit:
    12 Février 2010
    Localité:
    Le Mans, ou presque
    Forcer la carte graphique en mode VESA
    Me revoilà
    tu n'aurais pas trois sorties sur ta carte vidéo ? VGA / DVI / SVidéo

    sinon pour ton fichier xorg.conf remet "fbdev" là il il était et relance la machine, d'ailleur les sections que tu ne change pas tu devrais pouvoir les enlevées de ton fichier et donc laisser juste
    Code:
    Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
    ### <percent>: "<f>%"
    ### [arg]: arg optional
    #Option "NoAccel" # [<bool>]
    #Option "SWcursor" # [<bool>]
    #Option "Dac6Bit" # [<bool>]
    #Option "Dac8Bit" # [<bool>]
    #Option "BusType" # [<str>]
    #Option "CPPIOMode" # [<bool>]
    #Option "CPusecTimeout" # <i>
    #Option "AGPMode" # <i>
    #Option "AGPFastWrite" # [<bool>]
    #Option "AGPSize" # <i>
    #Option "GARTSize" # <i>
    #Option "RingSize" # <i>
    #Option "BufferSize" # <i>
    #Option "EnableDepthMoves" # [<bool>]
    #Option "EnablePageFlip" # [<bool>]
    #Option "NoBackBuffer" # [<bool>]
    #Option "DMAForXv" # [<bool>]
    #Option "FBTexPercent" # <i>
    #Option "DepthBits" # <i>
    #Option "PCIAPERSize" # <i>
    #Option "AccelDFS" # [<bool>]
    #Option "IgnoreEDID" # [<bool>]
    #Option "CustomEDID" # [<str>]
    #Option "DisplayPriority" # [<str>]
    #Option "PanelSize" # [<str>]
    #Option "ForceMinDotClock" # <freq>
    #Option "ColorTiling" # [<bool>]
    #Option "VideoKey" # <i>
    #Option "RageTheatreCrystal" # <i>
    #Option "RageTheatreTunerPort" # <i>
    #Option "RageTheatreCompositePort" # <i>
    #Option "RageTheatreSVideoPort" # <i>
    #Option "TunerType" # <i>
    #Option "RageTheatreMicrocPath" # <str>
    #Option "RageTheatreMicrocType" # <str>
    #Option "ScalerWidth" # <i>
    #Option "RenderAccel" # [<bool>]
    #Option "SubPixelOrder" # [<str>]
    #Option "ClockGating" # [<bool>]
    #Option "VGAAccess" # [<bool>]
    #Option "ReverseDDC" # [<bool>]
    #Option "LVDSProbePLL" # [<bool>]
    #Option "AccelMethod" # <str>
    #Option "DRI" # [<bool>]
    #Option "ConnectorTable" # <str>
    #Option "DefaultConnectorTable" # [<bool>]
    #Option "DefaultTMDSPLL" # [<bool>]
    #Option "TVDACLoadDetect" # [<bool>]
    #Option "ForceTVOut" # [<bool>]
    #Option "TVStandard" # <str>
    #Option "IgnoreLidStatus" # [<bool>]
    #Option "DefaultTVDACAdj" # [<bool>]
    #Option "Int10" # [<bool>]
    #Option "EXAVSync" # [<bool>]
    #Option "ATOMTVOut" # [<bool>]
    #Option "R4xxATOM" # [<bool>]
    #Option "ForceLowPowerMode" # [<bool>]
    #Option "DynamicPM" # [<bool>]
    #Option "NewPLL" # [<bool>]
    #Option "ZaphodHeads" # <str>
    Identifier "Card0"
    Driver "vesa" # ici avant il y avait "radeon"
    BusID "PCI:1:5:0"
    EndSection
    
     
  12. telson

    telson Apprenti

    Messages:
    54
    Inscrit:
    30 Janvier 2015
  13. bipbip30

    bipbip30 Compagnon

    Messages:
    2 380
    Inscrit:
    23 Décembre 2012
    Projets:
    H130 De Vallière en cours
    Département:
    30
  14. Laurent_CNC

    Laurent_CNC Apprenti

    Messages:
    234
    Inscrit:
    26 Avril 2012
    Forcer la carte graphique en mode VESA
    Salut telson,

    Moi aussi je serais très intéressé par un tuto sur le passage en VESA de la version Wheezy...

    Merci d'avance :wink:
    Laurent en quête du graal du Latency test :)
     
Chargement...

Partager cette page