1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Apparition caractères spéciaux Importation Gcode (Résolu)

Discussion dans 'Mach' créé par vrul, 10 Février 2015.

  1. vrul

    vrul Nouveau

    Messages:
    6
    Inscrit:
    19 Novembre 2014
    Apparition caractères spéciaux Importation Gcode (Résolu)
    Bonjour,

    Je fais appel à votre aide pour résoudre un problème très étrange. Cela fait quelques mois que j'utilise Mach3 de la façon suivante : Je créé mes modèles sur SolidWorks, puis je prépare la fabrication sur MasterCam et enfin j'importe le Gcode (fichiers NC ou txt) dans Mach3. Jusqu'à présent je n'ai rencontré aucun problème.

    Aujourd'hui j'essaye d'importer un fichier NC dans Mach3 mais le logiciel me signale la présence de caractères spéciaux dans le code, remplaçant des chiffres.

    J'ai tout essayé, le fichier txt est bien propre, j'ai redémarré plusieurs fois l'ensemble machine-PC. On dirait que c'est Mach3 qui pourrit mes fichiers Gcode.

    Auriez-vous une idée de l'origine de l'erreur ?

    Merci beaucoup !

    :-D :-D
     
  2. dh42

    dh42 Compagnon

    Messages:
    3 976
    Inscrit:
    4 Septembre 2009
    Localité:
    Près de St Etienne (42)
    Apparition caractères spéciaux Importation Gcode (Résolu)
    Salut,

    Vérifie que le fichier texte contenant le Gcode est bien sauvé avec le type de codage: ANSI ; si par malheur il est en UTF-8, Mach3 ne comprends pas et affiche des caractères bizarres.

    [​IMG]


    ++
    David
     
  3. vrul

    vrul Nouveau

    Messages:
    6
    Inscrit:
    19 Novembre 2014
    Apparition caractères spéciaux Importation Gcode (Résolu)
    Merci beaucoup! Problème résolu grâce à ton aide! Désolé de ne pas avoir répondu rapidement
     

Partager cette page