Vitesse constante pas constante !

dh42
Compagnon
4 Septembre 2009
5 243
Près de St Etienne (42)
  • Auteur de la discussion
  • #1
Bonjour à tous,

Je me suis battu avec Mach3 pendant un moment suite à un problème bizarre.

Même en mode Vitesse constante (constant velocity = G64) la machine donnait des à coups à chaque passage d'une ligne à l'autre du Gcode, exactement comme si elle était en mode Exact Stop (G61) ... catastrophique dans les splines bien sur :roll:

Après avoir contrôlé la présence du G64 en début de programme, j'ai alors essayé toutes les fréquences de sortie de Mach, sans résultat ... pas de vitesse constante. :?:

J'ai fini par trouver le problème, il s'agit d'un réglage dont je ne connais pas l'utilité, et qui se trouve sur la page Settings (alt6). Il y a deux boutons nommés CV distance et CV feedrate, ils étaient actifs (LED allumées). Il m'a suffit de les désactiver tous les deux pour régler le problème.




Un détail découvert au passage en faisant des expériences une fois le réglage ok.

Le mode vitesse constante ne se comporte pas de la même manière si vous avancez à la vitesse normale ou si vous êtes en survitesse.

Ex: si j'ai un Gcode avec une avance à 1000 mm/min et que je pousse à 2500 via le curseur de l'écran de Mach j'ai des à coups, alors qu'il n'y en à pas pour la même vitesse de 2500 si c'est la vitesse programmée dans le Gcode :roll: (le même fichier bien sur)

Voila, si ça peut servir à quelqu'un :wink:

++
David
 
dh42
Compagnon
4 Septembre 2009
5 243
Près de St Etienne (42)
  • Auteur de la discussion
  • #3
valentin a dit:
:-D bonjour
Je tiens a te remercier pour toute tes infos
surtout pour la prise Home

viens de lire ton spot et je mapercois
que le led CV distance est allume
par contre meme si je eteint et sauve le setting
quand je relance Mach3 il est a nouveau allume

:?: Pourquoi ?

++ :-D
Bonsoir Valentin,

Exact, je n'avais pas vu .. :oops:

Pour clouer le bec à CV distance, vas dans la config. générale (menu Config/general config) et décoche le paramètre CV dist. tolerance montré sur l'image.

++
David

cvdist.jpg
 
dh42
Compagnon
4 Septembre 2009
5 243
Près de St Etienne (42)
  • Auteur de la discussion
  • #5
valentin a dit:
:-D Bonjour
:supz: jai vu que tu as traduit Cambam
connait pas du tout
sais til piloter le 4eme axe(Axe a)
car je voudrais usiner un fichier Stl par rotation

Merci pour la reponse
++
Salut,

Non, pour l'instant Cambam ne gère que 3 axes, il est possible de faire du "double face" en usinage 3D (ou plus de deux faces moyennant bidouille), mais le mandrin ne tourne pas pendant l'usinage.

++
David
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut