retour home entre chaque opération

  • Auteur de la discussion fredobob
  • Date de début
F
fredobob
Apprenti
21 Sept 2018
125
  • Auteur de la discussion
  • #1
Bonjour,
J'utilise un cnc 6040 équipée de Mach 3. jusqu’à présent lors de l'usinage d'une pièce 'exemple un pignon , la broche exécutait les actions les unes après les autres et entre chaque , remontait en position de securité au dessus de la pièce , la broche s'arrêtait puis attendait que je la relance pour poursuive vers l'étape suivante...
Maintenant j'ai un petit souci, car au lieu de rester en sécurité au dessus de la pièce, elle repart vers sa position home, et au prochain ordre de poursuivre la broche descend puis va se positionner au dessus de la pièce, sauf que sur son chemin il y les brides....et crac!
Je ne vois pas ce qui a changer ou ce que je fais de mal pour qu'elle retourne à " home" et ne pas rester au dessus de la pièce.
Merci de bien vouloir m'aider
 
MegaHertz
MegaHertz
Compagnon
31 Août 2017
1 095
Bonjour,

Si tu mets un ancien prog maintenant, est ce qu'il y'a mise en sécurité entre chaque étape ?
Possible que ce soit le paramétrage de tes coordonnées pour le G28 qui ait changé.
 
F
fredobob
Apprenti
21 Sept 2018
125
  • Auteur de la discussion
  • #3
Merci pour ta réponse.je n'ai pas encore vérifié avec un ancien programme, mais je viens de relancer une dizaine de fois le même ''nouveau'' programme et parfois il y a mise en sécurité d'autre pas...c'est à n'y rien comprendre.
 
F
fredobob
Apprenti
21 Sept 2018
125
  • Auteur de la discussion
  • #5
voici une copie raccourcie du code; au deuxième m6 T1 la broche se retrouve au parking
 
JLuc69
JLuc69
Compagnon
19 Juin 2008
1 362
Genas (69)
C'est peut être une macro appelée par le M6...ou un paramétrage de mach3 au changement/appel de l'outil
De toute façon, il vaut mieux toujours commencer par se positionner en XY et APRES descendre en Z
 
F
fredobob
Apprenti
21 Sept 2018
125
  • Auteur de la discussion
  • #7
...''se positionner en XY et APRES descendre en Z ''
C'est aussi ce que je fais, xy puis z en zéro , je met tout à zéro en offset , puis retour en Home puis, rafraichiment de la fenêtre noire de visualisation de parcours d'outil (quel nom déja :smt017), et ensuite départ.
 
osiver
osiver
Compagnon
7 Sept 2013
11 764
Vous dites que la broche s'arrêtait en place pour attendre un ordre de reprise.
Mais dans ce que vous montrez, on ne voit pas la mise en pause, c'est où ?

Par contre M6 T1 déclenche en principe un changement d'outil, est-ce que votre broche ne va pas se mettre en position de changement d'outil ?
 
F
fredobob
Apprenti
21 Sept 2018
125
  • Auteur de la discussion
  • #10
je n'ai pas inséré de pause ici, dans mes précédantes réalisations, le M6 T1 était à la position de securite (1cm ) au dessus du dernier tour de broche
 
F
fredobob
Apprenti
21 Sept 2018
125
  • Auteur de la discussion
  • #11
je vais vérifier...
 
F
fredobob
Apprenti
21 Sept 2018
125
  • Auteur de la discussion
  • #12
-Bon j'ai coché "Ignore tool change" et la broche ne revient plus à sa position home...je vais rester la dessus.
-Question subsidaire: avant d'effectuer une tache d'usinage la broche descend dabord en Z avant de se positionner en XY, y a t'il un moyen de lui demander d'aller en xy et ensuite Z?
Merci
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut