Advertisements

réglage Machine problème

Gaamma
Gaamma
Nouveau
5 Août 2018
47
  • Auteur de la discussion
  • #1
Bonjour à tous.:)

Je suis nouveau dans le monde « fascinant des CNC » et déjà u besoin de vos conseils qui mon bien aider, encore merci à Jpbbricole et Hubert86 :smileJap:
J’ai fabriqué ma CNC avec 80% de matériel de récupération et cela ma couté moins de 200euro.

Elle a l’air de fonctionner correctement, elle répond bien a GRBL et Universal Gcode sender (axes X, Y, Z, remise à zéro, origine machine)
J’ai respecté la direction des axes (X- / X+, Y- / Y+, Z- / Z+.
J’ai posé des capteurs de fin de coures sur les axes (X- / X+, Y- / Y+, et Z+.


Matériels utiliser : Nema17, TB 6600, Arduino Uno, pour les axes X et Y courroie crantée S2M GT2 MXL, Poulie GMT22 (16 dents) pour l’axe Z tige filetée 10mm inox, alim 24 V.

Par contre j’ai quelques soucis :

:?: Quand je fais un retour en position 0, l’axe Z monte (Z+) et ne déclenche pas le capteur de fin de course, j’ai bien sur testé le capteur et les connections sur l’arduino (broches 12 et masse) tout et ok ??

Si je fais un retour en position d’origine l’axe Z ne bouge pas.

:?: J’ai voulu testé un fichier Gcode j’ai donc suivi le tuto de Jpbbricole très bien expliqué, mais ma CNC par et se bloqué sur un capteur de fin de course avec un message d’erreur, voir photo ?? j’ai du passé a coté de quelque chose !!

Voila mon souci, Merci par avance pour votre aide et bonne journée :-D

info.jpg
 
Advertisements
D
Doctor_itchy
Compagnon
20 Avr 2007
4 330
Morlanwelz
donc le signal recu dans le soft c'est celui d'un fin de course ! (hardlimite c'est le capteur de fin de course , softlimit c'est la limite calculée par le soft )

donc ton capteur fonctionne , mais quand tu remonte sur z il se cale dessus et se coupe , attitude normal c'est fait pour ... en gros tu veut faire un homing sur une fin de course ? , dans les souvenir il faut dans le code meme de l'arduino vérifier tout cela ! et j'ai eu des soucis de configuration avec les fin de course et homing ( sur uno ! ) je n'ai que deux capteur de fin de course qui sont les hardlimit ET homing , j'ai du pas mal chipoté le code pour que cela fonctionne , il faudrais que je regarde si je retrouve ma config et voir ce que j'ai fait , mais c'est vrais qu'il a falu du temps pour trouver l'astuce sinon pas de homing mais un hard limit :) si je retrouve cela je mettrais le fichier en lien :wink:
 
D
Doctor_itchy
Compagnon
20 Avr 2007
4 330
Morlanwelz
aussi avant ton fichier gcode tu a lancer le homing manuellement ? ou la machine le fait tout seul ?
 
Gaamma
Gaamma
Nouveau
5 Août 2018
47
  • Auteur de la discussion
  • #4
merci à vous, la machine le fait tout seul !
:)
 
Gaamma
Gaamma
Nouveau
5 Août 2018
47
  • Auteur de la discussion
  • #6
non ! c'est comme sur la photos plus haut, et après un reset soft et un déverrouillage, je reprend la main.
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 268
FR-28360
G4P0 ça veux dire qu'il faut faire une pause de 0 milleseconde donc completement inutile.
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 268
FR-28360
C'est peut-être tout simplement cette ligne qui ne passe pas, il faut essayer de l'enlever avec un éditeur de texte.
 
Gaamma
Gaamma
Nouveau
5 Août 2018
47
Bonjour à tous.:)
merci CNCSERV, mais rien y fait !!
Par contre j'ai trouvé le problème du capteur de fin de course de l'axe Z+, le câblage étais défectueux.
j'ai passé je sais pas combien d'heures !! a fabriqué cette CNC qui est maintenant fonctionnel et je suis bloqué pour une histoire de logiciel
.................. c'est rigolo. :smt022
 
La dernière réponse à ce sujet date de plus de 6 mois
Advertisements
Haut