problèmes fins de course

  • Auteur de la discussion cncsiste
  • Date de début
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #1
fin de course 00.jpg
bonjour,
est-ce que quelqu'un parmis vous a le shéma de ce type de fin de course, car je les ai testé et il y a des choses que je ne comprends pas.
J'ai bien trouvé un shéma mais ça ne correspond pas à mon modèle
et comme je ne sais toujours pas faire fonctionner cette machine j'ai un petit doute de ce côté là. Elle fonctionne en manuel, mais après fini
Donc, il y a deux résistances, un condo et une led + le fin de course mécanique
 
S
speedjf37
Compagnon
15 Oct 2009
2 274
indre et loire
Bonjour,

GND 0V masse ou moins alim 5V
VCC +5V
OUT sortie signal fin de course

Une led sur la carte indique l'état du fin de course

Cordialement JF
 
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #3
oui, merci
ce qui m'intéresse serait d'avoir le shéma, car quand je fais les mesures il y a une des résistances (R1 : 1k) qui est en court-circuit quand le fin de course est au repos, ce qui me semble curieux
 
Dernière édition:
?
******
Compagnon
6 Jan 2014
2 881
paris
normalement si ta led s'alume quand tu presse dessus ... cest ok...

apres tu peu confirmer le fonctionnement et voir ce qui ce passe (la tension quant tu clique dessus) entre out et gnd.

pas besoin de shema ..

jc
 
?
******
Compagnon
6 Jan 2014
2 881
paris
tu peu aussi envoyer le code "M119" et tu devrai avoir une reponse comme :
x_max: open
y_max: open
z_max: open

jc
 
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #7
merci pour le shéma, ça correspond. J'ai regardé vite fait, ils sont équipé avec deux modèles de simple inverseur si je comprend bien.
Ceux que j'utilise sont tous à l'état haut + 5V quand ils sont au repos (vérifié), donc c'est peut-être dans Marlin que j'ai un souci, parce qu'il m'a semblé lire quelque part que selon le type de fin de course, état haut où état bas selon le modèle il fallait valider 1 où -1,
mais je ne sais plus pour quel modèle on met 1 où -1
 
F
fabrice c
Compagnon
19 Juin 2008
3 139
reunion
c'est dans configuration.h

false pour des NC
true pour des NO

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
const bool X_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Z_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
 
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #9
merci Fabrice C,
entre temps j'avais trouvé, un peu par chance surement
donc là maintenant elle parle, je me suis rendu compte que le pololu (je crois que c'est le nom) de l'axe z chauffe un peu, logique il y a deux moteurs, alors j'ai fait une modif, maintenant il y en a deux, l'un au dessus de l'autre et c'est ok
c'est un peu l'aventure, ces imprimantes 3D
 
Dernière édition:
C
cr-_-
Compagnon
29 Sept 2009
869
FR-31 Plaisance du touch
heu tu as souder deux polulu l'un sur l'autre ? et ça marche sans rien griller :shock:
 
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #11
salut cr-_-,
j'ai pas vu ta réponse tout de suite, du fait que l'on descend très vite dans la liste
oui, j'ai monté deux drivers l'un au dessus de l'autre du fait que mes moteurs sont donnés pour une conso d'1.4 Amp théorique chacun
quand on voit la section des pattes de la puce qui constitue le pololu, je me suis dit je vais pas prendre de risque
ils sont emboîté l'un au dessus de l'autre comme la disposition d'origine et même démontable, je peux revenir à la configuration de base
avec un seul c'etait un peu juste, perte de pas, maintenant les deux moteurs restent super bien synchronisés
je pensais faire un petit tuto, mais bon maintenant c'est monté
 
pierrelouison
pierrelouison
Apprenti
1 Déc 2014
85
au fond de mon atelier :), Liffré
salut cr-_-,
j'ai pas vu ta réponse tout de suite, du fait que l'on descend très vite dans la liste
oui, j'ai monté deux drivers l'un au dessus de l'autre du fait que mes moteurs sont donnés pour une conso d'1.4 Amp théorique chacun
quand on voit la section des pattes de la puce qui constitue le pololu, je me suis dit je vais pas prendre de risque
ils sont emboîté l'un au dessus de l'autre comme la disposition d'origine et même démontable, je peux revenir à la configuration de base
avec un seul c'etait un peu juste, perte de pas, maintenant les deux moteurs restent super bien synchronisés
je pensais faire un petit tuto, mais bon maintenant c'est monté
bonjour,

Justement, quand j'ai reçu ma carte Ramps, le double connecteur moteur des Z sur un seul Pololu, j'ai eu la même réaction.
ma réflexion m'a porté vers un choix de moteur a ampérage inférieur (2x0.4 amp), considérant que sur une Prusa i3 l'axe des Z n'est pas sollicité outre mesure.

Si ma solution sous-équipe l'imprimante, la tienne ne la surcharge pas trop coté électrique ?

tu saurais nous différencier avantages et inconvénients des 2 méthodes ? (j'y connais finalement pas grand chose)

cordialement,

Pierrelouison
 
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #13
pololu02.jpg
M D = moteur droit, M G = moteur gauche
bonjour,
moi, j'ai pas changé les moteurs donc la conso reste pareille à la petite différence près qu'avec deux moteurs en parallèle l'impédance n'est plus la même ainsi que la valeur selfique des moteurs
là au moins chaque drivers s'occupe de son moteur, surtout que sur les pas à pas bipolaires, les changements de direction s'effectuent par des changement de polarité violents, ce qui n'est pas le cas des moteurs unipolaire et là au moins, si un des moteurs déconne il va me crâmer le driver correspondant, je ne devrais pas chercher
autrement au niveau consommation totale, avec un ampèremètre analogique les pointes de courant n'ont pas l'air trop importantes
cordialement
Xavier
 
M
MARECHE
Compagnon
6 Fev 2011
2 820
Nancy
Bonjour,
Sur ces drivers n'oubliez pas que le potentiomètre permet de régler le courant, qu'il est déconseillé de dépasser 2 ampères et qu'on peut coller un petit radiateur sur la puce, ca aide.
Salutations
 
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #15
bonsoir,
j'ai pas mis les radiateurs parce que je trouvais que ça ne servait pas à grand chose,
même si l'on considère un courant de 1 amp en 30 V tension de fonctionnement maximum du pololu et cela pour chaque sorties, il faudra que quelqu'un m'explique comment ont peut dissiper 60 W dans un radiateur alu qui fait 9 mm par 9 mm et en plus fixé sur le boîtier par un double face
 
Dernière édition:
pierrelouison
pierrelouison
Apprenti
1 Déc 2014
85
au fond de mon atelier :), Liffré
bonsoir,
j'ai pas mis les radiateurs parce que je trouvais que ça ne servait pas à grand chose,
même si l'on considère un courant de 1 amp en 30 V tension de fonctionnement maximum du Pololu et cela pour chaque sorties, il faudra que quelqu'un m'explique comment ont peut dissiper 60 W dans un radiateur alu qui fait 9 mm par 9 mm et en plus fixé sur le boîtier par un double face
bonjour,
{mode rigolo du bourg/on}
ben on fait pas, on dit qu'on fait ! :wink:
{mode rigolo du bourg/off}

je partage asse cet analyse, cependant, pour avoir monté des petits radiateurs comme ce que tu décris sur mes drivers (j'avais essayé avec de la graisse thermique avant, mais ayant fixé ma carte verticalement, et n'ayant pas monté de pince pour fixer le radiateur sur le composant (comme les proc des pc) cela faisait comme une motte de beurre dans une poêle qui chauffe) mais le résultat n'a pas été concluant, donc retour au double face....

on gagne quelques degrés sur la t° 'apparente', cela ne permet pas de dissiper un peu de calories ? car sans vouloir être absolu, un gain de quelques degrés ne permet-il pas de s'éloigner suffisamment des T° limite ?

cordialement,
 
C
cncsiste
Apprenti
3 Nov 2012
115
  • Auteur de la discussion
  • #17
bonjour,
malgré les caractéristiques des moteurs, je me suis rendu compte que la consommation était relativement faible, j'alimente avec une alim 14 volts 3 ampères (les moteurs seulement), j'ai lancé des simulations d'impression et avec l'index sur un des pololu c'est moyennement chaud donc je me suis dit, je ne vais pas installer les radiateurs, mais les mettre est une précaution supplémentaire
par contre, il y a des jours ça démarre et parfois pas, le Lcd j'arrive pas à l'activer (modèle 12864)
je dois avouer que c'est la curiosité qui a déclenché mon achat sans renier l'aspect intéressant du système, ayant déjà une CNC 2D fil chaud depuis plus de 10 ans et 2 CNC 3D depuis quelques années
comme je m'intéresse à beaucoup de choses, je suis toujours occupé
cordialement
 
A
alex111
Apprenti
30 Jan 2014
57
Tes pololu ils encaissent plutôt bien car moi les radiateurs sont bien chauds :)
 
C
cr-_-
Compagnon
29 Sept 2009
869
FR-31 Plaisance du touch
ou alors le courant des moteurs est réglé faible :)

Pour les polulu l'un sur l'autre j'avais pas vu que les sorties n'étaient pas reliées

Ensuite dans le cas des radiateurs j'ai remarqué que si on les mets dessous c'est beaucoup plus efficace (je les rehausse avec des broches pour les arduino voir ici pour l'exemple)
 
Haut