Problème de vitesse broche

  • Auteur de la discussion Gaetan59
  • Date de début
G
Gaetan59
Nouveau
6 Mar 2014
3
  • Auteur de la discussion
  • #1
Après avoir parcouru les pages du forum qui aurai pu m'aider sur mon problème je n'ai rien trouver je me décide donc à poster un nouveau sujet.
Voila je travail sur une commande Fanuc series 18i-TB muni d'un embarreur IMECA880, j'ai créé un programme assez simple.

appel butée embarreur->perçage dia20->dressage->perçage radiale dia6.75->taraudage (code G88)->tronçonnage

Ce programme tourne en boucle.
Mon problème est le suivant lorsque je lance mon programme pour la première fois tout ce passe bien jusqu'au cycle de taraudage, après celui-ci ma vitesse de broche reste constante malgré les G96 ou les G97 S.... à 608 TR/MIN

Voici le morceau de programme ou je suppose l'erreur :
T1111(TARAUD M8);
M23; (ACTIVATION AXE C)
G97S500M53P3 ;
G0Z-10 ;
C0 ;
X38 ;
M29S500 ;
G88X0F625; (CYCLE TARAUDAGE RADIALE)
G80M50; (FIN DE CYCLE)
M24;
M98P1;
M01;

Le taraudage fonctionne parfaitement mais un paramètre doit bloquer ma vitesse de rotation.
Si l'un de vous a la solution à ce problème je l'en remercierai !

Cordialement Gaëtan,
MANORGA INDUSTRIE
 
K
kro
Apprenti
16 Jan 2011
108
Bonjour :)

Sur commande 18i-T je programmais mes taraudages comme ceci :

M98P1
T1212(TARAUD M5)
G97S630M53P3
G19
M23
M66(AVANCE PAR TOUR)
G0B0
G0X45Y0Z-62
M29S630
G88X15P5000F0.8
G80
M24
M98P1

Je n'utilisais pas le M50, et dans mon point de changement d'outil :

O0001(POINT DE CHANGEMENT D OUTIL)
G00G40G99G97M64
T00M5
G28U0W0
G0Y0
M99

Ce n'est probablement pas les bonnes méthodes, mais ça fonctionnait :)

Es-tu sur de devoir utiliser M50 et pas M49 par exemple ?
Ma machine était capable de tarauder en rigide, et lorsque je coupait l'avance pendant le taraudage la broche s'arrêtait. C'était super pratique :)
 
G
Gaetan59
Nouveau
6 Mar 2014
3
  • Auteur de la discussion
  • #3
Merci pour ta réponce j'ai trouvé le probléme il s'agissait du M24 un programme protégé auquel je n'ai pas accées merci en tout cas du conseil :) !
 
G
Gaetan59
Nouveau
6 Mar 2014
3
  • Auteur de la discussion
  • #4
Bonjours, j'avais régler mon problème en supprimant le M29 mais j'ai rapidement remarquer que sans ce M29 mes taraudages avaient des défauts ainsi les vis avaient du mal à passer les deux premier filets.
Mais le problème a été identifier cela vient du M29 sauf que je n'arrive pas à voir qu'elle paramètre est modifié pour bloquer ma vitesse de rotation à 608 Tr/Min
Je fonctionne sur embarreur la machine ne s’arrête jamais et autant dire que de passer de 2000 à 608 Tr/min on perd beaucoup de temps sur les opérations d'usinage.

Si quelqu'un connait la variable associé à la vitesse de rotation maximal avec certitude ou le paramètre système à modifier je suis preneur !!!!
 
JLuc69
JLuc69
Compagnon
19 Juin 2008
1 377
Genas (69)
Tu as peut être un G50 (limitation de la vitesse de broche) avec un S608 qui traine...
Essaies de remettre un G50 S2500 à l'endroit où ça déconne.
De plus, pour faire tourner ta broche, c'est un M3 ou M4 pas M53...
 
Haut