probleme de comprehension sur mach3

  • Auteur de la discussion v tec
  • Date de début
V

v tec

Compagnon
bonjour a tous, dans la fenetre "automatique"

il y a f consigne;f actuel, et mm/mn

f consigne, c est le F du g code

exemple f2000= 2000mm/mn

f actuelle est le f appliqué par mach3, si la vitesse max des moteur c est 1000mm/mn, f actuel sera 1000


mais a quoi correspond mm/mn?


car cher moi ca colle pas du tout a la vitesse f actuel, que je fasse fonctionner un seul axe ou deux combiné


ca c est le premier soucis


le deuxieme, j ai donc une vitesse max de 2000mm/mn sur mes axe

j ai un gcode avec des ligne droite puis courbe, ma broche avance vite sur les ligne droite, et ralenti considerablement dans les courbe, je perd enormement de temp, c est pas fluide

ca c est le deuxieme


et le troisieme

en deplacement manuel, ca m arrive de bouger z par exemple,avec un raccourci clavier, et puis tout en gardant z en mouvement, je decide de bouger un autre axe en meme temps

et bien cela stop tout les mouvement, je relache ma touche clavier, je relance les deux ensemble, et les deux bouge ensemble
 
J

jpleroux

Compagnon
Bonjour,

Bon alors j'essaye :
la vitesse en mm/minute maxi (celle par défaut quand tu fait un G0) correspond à ton réglage moteur (Velocity). C'est normalement la vitesse maximum avant décrochage avec un facteur de sécurité :wink:
Et là c'est clair, cela doit correspondre parce que c'est aussi ta précision => C'est la partie réglage de ton moteur quand tu as une VAB au pas de 5mm (1 Tour = 5mm) et que ton driver est configuré pour 5000 pas/tour = tu as mis 1000 (5000/5) dans Steps per trs.

Si tu n'atteint pas tes 1000mm/min est-ce que ce ne serait pas lié à Acceleration qui serait trop courte pour que ta vitesse max soit atteinte ?

Le ralentissement dans les courbes, oui c'est un peu logique car le nombre de commande envoyer augmente beaucoup. Maintenant quand tu génères ton g-code, il faut bien configurer pour que ce soit en mode "Continu" (je me souviens plus du code :???: )

Sur le dernier point, je ne sais pas, mais j'observe la même chose que toi.

JP
 
V

v tec

Compagnon
ok donc faudrait que je voye avec visual mill pour qu il genere un code plus propre
 
dh42

dh42

Compagnon
Salut,

F consigne: Vitesse programmée dans le GCode

F actuelle: Vitesse tenant compte d'un éventuelle % de sur-vitesse.

mm/min: Vitesse réelle de la fraise tenant compte du mouvement combiné de tous les axes.
(cette option marque parfois n'importe quoi en simu, ou si le PC a été mis en veille)

Le ralentissement dans les courbes et peut être du à des courbes trop denses pour les perf de ton PC (nb de points de contrôle de la courbe), vérifie aussi que tu est bien en vitesse constante.

Je n'ai pas de problème pour faire bouger les 3 axes en rapide simultanément avec les touches du clavier, que je les démarrent ensemble ou séparément.

Un souci similaire m'était arrivé avec mon ancienne machine, c'était dut au clavier sans fil ; si les piles était un peu usées, je ne pouvais plus faire bouger qu'un seul axe à la fois.

++
David
 
V

v tec

Compagnon
salut, c est un pc portable


pour les courbe j ai trouver, en fait mon g code etait pas optimisé avec des rayon g2/g3, mais que des succession de point



si tu dit que mm/mn deconne en simulation je comprend mieux...
 
dh42

dh42

Compagnon
Salut,

c est un pc portable

Tu pilote en USB avec une "pulse box" ?

pour les courbe j ai trouver, en fait mon g code etait pas optimisé avec des rayon g2/g3, mais que des succession de point

Oui, j'ai eu le même pb sur des courbes avec trop de points (suite de lignes/arcs ultra courts), mais j'ai pu trouver une autre solution directement dans Mach3, liée à un réglage du dispositif de vitesse constante. (pour ne plus avoir d'à coups, il a fallu que je désactive CV distance et CV Feedrate dans l'écran "settings"), et la ça passe sans à coup même sur des courbes avec une forte définition.

J'ai remarqué aussi que l'augmentation de la V d'avance via mach (%) ne donne pas les mêmes résultats du point de vue de la vitesse constante, par ex, à 1500 mm/min défini dans le Gcode et 100% de V dans Mach, la trajectoire se fait sans à coup. A 1000 mm/min dans le Gcode et 150% de V, la vitesse de déplacement est toujours de 1500 mm/min, mais il y a des à coups !

si tu dit que mm/mn deconne en simulation je comprend mieux...

Oui, sur mon PC sans machine, la plupart du temps sa affiche 0, sauf si je viens de démarrer le PC, dans ce cas ça affiche n'importe quoi.

Sur celui que j'avais avec mon ancienne CN, après une mise en veille/réveil du PC, cet afficheur restait toujours à 0, mais tous le reste marchait.
Sur ma CN actuelle, et encore un PC différent, après une mise en veille/réveil du PC, impossible de faire fonctionner la machine, mach se comporte exactement comme si la machine fonctionnait, sauf qu'elle ne réagit absolument pas ... Même version de Windows/Mach sur les 3 machines .... :?: :?:

++
David
 
dh42

dh42

Compagnon
v tec a dit:
non j ai un port // sur mon vieux pc portable

Ok, donc en plus il n'est pas impossible que le PC n'arrive pas à suivre s'il y a une instruction Gcode tous les 0.1 mm :lol:

++
David
 
V

v tec

Compagnon
j ai tester vitesse constante et parcours exact, c est sur avec vitesse constante ca trace, sauf qu on est tres loin du parcours reel
 
dh42

dh42

Compagnon
v tec a dit:
j ai tester vitesse constante et parcours exact, c est sur avec vitesse constante ca trace, sauf qu on est tres loin du parcours reel

Salut,

Plus la vitesse de déplacement est élevée, plus la trajectoire de l'outil s'éloigne de la trajectoire réelle lors de "virages serrés", c'est dut à la capacité d'accélération maxi de la machine. Plus elle est faible et plus elle à du mal à suivre à haute vitesse. Cette accélération maxi est réglée dans motor tuning (case Acceleration en mm/s²)

Par exemple, avec un stylo en tracé de texte, avec une accélération à 400 (mach), à 2000 mm/min d'avance, je commence à voir les angles droits qui se transforment en courbes.

Dans Mach, il y a un réglage qui désactive la vitesse constante lorsque l'angle dépasse une certaine valeur.

general config -> section CV control -> Stop CV on angle > xx Degrees.

CV Dist Tolerance permet de définir la longueur maxi en unité courantes qui pourra être utilisée pour le freinage/accélération lors d'un changement de direction (freinage en X, accélération en Y par exemple)

Je ne connais pas ton soft de FAO, mais si c'est comme dans CamBam, tu peux aussi choisir un mode de déplacement différent pour chaque opération d'usinage et ainsi optimiser le déplacement en fonction des particularités d'une opération et de la vitesse d'usinage qu'elle nécessite.

PS: je parle du déplacement REEL de la machine, en simu Mach ne suis pas vraiment le parcours à haute vitesse, mais c'est uniquement sur la simu.

++
David
 
V

v tec

Compagnon
la j ai un soucis avec visualmill et mach3


j ai choisi d ameliorer le g code en utilisant les g02 et g03 pour toute les courbe de mes pieces


le g code passe sur un ordi, mais passe pas sur celui qui me sert avec la machine


il me dit que l arcline de tel ligne ne colle pas avec la fin de l arc de cher pas koi


j ai regarder les config general des deux ordi, rien de spé... je comprend pas trop
 
V

valentin

Compagnon
bonjour
config
case IJmode absolu ou incremental

++
 

Sujets similaires

K
Réponses
8
Affichages
1 872
LionelB
L
P
Réponses
6
Affichages
2 766
deathor
D
lesiso
Réponses
21
Affichages
6 311
david35460
D
taratata
Réponses
4
Affichages
2 472
taratata
taratata
Haut