problème cnc 3040 3axes et grbl arduino

  • Auteur de la discussion vita51
  • Date de début
V
vita51
Nouveau
5 Juin 2014
27
  • Auteur de la discussion
  • #1
Bonjour a tous,
je fait appel a vos compétence pour résoudre mon probleme

j'ai brancher ma cnc 3040z (made in china) et fait les modifications de la carte avec les condensateurs
une fois grbl connecter les problèmes commence...tous les axes étais inverser avec les commandes manuel
pas de probleme dans les options j'inverse les 3 axes
et voila en commande manuel parfait tous fonctionnent dans le bon sens.

mais une fois que je lance un g-code (que j'ai effectuer avec cam bam)tous les axes sont de nouveau inverser!! :twisted:

ex:le g-code effectuer avec cam bam je fait une gravure donc départ de la surface pièce a 0 avec un plan de dégagement de 3mm
je lance le g-code avec grbl contrôleur ou universal g-code sender avec mon stylo en contact avec la feuille (pour tester) au lieu de faire un plan de dégagement en Z+3mm il me fait tous le contraire un dégagement en Z-3mm
ont dirait que la cnc grave en miroir
conclusion quand ça devrait graver au lieu que le Z descende il monte et inversement pour tous les plan de dégagement
et si j'inverse les cable STEP avec DIR les moteur ne réagissent plus
avez vous une idée de mon problème

merci d'avance :prayer:
 
P
PsyKo
Ouvrier
24 Jan 2013
346
Salut,

J'imagine que tu fais un teste en traçant sur une feuille.
Juste pour être sûr, le Z+ monte le stylo et le Z- le fait descendre ?
Donc pour faire ton dégagement, Cambam (qui doit gérer le dégagement en Z+) te génère le GCode :
C'est juste ?

Et tu dis que ton stylo descend ?
 
assurancetourix
assurancetourix
Compagnon
17 Oct 2008
941
rennes
si c'est inversé ça peut aussi venir des origines qui sont différentes

ou a tu mis ton origine machine et ou est ton origine pièce sous Cambam ?
 
osiver
osiver
Compagnon
7 Sept 2013
12 262
Si j'ai bien compris et sans connaître cette machine, il a inversé le sens de fonctionnement des axes par paramétrage à cause du fonctionnement manuel.
Donc, le fonctionnement auto est aussi inversé.
Si on considère que la fonction d'une CNC est quand même de faire des usinages en auto sous la conduite du programme, faudrait remettre en normal le sens des axes et ensuite se pencher sur le problème des commandes manuelles, non ? :???:
 
V
vita51
Nouveau
5 Juin 2014
27
  • Auteur de la discussion
  • #5
PsyKo a dit:
Salut,

J'imagine que tu fais un teste en traçant sur une feuille.
Juste pour être sûr, le Z+ monte le stylo et le Z- le fait descendre ?
Donc pour faire ton dégagement, Cambam (qui doit gérer le dégagement en Z+) te génère le GCode :
C'est juste ?

Et tu dis que ton stylo descend ?
oui en commande manuel le Z+ monte le stylo et le Z- descend bien le stylo
quand CamBam fait un Z3 la cnc fait un Z-3 et inversement

> assurancetourix:
mon origine je le fait stylo en contact avec ma feuille et pareil sur CamBam (niveau surface pièce zéro)
donc CamBam commence le code en Z 0 et ensuite en Z+3 pour les déplacements rapide et après fait un Z-3 pour commencer le tracer
mais la quand la commande de CamBam fait un Z- j'ai un Z+ en réel sur la cnc
donc mon point zéro je le fait sur la pièce (feuille) a Z0 avant de lancer le g-code je fait un reset zéro avec grbl

>osiver:
oui j'ai remis les axes en inverser ou pas ça change pas le probleme du tracé une fois le gcode lancer

au final sur ma feuille je me retrouve avec le tracer des dégagements rapide et la gravure ce fait dans le vide en Z+ au dessus de la feuille au lieu du contraire...
 
V
vita51
Nouveau
5 Juin 2014
27
  • Auteur de la discussion
  • #6
si ca peux aider

dans grbl il y a les coordonné des axes machine quand je suis en manuel

alors en mode inverser des axes quand je fait Z1 le Z de la cnc monte mais grbl affiche Z-1.000 et inversement
quand je fait option axes inverser la les commande revient a la normal mais quand je fait Z1 la cnc fait toujours Z-1 et les cordonner aussi
 
P
PsyKo
Ouvrier
24 Jan 2013
346
vita51 a dit:
alors en mode inverser des axes quand je fait Z1 le Z de la cnc monte mais grbl affiche Z-1.000 et inversement
Ca n'a aucun sens.
Il va nous falloir plus d'infos.
- La version de Grbl,
- La valeur des tes paramètres Grbl (command $$ si je me souviens bien),
- Le fichier GCode exact tel que tu l'envoi.

Pour infos, l'inversion des axes dans Grbl ne fait pas ce que tu décrit. Elle inverse simplement le sens des moteurs, permettant de changer le X- "vers la gauche" ou "vers la droite". Mais en aucun cas elle ne fera bouger la machine en Z-1 si tu lui donne Z1. J'ai utilisé Grbl pendant un certain temps, jamais eu ce problème.
De plus, je n'ai pas souvenir que l'on puisse inverser les axes pour une commande manuelle, puisque Grbl n'a pas de commande manuelle. On lui envoi des commandes textes pour simuler les commandes manuelles.

A mon avis cela vient d'un problème d'utilisation de Cambam entre OP et OM.
 
V
vita51
Nouveau
5 Juin 2014
27
  • Auteur de la discussion
  • #8
j'utilise la version grbl 0.9A et grbl contrôleur 3.3 ou universel g-code sender en version 1.0.6 qui ont bien une fonction de commande manuel sauf que g-code sender pas d'option d'inversement d'axes

grbl contrôleur 3.3
295de0j.jpg


mes paramètres grbl

1h4b6g.jpg


avec grbl contrôleur l'inversion d’axes fonctionne que pour le mode manuel mais pas pour interpréter le g-code

voici mon g-code test

Voir la pièce jointe test2 stylo.rar

avec ce g-code ma cnc le stylo trace tous les dégagements et ce quelle aurait du tracer ce fait dans le vide au dessus de la feuille donc ces bien inverser
autre exemple peut etre plus indicateur
avec la commande manuel quand je fait Z1 grbl contrôleur affiche Z-1 et ça pour tous les axes même si je les inverse

en tous cas merci a vous pour votre aide!!
 
P
PsyKo
Ouvrier
24 Jan 2013
346
Bon le GCode a l'air bon. Rien de suspect en tout cas.

vita51 a dit:
j'utilise la version grbl 0.9A et grbl contrôleur 3.3 ou universel g-code sender en version 1.0.6 qui ont bien une fonction de commande manuel
Oui ces 2 logiciels ont des fonction de commande manuelle, mais qui sont émulés. Tu envoi un déplacement de 1mm (dans ton screenshot), à chaque fois. Grbl le voit comme une commande comme les autres. C'est Grbl qui n'a pas de fonction Jog.

vita51 a dit:
j'utilise la version grbl 0.9A
Tu es sur ?
D'après la liste de paramètres que tu donnes, ca erssemble plus à Grbl v0.8
Grbl v0.9 possède des paramètres $100, $101 que je ne vois, et l'ordre n'est pas le même. Ca ne change pas ton soucis, mais vérifie bien la version de Grbl.

Je vois aussi que ton $3=3. D'après la doc, ca me parait petit. Ils recommandent une valeur entre 5 et 50. Après je ne connais pas assez la théorie pour dire ce que le pulse mini change (et s'il est en accord avec ton pulse mini des moteurs), mais bon. C'est une remarque au passage.

Envoyer Z1 et que Grbl se place en Z-1. Franchement je ne vois pas. A moins que quand tu penses être à 0, tu est en fait à -2 et que tu soit en mode de déplacement relatif. Dans ce cas Z1 en relatif depuis Z-2 te déplace bien à Z-1.

Le problème n'est que sur l'axe Z ou aussi sur les autres ?

Tu as mis en place des décalages (G54 à G59).
Tu fais le positionnement a 0,0,0 avec la commande G92 ? Fonction Home ?
Ce que tu peux essayer de faire c'est de faire un mouvement juste après avoir faire un reset/redémarrage de Grbl. Aucune commande, rien (par défaut la machine sera en 0,0,0 même si physiquement ce n'est pas le cas). Et dis nous ce que ca donne. Donne nous le resultat de la commande " ? " après ton déplacement, pour voir si ce n'est pas un problème d'origine (machine ou offsets)
Tu devrais avoir qqchose comme (aux valeurs près) :

J'essayerai ce soir avec tes paramètres sur mon shield Grbl pour voir.
 
V
vita51
Nouveau
5 Juin 2014
27
  • Auteur de la discussion
  • #10
Voici le résultat
Run,mpos:0.505.0.000,0.000wpos: 0.505,0.000,0.000>
Tous a zéro position machine et work position
La sur la cnc le X par de 1mm sur la gauche au lieu de partir sur la droite quand je suis face a la cnc
J'ai modifier le $3 test de 5 jusqu'a 50 je n'est vu aucune modification...
Du coup j'ai laisser a 5
Malgré que les axes sont inverser si je fait 10mm avec le stylo en manuel j'ai bien 10mm impec
 
P
PsyKo
Ouvrier
24 Jan 2013
346
C'est bizarre que tu ai une valeur de 0.505... Tu as fais quoi comme déplacement ?


Pour le moment oubli le déplacement physique de la machine. Si deja, quand tu envoi la commande (la machine en 0,0,0) G0 Z-1, elle te remonte la position Z1 c'est qu'il y a un soucis.
Avec Grbl la valeur affichée n'est pas "nécessairement" la véritable valeur physique de déplacement si GRBL est mal configuré. Lorsqu'il est bien configuré, les déplacements seront bons.

Si tu veux vraiment qu'on t'aide, il faut :
- La position avant déplacement (commande "?" )
- L'état du parseur (commande "$G" )
- La commande que tu envoi
- La position après déplacement (commande "?" )
Tu me met tout ça dsur le forum, et roule.


Pour ton histoire de gauche et droite, ca ne représente rien, puisque c'est configurable avec le paramètre $6. Tu dis avoir inversé les axes, donc tu as passé $6 de 28 à 0 ?
La doc dit que pour inverser les axes il faut jouer sur les bits 5, 6 et 7 et pas les 2, 3 et 4 comme il semblerait que tu ai fait.
Essaie de mettre $6=224 (int:11100000) au lieu de $6=0.

Les bits 2, 3 et 4 indiquent que tu enverra un front montant (1) ou un front descendant (0) pour générer un pas moteur.
 
V
vita51
Nouveau
5 Juin 2014
27
  • Auteur de la discussion
  • #12
je vais faire les test que tu me demande

j'arrive pas a télécharger la version 0.9f grbl en .hex
 
P
PsyKo
Ouvrier
24 Jan 2013
346
Pas besoin de passer à la 0.9.
La 0.8 fonctionne bien. Fait toi la main la dessus avant de passer à la 0.9
 
V
vita51
Nouveau
5 Juin 2014
27
  • Auteur de la discussion
  • #14
je viens enfin de résoudre le problème :smt003
pas sans mal!!!

Psyko le faite de m'avoir indiquer qu'il fallait modifier les bits en $6 ma énormément aider

moi je modifiait comme ce que indiquait plusieurs tuto grbl (officiel) par les commandes $6=1 $6=2 etc...mais je n'est effectivement vu aucun changement...
alors j'ai fait $6=32 et la parfait tous et devenu magique
ca fonctionne a la perfection

donc j'ai fait un surfaçage de ma planche en bois (dépannage) sur un carré de 200x152 la cnc a usiné 199.5x151.5 il me manque 0.5mm en X et Y par contre j'ai bien mes 0.5mm en Z comme demander
que c'était long par contre!!2h41 pour faire ce carré en 2 passe de 0.25 avec une fraise de 4mm je vais augmenté la vitesse mais je débute alors j'ai pas voulu forcé :wink:


en tous cas un TRÈS GRAND MERCI pour votre aide!!!

cette petite cnc 3040z-dq fonctionne pas mal pour le prix
ont verra bien sur de l'alu de 2mm anodisé le résultat
a l'avenir je pense déjà changer la broche par une de 600w la actuellement elle fait que 280w
je suis bloquer par le diamètre en 52, le support et tailler dans la masse il faut presque tous changer pour installer un diamètre supérieure!la par contre gros point noir de cette bécane
les moteurs nema 23 1.8A me parait pas mal pour mon utilisation (maxi usinage alu 2mm) les vis a billes ont pas de jeux apparent ces déjà une bonne chose

encore merci a vous tous :prayer: le top avec de vrais passionné
 
Haut