Probleme avec g-code.

Tonino.59
Nouveau
9 Novembre 2016
8
  • Auteur de la discussion
  • #1
Bonjour à vous. J'espère poster au bon endroit.
Je vous présent mon problème, je souhaite graver un circuit imprimé après quelques essais concluant mais pas top avec gravit en version essais, je souhaiterai passer à flatcam qui à plus de fonctionnalité et gratuit. J'arrive à exporter mon g-code avec flatcam mais le souci c'est que ce dernier ne laisse pas d'espace en le chiffre du x et le y.
je m'explique : Gravit exporte "G01 X4.831 Y5.664"
alors que Flatcam exporte "G01 X4.831Y5.664".
Le problème c'est que mon g-code fait quelques centaines de ligne alors je ne peut pas faire un espace manuellement à chaque ligne (trop long :cry:). Je ne sais pas pourquoi mais le logiciel que j'utilise pour gerer ma cnc ne fonctionne pas sans cette espace. Ma cnc fonctionne sur l'axe x et z mais pas sur l'axe y. Existe t'il un moyen de mettre en option dans flatcam cette espace ou existe t'il un logiciel qui transformerai mon g-code automatiquement ?
Merci d'avance pour vos réponse.

Ma machine est une open Maker fabriquer par moi meme d'apres les plans de "http://mon-club-elec.fr/openmakermachine/"
J'utilise leur logiciel "simple g-code" avec python sous windows 10.
 
osiver
Compagnon
7 Septembre 2013
10 461
C'est clairement un bug de flatcam mais tellement énorme que ça devrait avoir été corrigé depuis longtemps.
Êtes-vous sûr d'avoir la dernière version ?

D'autre part en attendant, avec python il est facile d'écrire une expression régulière qui ajoute cet espace. Soit vous incorporez cette expression comme postprocesseur à flatcam, si c'est possible, soit en préprocesseur à simple g-code (si ça existe), soit vous créez un script de toute pièce à appliquer avant gravure :wink:
 
Tonino.59
Nouveau
9 Novembre 2016
8
  • Auteur de la discussion
  • #3
Merci pour votre réponse osivier.
J'ai essayer de désinstaller proprement flatcam et de réinstaller mais c'est toujours pareil.
Je dispose de la version 8.5, la dernière apparemment.
Je vais chercher du coté du script qui me parait plus simple a mon niveau. Je ne suis pas vraiment caler au niveau de la programmation.
En tout cas merci beaucoup pour votre réponse.
 
osiver
Compagnon
7 Septembre 2013
10 461
Je ne connais pas flatcam (il me semble intéressant :wink: ) mais en fouinant un peu sur leur site, j'ai vu un exemple de fichier gerber où on voit que les déplacements sont codés sans espace entre les valeurs X et Y. Ils ont peut-être repris le fichier plus ou moins tel que ... :???:
 
Tonino.59
Nouveau
9 Novembre 2016
8
  • Auteur de la discussion
  • #7
J'ai trouver un moyen simple de transformer mon g-code pour ceux que ça pourrai intéresser.
J'ouvre mon g-code avec bloc-notes ensuite faut aller dans édition/remplacer puis dans "rechercher" mettre "y" et dans "remplacer par mettre un " y". (barre espace et y).
C'est une solution qui va me dépanner.
 
Tonino.59
Nouveau
9 Novembre 2016
8
  • Auteur de la discussion
  • #8
Merci beaucoup d'avoir chercher ovisier, je vais utiliser la solution du bloc notes. Pour l'instant en tout cas. Peut être effectivement que ça vient su simple g-code.

Merci à vous.
 
osiver
Compagnon
7 Septembre 2013
10 461
Je ne m'étais pas penché sur l'aspect normatif (NIST) du g-code, je me suis heurté à quelque chose de similaire mais inverse avec g-codetools qui met un espace après la lettre de l'axe ce que ma commande de machine refuse ! :P
 
Tonino.59
Nouveau
9 Novembre 2016
8
Peut être pouvez vous faire de même avec le bloc-notes. :-D
 
osiver
Compagnon
7 Septembre 2013
10 461
Heu, j'ai réglé ce pb et quelques autres petits, directement en modifiant g-codetools par une expression régulière 8-)
 
Tonino.59
Nouveau
9 Novembre 2016
8
Malheureusement j'en suis pas encore à ce niveau. :wink:
 
pierrepoulpe
Nouveau
8 Novembre 2016
5
Je grave aussi mes PCB à la fraiseuse.
Après pas mal d'aller/retour, j'ai fini par me stabiliser sur le couple Eagle/pcbgcode... je peux témoigner, ça marche très bien, même si au global ce n'est pas un processus "fichier>imprimer". Il faut se plonger dedans...

De façon général, le g-code est une norme "faible". Il y a un vague tronc commun, et puis chaque éditeur/constructeur rajoute (enlève) ce dont il (n')a (pas) besoin....

Du coup, mon conseil de façon général, c'est qu'on rencontre le minimum d'ennui quand on utilise une chaine d'outil connue pour fonctionner ensemble.
Tu fais peut être partie des rares qui utilisent le trio flatcam / simplegcode / je-sais-pas-quel-firmware-arduino
(D'ailleurs, c'est probablement le firmware arduino qui est en cause, plus que simplegcode, c'est lui qui interprète chaque ligne de gcode, pas simplegcode qui ne fait qu'envoyer ligne à ligne...)

Soit tu veux conserver cette chaine, et tu corrige le gcode à la semi-mano. Aide toi de notepad++ si nécéssaire, pour faire des rechercher/remplacer intelligents. Du genre remplacer Y par ' Y'
Soit tu garde flatcam, tu identifie qui ne supporte pas l'espace manquant entre simplegocde et le firmware, et tu remplace par autre chose =>
fais un tour sur http://reprap.org/wiki/Firmware
ou l'option PC + linuxcnc (que j'affectionne bien au final, malgré la lourdeur d'avoir un pc pour ça, linuxcnc sait faire des choses que les arduino-based ne savent pas faire (faut dire qu'ils ont été pensés pour l'impression))
Soit tu vire flatcam....
 
Tonino.59
Nouveau
9 Novembre 2016
8
Merci pour tes conseils. La solution linuxCnc m'a pas beaucoup plu, un peu trop lourd comme tu as dit, il a fallu que je supprime windows d'un pc pour tester. Et puis c'est assez déroutant puisque je suis habitué à windows et un peux d' ubuntu. Je n'avait pas pensé au problème du firmware arduino, c'est vrai que notamment au niveau de l'echelle je suis obligé de multiplier par 2 tous mes conceptions pour pouvoir avoir la bonne échelle du produit fini. Par contre une fois lancé la machine tourne très bien. Je vais suivre ton lien et voir ce que ça donne. Pourrai tu me donner le modèle de fraise que tu utilise pour graver les PCB ?
Moi j'utilise celle ci "http://www.cncfraises.fr/gravure/76-pjm45.html" mais je suis pas totalement satisfé surtout au niveau des piste les plus rapprochées. Merci
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut