pièce étirée en longueur

  • Auteur de la discussion rastaferraille
  • Date de début
R
rastaferraille
Nouveau
30 Août 2017
20
  • Auteur de la discussion
  • #1
Bonjour !

J'ai enfin réussi à faire marcher une petite fraiseuse CNC d'un ami avec linuxCNC (vendue à l'origine par planetCNC).

Je suis vraiment débutant de chez Débutant. Pardon d'avance si mes questions paraissent absurdes..

Tout marche bien à ceci près que mes pièces ne sont pas à l'échelle, je me retrouve avec des pièces toutes étirées en longueur.
Ca leur donne une gueule marante, mais elles ne sont pas trop utilisables du coup !!

De quoi ça peut venir d'après vous ? Vis sans fin qui n'est pas réglée sur le bon pas ? si c'est le cas, comment vous faites pour mesurer le pas de la vis ? Est-ce que ça peut venir d'autre chose (j'ai réglé mes drivers sur 1600, sachant que les moteurs tournent à 200 pas, j'ai réglé sur 8 dans stepconf) ?

Je me demandais aussi comment vérifier que le réglage est bon facilement sans usiner forcément une pièce.

Bon, j'arrête là, si vous avez une peu de temps pour m'aider, ça serait bien sympa !

Merci d'avance
 
Dernière édition:
S
speedjf37
Compagnon
15 Oct 2009
2 283
indre et loire
Bonjour,

Dans stepconf il y a un test de déplacement.

On peut choisir la distance de déplacement et simplement mesurer avec un réglet ,un pied à coulisse etc pour vérifier le déplacement.

Tant que ce n'est pas réglé pour tous les axes pas utile d'usiner. (un crayon suffit pour vérifier).

On peut aussi vérifier la vitesse max avant perte de pas (ou hurlement des moteurs) et réduire à 80%.

Plus on choisit de micropas sur les drivers plus le PC doit générer d'impulsions pour un déplacement et ce n'est pas plus précis seulement moins bruyant .

Bon réglages.

JF
 
R
rastaferraille
Nouveau
30 Août 2017
20
  • Auteur de la discussion
  • #3
Bonjour !

Merci pour ces explications. C'est assez trivial en effet.... Mais par contre, justement, le test de déplacement des axes ne marche pas pour moi dans le stepconf.
Je crois qu'il parlent d'enable à activer manuellement dans certains cas pour faire fonctionner le test, du coup, ça se passe comment ? Il faut juste envoyer du 5V sur Enable + ?

Sinon, j'y pense maintenant, mais je dois pouvoir me débrouiller avec les coordonnées X,Y,Z affichées dans linuxCNC luii même.
Ceci dit j'aimerais bien arriver à faire marcher le test des axes pour régler correctement l'accélération et la vitesse.

Par contre je pensais que le nombre de micropas jouait sur la précision... A quoi ça sert alors de pouvoir faire tous ces réglages différents sur les drivers, si les moteurs ne sont de toute façon pas en mesure de faire autant de pas par rotation ?

200 pas par rotation, avec une vis de 5 ça donne 5/200 = 0.025mm par pas. Donc en mettant 800 pas on ne se retrouve pas avec une précision augmentée d'un facteur 4 ?

Merci encore !
 
Dernière édition:
S
speedjf37
Compagnon
15 Oct 2009
2 283
indre et loire
Mais par contre, justement, le test de déplacement des axes ne marche pas pour moi dans le stepconf.
Je crois qu'il parlent d'enable à activer manuellement dans certains cas pour faire fonctionner le test, du coup, ça se passe comment ? Il faut juste envoyer du 5V sur Enable + ?
Les "enable" sont activés par défaut sur la plupart des drivers.(même décâblé c'est actif)
Lors de mes essais par axe avec stefconf les "enables" s'activaient tous seul a chaque essais.

Il faut régler et valider les paramètres avant de faire des déplacements.

JF
 
R
rastaferraille
Nouveau
30 Août 2017
20
  • Auteur de la discussion
  • #5
Salut !
Ben j'arrive toujours pas à faire marcher le test des axes dans stepconf, alors que tout marche dans linuxCNC...
Une idée ?
 
Haut