panne sur carte électronique électro érosion

  • Auteur de la discussion biscotte74
  • Date de début
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #1
Bonjour, je viens de mettre sous tension ma carte électronique de ma machine à électro érosion. Au bout de 10 secondes environ j'ai un, voir 2 transistors de puissances qui ont lâchés. Ils sont devenus bouillants, le temps que j'arrête tout ,c'était trop tard.
Est ce que quelqu'un pourrait jeter un coup d’œil afin de m'orienter dans mes recherches ?
Je mets les schémas dont je dispose

edm1.jpg
le schéma de câblage sur la notice du concepteur

Voir la pièce jointe 57HS25.pdf le moteur utilisé pour les essais

edm2.jpg
le schéma de câblage

Les transistors qui ont chauffés sont ceux marqués "Q2" et "Q3" se sont des 2N6387

Sur le livret, l'auteur ne précise pas grand chose sur les caractéristiques du moteur à utiliser (intensité max, mais sur mes autres cartes ont peut mettre des moteurs plus gros que prévu car c'est la carte qui limité l'intensité). Est il possible que le miens soit trop gros ?
Merci à ceux qui auraient des idées
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #2
Il est à noter que le moteur a fonctionné correctement quelques secondes, dans un sens comme dans l'autre. Par contre il faisait "beaucoup de bruit" comme si il vibrait et il était impossible de le faire tourner vite avec le potar car il décrochait quasi à mi course du réglage de vitesse.
Ayant beaucoup de mal à trouver des transistors 2N6387 est il possible de les remplacer par des 2N6388, les caractéristiques générales sont identiques sauf le "Collector−Base Voltage " qui est de 60v sur le 6387 et 80v sur le 6388
 
LETARTARE
LETARTARE
Ouvrier
27 Sept 2010
442
Haute-Savoie
Bonjour,
Ayant beaucoup de mal à trouver des transistors 2N6387 est-il possible de les remplacer par des 2N6388, les caractéristiques générales sont identiques sauf le "Collector−Base Voltage " qui est de 60v sur le 6387 et 80v sur le 6388
Sur ce dernier point et à la lecture de votre texte : aucun problème.
Bien cordialement.
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #4
Je vous remercie, je vais donc passer commande de nouveaux composants afin de reprendre les essais au plus vite.
Je me demande aussi si je n'aurais pas du monter des radiateurs sur mes transistors, ils sont capable de dissiper 65w si j'ai compris leurs caractéristiques, ce qui me semble beaucoup sans radiateur, car mon moteur consomme 4A. ( ils tiennent 10A donc ce n'est pas à ce niveau que cela pose pb).
Par contre mon moteur est quand même très gros pour cette machine, je pense en prendre un plus petit.
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
A mon avis un radiateur est indispensable, et pas un petit riquiqui.
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #6
PGL a dit:
A mon avis un radiateur est indispensable, et pas un petit riquiqui.
Le problème reste la place, à moins qu'il soit possible de déporter les 4 transistors en les reliant par des fils à la carte
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
817
FR-81150
bonjour,
quelques remarques:
- les points milieux du moteur qui vont au + de l'alim doivent etre A', C', B' et D'
- Quelle est la tension continue sur le pont de diode d'alimentation du pap
- Il est normal que sans radiateur conséquent les transistors (darlington) ne vont pas suivre à basse vitesse (mettre une résistance série pour limiter le courant)

La logique TTL et l'industriel ne font pas bon ménage. Laisser des pins en l'air, ce sont des sources de fonctionnement erratique.
les pins 4 et 5 du ls138 sont reliées à quoi? (normalement GND)
la pin 11 du ls193 doit etre forcée à VCC
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #8
f6bqi a dit:
bonjour,
quelques remarques:
- les points milieux du moteur qui vont au + de l'alim doivent etre A', C', B' et D'
C'est bon, c'est ce que j'ai fais
f6bqi a dit:
- Quelle est la tension continue sur le pont de diode d'alimentation du pap
Je n'ai pas regardé, mais le transfo est un 12v alternatif, donc je pense dans les 16-17v (c'est que qui est préconisé par l'auteur

-
f6bqi a dit:
Il est normal que sans radiateur conséquent les transistors (darlington) ne vont pas suivre à basse vitesse (mettre une résistance série pour limiter le courant)
Effectivement je n'ai pas mis de radiateurs, sûrement une grosse erreur de ma part, je vais tenter de remédier à ce point

f6bqi a dit:
La logique TTL et l'industriel ne font pas bon ménage. Laisser des pins en l'air, ce sont des sources de fonctionnement erratique.
les pins 4 et 5 du ls138 sont reliées à quoi? (normalement GND)
C'est bien le cas
f6bqi a dit:
la pin 11 du ls193 doit etre forcée à VCC
Elle est "dans le vide", comment la forcer à VCC ?

En vous remerciant de votre aide. Pour la résistance série, comment l'inclure et quelle devrait être sa valeur ?
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #9
Est ce qu'il est possible d'enlever les 4 transistors de la carte afin de les monter sur un radiateur commun de grande dimension et de les raccorder à la carte par des fils ?

J'ai aussi commandé un moteur plus petit qui va consommer au max 2A/phase en unipolaire au lieu des 4A/phase actuellement. Comme il n'y a pas d'effort sur ce genre de machine cela suffira grandement.J'aurais pu mettre plus petit, mais il est difficile de trouver de petits moteurs en forma nema 17 avec 6 ou 8 fils, la plupart sont en bipolaire.
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 852
FR-28360
D'après ce que je vois, la carte n'a pas de régulation de courant, donc le courant est limité seulement par la résistance du moteur ici 0,7 ohm donc selon la loi d'ohm U=RI grosso-modo I = 15/0.7 = 21 Ampères :shock:
Il faudrait ajouter des résistances supplémentaires pour limiter le courant.
Pour ce type de montage il est préférable d'utiliser des moteurs ayant une résistance élevée,
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #11
Le nouveau moteur a une résistance de 1.8 ohm, ça va donc limiter les "dégats", comment faire pour ajouter des résistances de limitation ?
 
f6bqi
f6bqi
Compagnon
26 Sept 2008
817
FR-81150
idem à R20 1K entre pin 11 et le +5V

Les transistors peuvent être déplaces sur un radiateur mais attention à l'isolation.
En principe la semelle des trans est le collecteur ==> donc isolation
réduisez la tension d'alim du moteur car sous 17V = 65W par enroulement (dur dur)
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #13
f6bqi a dit:
idem à R20 1K entre pin 11 et le +5V

Les transistors peuvent être déplaces sur un radiateur mais attention à l'isolation.
En principe la semelle des trans est le collecteur ==> donc isolation
réduisez la tension d'alim du moteur car sous 17V = 65W par enroulement (dur dur)
Ok, pour la résistance cela doit pouvoir se faire facilement, les radiateur, effectivement je n'avais pas pensé à l'isolation par rapport au châssis, faut que je trouve une "combine...............Par contre je peut les mettre les 4 sur un radiateur commun où alors il leur faut un radiateur chacun ?
Réduire la tension, je n'ai pas beaucoup de choix, le transfo est un 2x6v, donc je le passe en 6V ? redressé cela va donner dans les 8.5v cela vous semble t-il mieux ?
 
S
speedjf37
Compagnon
15 Oct 2009
2 217
indre et loire
Bonjour,

Au risque d'être hors sujet ! :smt011
Ne serait il pas plus simple d'adapter le schéma pour pouvoir utiliser n'importe quel module driver de pas à pas ? :smt003

Cordialement JF
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 852
FR-28360
Valeur de la résistance -> R_additionnelle = (U_Alimentation / I_Moteur ) - R_moteur.
Puissance de la résistance -> R_additionnelle X I_Moteur²
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #16
Ok, par contre je la monte en série avec les sorties moteurs ?
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #17
CNCSERV a dit:
Valeur de la résistance -> R_additionnelle = (U_Alimentation / I_Moteur ) - R_moteur.
Puissance de la résistance -> R_additionnelle X I_Moteur²
Donc avec une résistance moteur de 1.8 ohm , une tension de 8.5v et une intensité de 2A, cela me donne une résistance additionnelle de : 2.45 ohm et une puissance de 9.8 W. C'est bien ça ? je vais jamais trouver un truc pareil..........
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 852
FR-28360
Oui, en série avec l"enroulement.

Les calcul sont bons, il n'y à pas de limitation de courant à l'arrêt, tu peux peut-être prendre un peu plus...
 
osiver
osiver
Compagnon
7 Sept 2013
11 988
Il vaut mieux se ménager une marge de sécurité. De la même façon que les transistors ne peuvent dissiper 65W au collecteur que dans la limite de leur courant collecteur max ET de la tension collecteur émetteur max ET pour une température jonction donnée, les résistances vendues pour 10W ne devraient pas être utilisées à 9,8W. :cry:
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #25
Dernière édition par un modérateur:
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
Oui chaque transistor doit être isolé et la feuille isolante est prévue pour laisser passer la chaleur, t'en fais pas c'est toujours comme ça que c'est monté avant c’était du Mika.
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #27
Ok, j'ai compris, je commande ça.
 
biscotte74
biscotte74
Compagnon
28 Nov 2012
3 867
Annemasse
  • Auteur de la discussion
  • #28
Encore une question, si je prends le moteur de chez selectronic, je peut me passer des résistances, mais est ce que cela me permettra aussi de limiter la taille des radiateurs des transistors ?
Parce que question place, je commence à être très limite et si je pouvais juste monter 4 petits radiateurs en laissant les transistors sur le carte, je vous cache pas que cela m’arrangerais bien.
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
Des petit radiateurs avec 65 w, ça va pas changer grand chose à ton problème, mais tu as la place tu peux aussi fixer les transistors sur le corps du boitier et le radiateur de l'autre coté, le truc c'est d'évacuer la chaleur au maximum.

Tu peux aussi découper le boitier pour faire un sorte de fenêtre, le radiateur étant fixé par l'extérieur de la fenêtre.
 
CNCSERV
CNCSERV
Compagnon
27 Déc 2007
5 852
FR-28360
Le moteur vient de chez RS, c'est le seul que j'ai trouvé avec une résistance presque adaptée a un prix raisonnable. (ils ont un site pour particulier)
Chez selectronic, chez Conrad, chez Farnell ils n'ont rien. Ce genre de moteur n'ai plus trop répandu.
Ce moteur a une résistance de 20 ohms et un courant de 0.6A pour 12V. Si ton alimentation est de 8.5V le courant sera seulement d'environ 0.4 A donc tes transistors ne vont pas chauffer beaucoup.
 
Haut