les drivers hss86 et HBS57, branchement de alm- et alm+ et pend+ et pend-

  • Auteur de la discussion c.phili
  • Date de début
c.phili
c.phili
Compagnon
14 Fev 2007
4 284
Comines Belgique près du 59 (Fr)
  • Auteur de la discussion
  • #1
bonjour à tous
Je suis en train de monter 3 contrôleurs pour des pas à pas closed loop, j'emplois des drivers hss86 et HBS57, branchement de alm- et alm+ et pend+ et pend-.
Tout à l'air de fonctionner très bien, je mettrais les détail dans mon post "c'est parti pour 3 cnc" une fois terminé.
Mais en attendant je butte sur les connexions de alm- et alm+ et pend+ et pend- et j'aimerais déjà connaître leur utilité et le branchement préconisé.
Je n'ai pas trouvé beaucoup d'infos à ce sujet mais je suppose qu'il doit y avoir moyen de créer un AU pour que la machine s'arrête en cas d'alarme.
Je sais que je trouverais des gens assez sympa pour m'aider ici :wink:
Philippe
 
R
Rom'
Compagnon
26 Oct 2011
2 333
Salut,
Rapidement,
alm est une sortie alarme, donc dès que le drive se met en défaut elle est activée ( NO ou NC à voir dans le datasheet ), normalement defaut courant/tension et defaut position,
pend grosso modo te permet de savoir si il y a de l'erreur de poursuite, pas vraiment à exploiter dans ton cas je pense.
C'est des sorties a collecteur ouvert, et tu cable ca sur ta carte d'interface, et tu déclare une entrée estop correspondante dans mach3 ou autre...
 
c.phili
c.phili
Compagnon
14 Fev 2007
4 284
Comines Belgique près du 59 (Fr)
  • Auteur de la discussion
  • #3
salut rom' et merci pour ton aide
en effet c'est rapidement:cry:
Si je branche le 5 volt sur alm+, une fois en alarme j'ai bien 5 volts entre alm- et GND mais si je branche un relais de 5 volts qui me permettrait de couper le circuit (AU) ça chute à 2 volt et ce n'est pas suffisant pour enclencher le relais:smt017
 
R
Rom'
Compagnon
26 Oct 2011
2 333
Oui ca doit pas drainer grand chose comme courant,
Le mieux c'est de cabler ca sur une entree optocouplée,
Si tu veux un truc tout fait cherche un truc du genre " relais arduino " dans google
 
c.phili
c.phili
Compagnon
14 Fev 2007
4 284
Comines Belgique près du 59 (Fr)
  • Auteur de la discussion
  • #5
oui c'est ça que j'ai essayé
 
R
Rom'
Compagnon
26 Oct 2011
2 333
Tu peux faire un bout de schéma de quoi t'a fait stp
 
c.phili
c.phili
Compagnon
14 Fev 2007
4 284
Comines Belgique près du 59 (Fr)
  • Auteur de la discussion
  • #7
3.jpg

1.jpg
 
G
gaston48
Compagnon
26 Fev 2008
9 697
59000
Bonjour, :wink:
je verrais plutôt :
ALM+ au +5 c'est bon
ALM- sur IN
VCC au +5 c'est bon
GND au 0V du +5
 
c.phili
c.phili
Compagnon
14 Fev 2007
4 284
Comines Belgique près du 59 (Fr)
  • Auteur de la discussion
  • #9
salut Gaston, comment va? Je vais essayer
 
R
Rom'
Compagnon
26 Oct 2011
2 333
En faisant comme ton schéma tu essayait d’alimenter la carte entière via l'opto du drive, ce qui reviens a mettre directement un bête relais...
Donc oui IN et GND direct sur ton alim 5v
Ton ALM+ sur ton +5v et ALM- sur GND
 
c.phili
c.phili
Compagnon
14 Fev 2007
4 284
Comines Belgique près du 59 (Fr)
  • Auteur de la discussion
  • #12
Un grand merci, on avance mais ça ne marche pas vraiment :smt017
Si je branche ce relais de 5 volt comme vous me le préconisez, ça ne marche pas, peut-être due à l'alim prise directement sur la carte cnc ou alors le relais qui ne va pas.
Par contre, comme la carte cnc n'a pas de relais pour la broche, la lub etc, j'en ai rajouté en externe mais alimentés en 24 volt et là en prenant un même relais et en branchant le +24 et le- sur le relais puis le - et le in sur alm+et- du drivers, là ça marche, le contact s’allume dès que je provoque une alarme, pour ça rien de plus simple, il me suffit de débrancher le câble du codeur, donc en faisant une coupure de l'AU ça va marcher.
J'ai remarqué aussi que je pouvais directement faire la coupure en sortant du drivers sans passer par un relais mais là j'aurais un tout autre problème mais cette fois de config.
Alors comment expliquer clairement, le mieux pour une CN c'est d'avoir le circuit AU en circuit fermé pour qu'au cas ou on arrache un câble ou q'un contact arrêt d'urgence foire, la machine se met en AU, jusque là c'est clair.
Dans la config de mach3, on peut bien sur choisir le circuit ouvert ou fermé, la notice de la carte préconise fermé mais sur cette carte, j'ai une manivelle qui se branche et si je met l'AU en circuit fermé, dès que je tourne la manivelle, mach se met en AU, je ne sais pas pourquoi, j'ai cherché des heure sans trouvé, donc je dois resté en circuit ouvert et donc, pour contré ça, j'ai ajouté un relais qui reste alumé tant que le circuit est fermé qui donne le signal ouvert à la carte, là je suis plus sur d'être clair:smt017
Ca marche très bien comme ça mais pour moi c'est pas vraiment logique, dès que j'appuis le n-stop, mach3 se met en AU et je ne sais plus le réenclencher aussi longtemps que le circuit reste ouvert mais par contre si j'éteins le contrôleur, je sais retirer l'AU dans mach, bien sur je ne sais rien faire mais bon, pas logique quand même.
Donc si quelqu'un à une solution pour que cette manivelle marche avec l'AU en circuit fermé ce serait génial, et ne venez pas me dire que c'est normal parce que c'est du matos chinois, même les BMW sont bourrée d'électronique chinoise et ça ne fait pas d'elles de mauvaise voitures:mrgreen:
D'habitude les vendeurs sont vite là pour me répondre mais celui-là ne donne pas signe de vie:mad:
Bien sur pour plus de clarté, je pourrais mettre des photos et des liens du matos, je le ferais si on me le demande, pour le moment c'est l'heure de la bouffe:wink:
Philippe
 
R
Rom'
Compagnon
26 Oct 2011
2 333
Peux tu mettre une photo de ta carte relais, pas une du web, qu'on voit les tensions sur le relais et tout ca ...
 
c.phili
c.phili
Compagnon
14 Fev 2007
4 284
Comines Belgique près du 59 (Fr)
  • Auteur de la discussion
  • #14
Salut à tous
un peu en retard mais je suis là

Un peu noir mais c'est la photo, en réalité il est bien neuf et tout beau :-D
relais 5 volts
S1750008.jpg

S1750009.jpg


Et ici le relais 24 volt qui va bien
le cavalier sur L pour que c'est le - qui traverse le contact du drivers
S1750010.jpg
 
Haut