Advertisements

image bitmap me fait planter cambam

B
bruntch
Ouvrier
16 Mai 2010
328
12
  • Auteur de la discussion
  • #1
bonjour a tous ,
si dh42 passe par là , ou si quelqu'un saurait me guider
j'ai un petit souci avec une image bitmap , lorsque je veux l'importer dans cambam , elle ne s'ouvre pas et la petite fenêtre d'ouverture est marqué "ne répond pas" , d'autre images s'ouvrent sans problème sous le meme format , meme avec des dimensions différentes inscrites dans la première case (je mets 100mm) j'ai essayé avec une dimension plus petite , c'est pareil .
pour le moment je suis toujours avec la version démo , la taille de l'image est de 100ko
je joint le fichier au cas "zoù" , par-contre celui est en jpg , je ne peux pas transférer celui en bitmap et même celui-ci me fait planter cambam
logo pomayret 2 jpeg.jpg

merci
 
Advertisements
dh42
dh42
Compagnon
4 Septembre 2009
5 314
Près de St Etienne (42)
salut,

peut tu être plus précis ?

il existe 2 façons d'importer des images dans Cambam (0.98) et 3 dans la V1.0 :wink:

par bitmap, tu veux parler du format .bmp ?

++
David

Edit: il n'y a pas de fichier joint :wink:
 
Fred69
Fred69
Compagnon
2 Décembre 2008
4 197
F-69 sud-ouest Lyon
j'ai un petit souci avec une image bitmap
Tu ne donnes pas le format de ton image bit-map et tu n'arrives pas à la mettre sur le forum, il doit y avoir un problème là.
d'autre images s'ouvrent sans problème sous le meme format
quel format ?
ça ne serait pas plus simple d’envoyer dans Cambam une image vectorisée plutôt que bit-map ?
 
Dernière édition:
Fred69
Fred69
Compagnon
2 Décembre 2008
4 197
F-69 sud-ouest Lyon
j'ai trouvé un convertisseur de format en ligne :( DXF)
J'utilise déjà COREL draw.
Le problème c'est surtout qu'avant de vectoriser il faut une image propre. On peut l'obtenir en forçant le contraste de manière à supprimer tous les gris intermédiaires qui risquent d'être mal interprétés.
Après vectorisation il faut vérifier que toutes les lignes entourant les parties que l'on veut graver sont fermées et sans croisement, ça n'est pas toujours facile à voir.
 
dh42
dh42
Compagnon
4 Septembre 2009
5 314
Près de St Etienne (42)
je pense que vous êtes à coté de la plaque les gars ! ; la question c'est pourquoi cette image fait planter CamBam, et la réponse et dans le 3iem message (enfin la solution, pas la réponse)

je pense que ce que bruntch appel image bitmap, c'est tout bêtement une image au format .bmp ; il ne faut pas chercher midi à 14h00 :roll: (et il faut décoder !)

++
David
 
B
bruntch
Ouvrier
16 Mai 2010
328
12
  • Auteur de la discussion
  • #7
je pense que ce que bruntch appel image bitmap, c'est tout bêtement une image au format .bmp ; il ne faut pas chercher midi à 14h00 :roll: (et il faut décoder !)

++
David
exact ce que j'apelle image bitmap c'est ce logo(fichier) qui fini par .bmp
ce logo que j'ai mis dans mon premier message "ferme equestre de pomayret"

re

si c'est avec surface depuis bitmap, met 1 dans 'pas de la grille' pour X et Y :wink:

++
david
du coup je vais essayer de-suite cette solution
 
B
bruntch
Ouvrier
16 Mai 2010
328
12
  • Auteur de la discussion
  • #8
nickel ca marche, merci david ,
juste pour savoir , est-ce que tu serai me dire pourquoi avec d'autre image je met juste une valeur sur la largeur de taille de sortie et je laisse les autres a zero et ca fonctionne mais pas pour celle-ci !!
 
dh42
dh42
Compagnon
4 Septembre 2009
5 314
Près de St Etienne (42)
juste pour savoir , est-ce que tu serai me dire pourquoi avec d'autre image je met juste une valeur sur la largeur de taille de sortie et je laisse les autres a zero et ca fonctionne mais pas pour celle-ci !!
Non, aucune idée ; sur le moment j'ai pensé que c'était à cause de sa taille ; certains softs n'aiment pas les images avec un nombre de pixels impairs sur X, mais même après modif pour la passer à 170px de large au lieu de 169, ça ne change rien, même chose en la sauvant en .bmp

j'ai envoyé l'image et le rapport de bug a Andy (le programmeur) pour investigations, avec un peu de chance ce sera réparé sur la version en cours de développement.

++
David
 
ingenieu59
ingenieu59
Compagnon
10 Septembre 2013
3 422
cassel 59
Bonjour,

j' ai aussi le même problème sur la version P .
Je ne peux plus faire de courbes de niveau , parce qu' il ne lit plus les images .bmp
 
dh42
dh42
Compagnon
4 Septembre 2009
5 314
Près de St Etienne (42)
Salut

Oui, c'est exactement le même bug sur les 2 (il est probable que la routine est exactement la même) ; la solution c'est de mettre 1 dans les 2 cases "pas de la grille"

++
David
 
ingenieu59
ingenieu59
Compagnon
10 Septembre 2013
3 422
cassel 59
Bonjour David,

le soucis, c' est que je ne trouve pas le " pas de la grille "
 
ingenieu59
ingenieu59
Compagnon
10 Septembre 2013
3 422
cassel 59
Merci David .

Vu que c' est une fonction que je n' utilise plus, j' avais oublié comment j' avais fait la première fois .

Mais, je ne t' embêterais plus là dessus , j' ai tout noté sur papier .
 
N
Num
Compagnon
21 Mai 2014
689
Bonjour à tous,
Ca sert à quoi d'importer une image point JPG sur Cambam ?
bonne journée.
A+
 
La dernière réponse à ce sujet date de plus de 6 mois
Advertisements
Haut