Erreur : Interférence g41/g42 en tournage

  • Auteur de la discussion ESalomez
  • Date de début
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #1
Bonjour à tous,

Suite à une rapide formation sur une console fanuc Series 31i-Model A, nous sommes deux à essayer de programmer des pièces relativement simples. Cependant nous avons toujours un problème en ce qui concerne les chanfreins sur la première arête d'une pièce. Je vous mets le morceau de programme qui coince en dessous :

N40 T1212 ;
G50 S2000 ;
G54 G96 G99 ;
M81 ;
G28 U0 V0 ;
G0 Z200 ;
G0 G41 X23 Z5 S90 M3 ;
M8 ;
G71 U0.5 R0.5 ;
G71 P41 Q 42 U-0.2 W0.2 F0.2 S90 ;
N41 G0 X27.1 S110 ;
G1 Z0 F0.12 ;
X25.1 , C1 ; (chanfrein de 1 à l'entrée de l'alésage)
Z-44 ;
X23 ;
N42 G0 Z5 ;

Lorsqu'on arrive à cette ébauche, le programme s'arrête et on a l'alarme suivante : 041 Interférence G41/G42. Cependant, si on change le chanfrein en rayon alors il n'y a plus de problème et ça passe sans problème.

Est-ce que quelqu'un aurait une idée s'il vous plait, voire une solution ?

Merci d'avance pour votre aide.

PS : Petite précision on utilise la même technique pour le chanfrein extérieur et il n'y a aucun problème. La prise de tête en est encore plus grande.
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
C'est peut être un problème avec la description de l'outil dans la bibliothèque d'outil.
 
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #3
L'outil est déjà monté et utilisé dans un autre programme où il y a besoin d'un rayon. Donc je pense que le problème vient bien du chanfrein ou de la définition de celui-ci dans le programme.
 
bistouc
bistouc
Apprenti
5 Déc 2011
122
epinay sur seine
Bonjour à tous,
petite question avez vous essayez de taper K-1 au lieu de C1.
a+
bistouc
 
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #5
Bonjour,

Nous venons d'essayer avec K à la place de C et le problème est le même. On retrouve la même erreur.
 
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #6
Pour que ce soit plus simple, voici un plan de la pièce à réaliser. On sort pièce finie, enfin si le programme veut bien passer un jour.

Accouplement moteur tube.PNG
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
Est ce que tu as essayé de mettre X27 au lieu de de X25.1, parce que si tu as un chanfrein de 1 mm sur du 25 intérieur, il faut l’attaquer a 27.
 
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #8
C'était pour tenir les tolérances dans le programme. Mettre 25.1 en diamètre inter avec le départ du chanfrein à 27.1. J'ai même essayé ne mettant un chanfrein de 1.5 avec un départ en z0.5, sans chanfrein en définissant juste les points, en mettant un angle de 45° (-135° en trigo) et juste le x25.1 pour qu'il se calcule le z tout seul mais rien n'y fait. Au mieux j'ai le droit à une passe qui commence à ébaucher le chanfrein et ensuite j'ai l'apparition de l'erreur qui revient encore et encore :smt011
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
Si tu veux garder un peu de matière pour la finition, c'est peut être 24,9 qu'il faut mettre.

ensuite, pourquoi as tu deux fois G71, est ce que tu ne pas tout mettre dans la même ligne.

Est ce que tu as essayé de mettre le G41 dans la ligne N41, est ce que tu as bien mis un point pour C1. aprés le1

Je ne connais pas ta machine, mais quelque fois, les codes de compensation sont inversé si la tourelle est à l’arriéré, est ce que tu as essayé avec un G42?
 
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #10
Le G71 est défini en 2 lignes pour cette machine (je sais que ça dépend des versions et tout). C'est dans le G71 que sont précisés les surépaisseurs : U-0.2 surep en X et W0.2 surep en Z, le U négatif précise que c'est un cycle inter.
Ensuite dans la plupart des exemples de programme que je trouve sur le net, le G41 est effectivement à l'intérieur du G71 mais encore une fois ici c'est spécial et si je le fais la machine me dit que la commande est invalide et vu que pour le reste ça marche en dehors du cycle, je laisse comme ça. Le pire dans l'histoire c'est quand même que j'utilise le même cycle pour l'exter (avec U positif) avec chanfrein et tout et il passe impeccable.

En tout cas merci pour l'aide, les idées se font rare maintenant pour moi après avoir essayer pas mal de choses.
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
Est ce que tu as essayé de contourner le problème

N41 G0 X27.1 S110 ;
G1 Z0 F0.12 ;
X27. ;
X25. Z-1.;
Z-44 ;
X23 ;
N42 G0 Z5 ;

Si ça marche en extérieur avec un G42, alors ça devrait marcher avec le G41 en inter.
 
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #12
Effectivement le G41 devrait marcher en inter mais apparemment la machine n'est pas de cet avis.
Et oui j'ai essayé en définissant les points, avec toujours le même résultat.
J'ai aussi fait avec :

N41 G0 X27.1 S110 ;
G1 Z0 F0.12 ;
X25.1 , A-135 ;
Z-44 ;
X23 ;
N42 G0 Z5 ;

Et encore pareil.
C'est une machine d'occasion donc on contacte la société qui nous l'a revendu pour savoir s'il y avait une technique particulière ou pas. Peut-être bientôt une solution. Si on l'a je vous la donnerai.
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
Je ne sais pas si tu a la doc FANUC, je viens de la télécharger sur le site

#

Si ça peut t'aider

Bon courage.
 
Dernière édition par un modérateur:
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #14
Merci bien. Je vais étudier tout ça.
 
P
pakito61
Apprenti
7 Jan 2011
118
bonsoir je voie peut etre une valeur faible pour la prise de correction

N40 T1212 ;
G50 S2000 ;
G54 G96 G99 ;
M81 ;
G28 U0 V0 ;
G0 Z200 ;
G0 G41 X23 Z5 S90 M3 ;
M8 ;
G71 U0.5 R0.5 ;
G71 P41 Q42 U-0.2 W0.2 F0.2 S90 ;
N41 G0 X27.1 S110 ; [glow=red](25.1+ 2x le ch de 1) x27.1 trop faible pour prendre la correction de plaquette ( 27.1(25.1+ 2x c1) + 2x le rayon de plaquette)[/glow]
G1 Z0 F0.12 ;
X25.1 , C1 ; (chanfrein de 1 à l'entrée de l'alésage)
Z-44 ;
X23 ;
N42 G0 Z5 ;
 
JLuc69
JLuc69
Compagnon
19 Juin 2008
1 377
Genas (69)
Je pense que tu t'y prends mal dès le début :cry:
Personnellement, je programmerais comme ça :
Il y a deux choses à faire attention :
1/ il faut un déplacement minimum de 2*rayon de plaquette en X et 1*rayon de plaquette en Z
2/ il faut prévoir un peu de déplacement en X si tu passes par un chanfrein

Quand je programme, je fais comme ça (mais c'est ma façon de faire, hein) :
Je viens directement sur le chanfrein à 1 millimètre de la face en correction de rayon puis je mets mes points suivants en dur.
De mémoire, sur Fanuc, les chanfreins/rayons ne marchent que sur des lignes horizontales/verticales. Si tu as un cône, ça ne marche plus (enfin, c'était peut être avant la 32 :mrgreen: )
 
M
marto0362
Apprenti
10 Juil 2013
234
J ai le meme message en fao en fraisage et la avec des milliers de lignes pffff d ou vient l erreur.
 
JLuc69
JLuc69
Compagnon
19 Juin 2008
1 377
Genas (69)
marto0362 a dit:
J ai le meme message en fao en fraisage et la avec des milliers de lignes pffff d ou vient l erreur.
L'erreur vient souvent d'une distance trop faible entre le point de départ et le point de prise de correction ou le dernier point en correction et le point d'annulation.
Je m'explique :
je me positionne à X-10 Y8 en G40
Je prends ma correction en G41 à X-10 Y0
Ensuite je vais à X50 Y0
Puis j'annule : G40 X50 Y8
Jusque là, tout semble normal ! Mais, manque de chance, j'ai monté une fraise de Ø20 :axe:
Pour prendre sa correction, la machine est obligée de "sortir" de la matière donc alarme ! Alarme à l'entrée, alarme à la sortie ! Alors que si j'avais monté une fraise de Ø14, je n'aurais pas eu d'alarme.
Alors attention ! Ca, ça se produit sur quelques armoires, pas toutes. Je pense que c'est fonction des réglages du constructeur. Je ne connais malheureusement pas quels paramètres machines interviennent. Mais quand on programme, il faut prendre certaines bonnes habitudes :wink:
Les programmes que j'écris, passe sur toutes les armoires que j'ai pûs avoir à utiliser :mrgreen:
 
M
marto0362
Apprenti
10 Juil 2013
234
Je comprend ton raisonnement mais en fao il n y a pas d erreur possible les points sont bon vu que les prog tournent sur du num 1060 ensuite je change le post pro et je balance en fanuc et la ca plante .je vais essayé de faire avec des distances plus loin et je balancerais le prog sur le forum pour essayer de trouver l erreur merci jean luc.
 
P
PGL
Compagnon
29 Sept 2014
1 325
Toulouse
Les FANUC sont de bonnes commandes numériques, mais aussi de bonnes prises de tête.

Quand ça veut pas passer pour une histoire de rayon trop fort ou une virgule là ou il faut pas.
 
E
ESalomez
Nouveau
14 Oct 2014
12
Saint-Paul-lès-Dax
  • Auteur de la discussion
  • #21
Bonjour,

Un grand merci à tous pour votre aide et effectivement je n'avais pas pris en compte le rayon de plaquette, ce qui me mettait dans le rouge.
Ce problème est donc résolu. Encore merci.

Bonne journée à tous et à bientôt pour de nouveaux problèmes.
 
D
Délaissé de l'afpa
Nouveau
14 Mar 2019
1
Merci jLuc69, tu m'enlève une épine du pied :D.
 
Haut