DRO DRO sur base Arduino

  • Auteur de la discussion erolhc
  • Date de début
?
******
Compagnon
6 Jan 2014
2 881
paris
bonjour , afin de ne pas embrouiller votre sujet 59jag je vais ouvrir un topic qui decriras ma manip

s'il vous plais venez voir et dites moi votre avis

AMicalement

jc
 
D
diiity
Compagnon
6 Juil 2011
883
Re
Donc si pac lidl alimente en 3v et data et clk snt en 0 1,5v je propose ce montage
Voir la pièce jointe 270856
Merci 59jag mais ça marche pas, le pac est bien alimenté mais avec un contrste trop fort, l'affichage se fait correctement.

Par contre rien sur l'écran de l'arduino à part le nom de l'axe que j'ai changé
bonjour

il me semble que pour adapter la regle a 3V (3.3v exactement )

il suffit de suivre le shema de 59jag avec des resistances de 100 ohms?

non ? oui ? pouvez le confirmer 59jag?

[div=none][div=none][div=none][div=none][/div][/div][/div][/div]



D'autre part je viens de recevoir la regle, et du moment quelle est alimentée par la une tension de 1.5 v de la pile :

Si on eteint avec le bouton on/off

puis si on bouge la regle elle garde en memoire la derniere valeur

de meme si on etein et rallume avec on/off elle repart au valeur d'avant l'extinction et non de zero .

je ne comprends donc pas vos remarque


Amicalement

Jc

ps: que voulez vous dire ?
Merci 59jag mais ça marche pas, le pac est bien alimenté mais avec un contrste trop fort, l'affichage se fait correctement.

Par contre rien sur l'écran de l'arduino à part le nom de l'axe que j'ai changé.

La tension sur la sortie du pac est de 2v72

IMG_0624.JPG


serge
 
Dernière édition:
lion10
lion10
Compagnon
7 Mai 2010
4 725
Bonjour

Le pac est peut être bien alimenté en 1v5, mais il faut que les signaux qu'il génère vers l'arduino soient bien calibrés en terme d'amplitude :
-quand le pac génère un niveau logique 0 il faut qu'il soit inférieur ou égale à VI low max de l'arduino,
-quand le pac génère un niveau logique 1 il faut qu'il soit supérieur ou égale à VI hight min de l'arduino.

On peut tenir un raisonnement similaire dans l'autre sens, mais ici les signaux ne sont peut être que dans le sens pac => arduino.

Je ne sais pas quelles sont ces valeurs précises sur l'arduino mais quelqu'un qui en a un pour peu qu'il l'utilise en interface , il doit le savoir.
Bien entendu je suppose que vous avez bien respecté le schéma donné et pas fait d'inversion sur les fils din et dout.

cf http://www.locoduino.org/spip.php?article57

A défaut d'oscilloscope, en se mettant dans une situation où l'horloge du PAC est toujours générée il faudrait voir avec un voltmètre en tension continue qu'elle est la tension moyenne lue, cela donnerait un ordre de grandeur du VoH du PAC.
(Créneau 50 % de rapport cyclique, tension moyenne Voh /2 en considérant que Vol =0) .


cdlt lion10
 
Dernière édition:
D
diiity
Compagnon
6 Juil 2011
883
Bonjour,

Oui j'avais bien corrigé le sens de data et de clock depuis les premiers essais sur un pac 1.5v.

Là je viens de faire l'essai sur le pac 3v en branchant avec le schéma d'origine( les 2R de 100) le pac fonctionne bien, donc il faut bien 1.5v sur les sorties data et clock seulement là j'ai 0, peut être une histoire de niveau ou de programme à adapter, je ne sais pas.

En alimentant le pac avec sa pile de 3v, j'ai:
entre la sortie + et - 1.48v
entre data et gnd 1.48v
entre clock et gnd 0v
entre + et clock 1.48v
entre + et data 0v

En alimentant le pac 1.5v avec sa plie de 1.5v et qui fonctionne bien avec l'arduino, j'ai:
entre la sortie + et - 1.42v
entre data et gnd 1.36v
entre clock et gnd 1.36v
entre + et clock 0.06v
entre + et data 0.06v

Il y a donc un souci sur le pac 3v

serge
 
D
diiity
Compagnon
6 Juil 2011
883
Sur un pac neuf 3v, j'ai:

entre la sortie + et - 1.55v
entre data et gnd 0v
entre clock et gnd 0v
entre + et clock 1.55v
entre + et data 1.55v
 
5
59JAG
Apprenti
7 Fev 2010
200
59 chti nord
Re
Relie clk et data du pac sur les entrées analogique de l arduino, puis ecrit un prog qui lire les entrees Analogique et envoi le sur le tracer serie, pour voir la variation des signaux clk et data
 
D
diiity
Compagnon
6 Juil 2011
883
Re
Relie clk et data du pac sur les entrées analogique de l arduino, puis ecrit un prog qui lire les entrees Analogique et envoi le sur le tracer serie, pour voir la variation des signaux clk et data
Je veux bien faire ça mais je ne sais pas faire, je ne connais pas je ne suis qu'un simple monteur pas un créateur:sad:

Si tu peux me piloter pas de souci?

serge
 
?
******
Compagnon
6 Jan 2014
2 881
paris
Merci 59jag mais ça marche pas, le pac est bien alimenté mais avec un contrste trop fort, l'affichage se fait correctement.

Par contre rien sur l'écran de l'arduino à part le nom de l'axe que j'ai changé


Merci 59jag mais ça marche pas, le pac est bien alimenté mais avec un contrste trop fort, l'affichage se fait correctement.

Par contre rien sur l'écran de l'arduino à part le nom de l'axe que j'ai changé.

La tension sur la sortie du pac est de 2v72

Voir la pièce jointe 270923

serge
j'ai eu le meme probleme pour les signaux

j'ai mis des transistors et maintenant ca vas

Amicalement

jc
 
?
******
Compagnon
6 Jan 2014
2 881
paris
tu peux aussi regarder les signaux sur le port analogique oui c'est pas trop dure a faire comme programme

mais a mon avis tu vas voir des signaux faible ...
 
D
diiity
Compagnon
6 Juil 2011
883
tu peux aussi regarder les signaux sur le port analogique oui c'est pas trop dure a faire comme programme

mais a mon avis tu vas voir des signaux faible ...
Et comment fais tu, ce programme c'est quoi, je suis une buse en éléctronique?

serge
 
pierrem
pierrem
Apprenti
13 Déc 2010
125
Bonjour

bizarement je suis dans le même cas que diiity il y a quelques mois j'ai tenté le montage avec un PAC Lidl mais aucun résultat pourtant a oscilo on voit bien les trames CLk et DATA il ont bien une amplitude de 1,5 Vdc le problème était que lorsque l'une des pin était relié l'amplitude du signal diminuait a une amplitude de 0,4Vdc
Si je trouve le temps je referai le montage afin de comprendre ce qui cloche
 
D
diiity
Compagnon
6 Juil 2011
883
je veux bien, tu n'aurais pas un petit schéma par hasard:wink:

serge
 
M
metalux
Compagnon
11 Jan 2009
5 349
nord
pour amplifier le signal faiblard
celui ci par ex
levelshifter2.jpg
[div=none][arrow][/arrow][/div]
 
D
diiity
Compagnon
6 Juil 2011
883
merci Métalux mais l'alimentation 5v je l'a prends sur l'arduino ou en externe, le pac étant alimenté en 3v?

serge
 
M
metalux
Compagnon
11 Jan 2009
5 349
nord
visiblement l'alim est prise directement sur l'Arduino a l'aide d'un pont diviseur , mais rien ne t'empêche de lui créer sa propre alim le tout étant de respecter sa tension d'alimentation bien sur
 
D
diiity
Compagnon
6 Juil 2011
883
ça ne marche pas, ni avec l'alim prit sur l'arduino ni avec une alim extérieur.

Je vais changer de pac, peut être que celui ci à un problème puisque les valeurs relevées plus haut sont différentes.

serge
 
M
metalux
Compagnon
11 Jan 2009
5 349
nord
oui mais là, c'est un problême d'alim ou de lecture ??
il faudrait déjà savoir si il est bien alimenté dans un premier temps ( c'est un minimum )
et savoir que sur les pac du commerce il y a au moins 3 protocoles différents ,est ce le bon pac ?
 
D
diiity
Compagnon
6 Juil 2011
883
Ce qui serait le pied c'est que quelqu'un qui touche puisse se procurer ce genre de pac et le passer à la moulinette, ce pac est de la marque powerfix en 3V

serge
 
D
diiity
Compagnon
6 Juil 2011
883
J'ai donc refait le montage avec un pac neuf, cette fois il y a un affichage en utilisant les transistors et les 10R et une alim exterieur. Ne fonctionne pas avec alim prit sur l'arduino en 5v.

Si j'arrête le pac l'affichage se met à 0. Quand je démarre le pac l'affichage reste à zéro tant que je ne le fait pas varié, si je bouge le vernier alors l'affichage est n'importe quoi mais il est là, on avance...

serge
 
D
diiity
Compagnon
6 Juil 2011
883
celui ci n'est pas un powerfix, ce serait un Mitutoyo et donc peut être pas le même protocole.

Mais comment savoir si le programme a le bon protocole pour mon pac, je n'ai pas d'oscillo?

serge
 
M
metalux
Compagnon
11 Jan 2009
5 349
nord
effectivement ! si c'est un Mitutoyo ça ne fonctionnera pas, ils ont leur propre protocole ( Digimatic si mes souvenirs sont exacts )

je n'ai pas d'oscillo?
oui c'est un plus, mais encore faut il savoir interpréter les signaux
 
D
diiity
Compagnon
6 Juil 2011
883
sinon, pourrais tu me dire quelles marques fonctionnent bien ?

serge
 
?
******
Compagnon
6 Jan 2014
2 881
paris
salut diity

est ce que tu a bien fait la connection ( soudure ou contact directe ?

pourrai tu faire une photo de cela ?

Amicalement

ps : je me demande si ton probleme n'est pas la en particulier.

ps1: et si cela est ok alors c'est du coter d'une amplification a transistor du signal

qu'il faudrai que tu realise.
 
D
diiity
Compagnon
6 Juil 2011
883
Bon je pense que je vais laisser tomber et attendre de recevoir le nouveau pac.

Mais pour te répondre, oui j'ai tout fait comme il est dit bien sur sinon ça ne sert à rien.

serge
 
gaston83
gaston83
Compagnon
17 Fev 2016
1 499
FR-71520
Bonjour à tous
Je suis partant pour réaliser le projet.
Je possède un tour (vieux, très vieux) Louis BESSE que je voudrais actualiser car il est assez précis.
J'ai une arduino Duemilanove et une tablette TAB750 de Logicom.
Je tente désespérément de faire reconnaître l'arduino par ma tablette en USB mais pas moyen.
A priori d'après les videos ça fonctionne.
Quelqu'un a-t-il eu ce problème?
GG
 
D
diiity
Compagnon
6 Juil 2011
883
Bonjour,

Oui c'est celui ci, le n° de modèle est identique mais la version du mien est de 04/2013.

Tu crois qu'il possible de faire quelque chose?

serge
 
Haut