depannage DRO VISULESTA 2E

  • Auteur de la discussion midodiy
  • Date de début
midodiy
midodiy
Compagnon
24 Sept 2009
7 032
Reims
  • Auteur de la discussion
  • #1
Dernière édition:
midodiy
midodiy
Compagnon
24 Sept 2009
7 032
Reims
  • Auteur de la discussion
  • #3
Cette pile est soudée, je met 2 fils, je perce le fond pour mettre 2 piles de 1.5V à l'exterieur.
Remontage, meme erreur 4, en tapotant sur le clavier, je me rend compte qu'il faut faire 2 appuis sur C puis on peut alors rentrer la sequence" P701P, enter". Les 3 afficheurs passent à 0.00 gagné:smt023
IMG_20171030_163826.jpg

Normalement apres cette raz, on doit parametrer les caracteristiques des regles. Moi ça marche de suite.
En fait cette pile vient alimenter 2 boitiers de memoire volatile en cas de coupure secteur. Si pas de pile, à la remise sous tension, l'appareil demarre avec une erreur4...il faut faire la raz à chaque fois!
 
Dernière édition:
midodiy
midodiy
Compagnon
24 Sept 2009
7 032
Reims
  • Auteur de la discussion
  • #4
Normalement apres cette raz, on doit parametrer les caracteristiques des regles. Moi ça marche de suite.
Oups, l'affichage indique la moitié du deplacement reel! J'arrive à afficher la bonne valeur en rentrant P971P X 1 entré, idem pour Y et Z.(voir la doc rapide dans le premier post). J'ai une resolution de 0.005
Mais...J'ai toujours a gauche des afficheurs le sigle bizarre -I suivi de 8...ce 8 est tres genant quand le deplacement indiqué est superieur à 9.995 Exemple pour 9.995 j'ai l'affichage -I809.995, ensuite je passe à -I810.000 Si je depasse -I899.995, le 8 s'efface pour afficher le 1 -I100.000
:mad:
 
midodiy
midodiy
Compagnon
24 Sept 2009
7 032
Reims
  • Auteur de la discussion
  • #5
Les photos
Le sigle bizarre et le 8:
IMG_20171130_145450.jpg

deplacement du Y de 21.415mm
IMG_20171130_145529.jpg

deplacement du Y de 100.220mm
IMG_20171130_145623.jpg
 
midodiy
midodiy
Compagnon
24 Sept 2009
7 032
Reims
  • Auteur de la discussion
  • #6
Pas sympa chez Elesta, je leur ai demandé de l'aide par mail...aucune reponse depuis un mois:mad:
Maintenant que l'avance fonctionne, je regardais, facinné, l'affichage du X s'incrementer regulierement ...:shock: l'affichage passe directement de 8,995 à 10,000. En fait la plage du 9 existe mais il affiche 8. Et le meme defaut sur Y et sur Z!
Je me dis qu'il doit y avoir un decodeur 7 segment pour chaque colonne et que celui des unités doit avoir un probleme et que c'est peut etre le meme probleme sur l'afficheur constamment a 8...:roll:
 
C
cfort38
Nouveau
26 Déc 2010
35
isere (Vinay)
Bonjour
Regarde côté 8279 et plus certainement driver de puissance ULN2064. sur le schéma 8 en pj comme exemple, ils utilisent un ULN2003 mais sur la visu il s'agit d'ULN2064
Charles

8279.jpg


8279_1.gif
 
T
tronix
Compagnon
6 Mar 2012
1 327
Toulouse
Petite erreur sur les schémas : les transistors sont des pnp et non des npn.
 
midodiy
midodiy
Compagnon
24 Sept 2009
7 032
Reims
  • Auteur de la discussion
  • #9
Oui exact tronix!
J'ai regardé le circuit imprimé mais il est tres difficile de suivre, je me demande si c'est pas du multicouche...
Donc pas de decodeur BCD/7segments, le 8279 sort les 7 signaux qui doivent passer par des drivers uln2064 avant d'attaquer les afficheurs. Et 2 boitiers bizarre
Je vais voir si j'ai un 8279 dans les vieux stock au boulot...

20180114_144817.jpg


20180114_144704.jpg
 
Dernière édition:
T
tronix
Compagnon
6 Mar 2012
1 327
Toulouse
Double face sans plan de masse (à l'ancienne...), on suit facilement les pistes puisque l'on voit au travers. Cela ne devrait pas être trop difficile à dépanner avec un oscilloscope.
 
T
tronix
Compagnon
6 Mar 2012
1 327
Toulouse
Si ce sont des prom, elles ont pu être utilisées comme des pal pour faire du décodage, à une époque où les pal étaient encore peu courantes. Bon, et maintenant, tout ça est obsolète...
 
C
cfort38
Nouveau
26 Déc 2010
35
isere (Vinay)
une idée serait de suivre le signal pilotant le segment "e" de l'afficheur, l'uln2064 est un simple driver, tu pourras voir rapidement si c'est le 8279 ou l'uln qui est en cause. Je suppose que les proms permettent la sélection de l'afficheur 7 segments considéré, si elles étaient en cause ce serait tout le 7 segment qui serait en vrac.
J'avais commandé des 8279, en vue du dépanage de ma visu, mais bon il n'était pas en cause (merci encore pour l'eprom, midodiy). Je peux te dépanner !
 
midodiy
midodiy
Compagnon
24 Sept 2009
7 032
Reims
Merci a tous pour vos reponses,
J'ai pas de regle pour essayer sur table et j'ai pas envie d'en demonter une de la fraiseuse, je vais essayer de depanner par remplacement.
Je commande des udn2981, j'ai rien trouvé a mon boulot juste 2 Z80 et des proms qui ressemble mais pas exactement la meme reference .Et a quoi bon, sans le programme...
 
Dernière édition:
C
cfort38
Nouveau
26 Déc 2010
35
isere (Vinay)
Pas de souci pour les proms, je peux certainement lire le contenu des miennes, et leur fonction n'est qu'une table de correspondance, qu'on peut faire avec d'autres types de circuits (PIC, ......) si on ne trouve plus de prom sur le marché.
 
La dernière réponse à ce sujet date de plus de 6 mois
Haut