cotes de fabrication

  • Auteur de la discussion GEMI
  • Date de début
G
GEMI
Nouveau
6 Avr 2020
5
  • Auteur de la discussion
  • #1
Bonjour,voila mon problème: je me suis fait une petite cnc il y a environ 4 ans, je travail sous linux et là depuis quelques mois les cotes réalisées sur la pièce sont divisées par 2 ou 3.
Problème de linux, de carte électronique ou autre? Si quelqu'un à une petite idée je suis preneur , merci.
Je travail avec driver TB6600HG
2 moteurs pas à pas Néma 23 3Amp axes X,Y
1 moteur pas à pas Néma 24 4Amp axe Z
 
Dernière édition:
Earthwalker
Earthwalker
Compagnon
7 Déc 2013
1 211
45
A mon avis le probléme est purement logiciel , vous programmez bien en mm , pas en pouces , par hazard ?
 
F
franck67
Compagnon
22 Déc 2011
1 682
et c'est venu d'un coup de genre de chose ? si oui tu as du comme disent les autres modifier le parametre des unité ( dessin ou parametrage machine )
 
G
GEMI
Nouveau
6 Avr 2020
5
  • Auteur de la discussion
  • #5
Et bien non je suis toujours en mm, c'est une des premières vérif que j'ai faite. Oui c'est venu d'un coup, en règle générale je ne programme pas j'emploie
le logiciel INKSCAPE qui me fait le gcode.
Sincères salutations.
 
MegaHertz
MegaHertz
Compagnon
31 Août 2017
1 055
Bonjour,

Vu le facteur, on dirait que c'était en pouces avant et que c'est passé en millimètres.

Est ce que vous avez mis à jour l'électronique ou la machine linux ?

Est ce que vous avez mis à jour le plugin InkScape qui vous fait le GCode ?

Si vous imprimez votre tracé InkScape, à quelle taille sort il ?

Pourriez vous envoyer le texte du GCode ici ?
Les 30 premières lignes devraient suffire.
 
G
GEMI
Nouveau
6 Avr 2020
5
  • Auteur de la discussion
  • #7
je pense que le problème vient plutôt de linux car quand je fais la demo de base avec les caractères linuxCNC J'ai le même problème d'échelle.
 
J
Jmr06
Compagnon
14 Fev 2017
1 874
Cannes
Modif dans le fichier de config de LinuxCNC ? Quand tu bouges manuellement les axes dans l'IHM de LinuxCNC, est-ce que le axes bougent de la distance annoncé ? Si ce n'est pas le cas, c'est le fichier de configuration qui est à reprendre.

Édit : au démarrage de LinuxCNC, tu pointe bien vers le bon fichier ?
 
G
GEMI
Nouveau
6 Avr 2020
5
  • Auteur de la discussion
  • #9
Bonjour, j'ai vérifié en bougeant les axes dans l'IHM non les axes ne bougent pas de la valeur annoncée. Donc j'ai refait une configuration nouvelle le problème est le
même. Peut être faut il désinstaller LINUX CNC et le réinstaller?
Sincères salutations.
 
J
Jmr06
Compagnon
14 Fev 2017
1 874
Cannes
Peut être faut il désinstaller LINUX CNC et le réinstaller?
Je ne vois pas pourquoi.
Si cela ne bouge pas de la valeur annoncée, c'est qu'il y a forcément une discordance entre le fichier de configuration et le matériel.
Dans le fichier, tu as vérifié le rapport de poulie, le nombre de pas, enfin tous les paramètres d'un axe ? Sur le matériel, tu n'a pas modifié les micro pas ?
Quand tu modifies un paramètre dans le fichier, cela a bien une conséquence le le mouvement (c'est à dire que LinuxCNC prend bien en compte le fichier que tu es en train de modifier).
Si non, a part ça, je ne vois pas.

Édit : a si ! Quand tu lances un mouvement de 5mm sur l'IHM, le mouvement est toujours faux de la même valeur, ou cela varie ? Si ça varie, c'est peut-être une poulie mal serrée sur son axe.
 
G
GEMI
Nouveau
6 Avr 2020
5
  • Auteur de la discussion
  • #13
je vais revérifier un nombre de paramètres.
 
Haut