Circuit L6208N, sur driver HS

K

karimosdaily

Nouveau
Bonjour tous le monde, hier j ai allumé le controlleur de ma machine comagrav MT profit
J avais le moteur Z qui decroche depuis un mois mais j arrive malgré ça à travailler avec la machine car le phénomène s arrete au bous d un moment.

mais cette fois j ai entendu un sens bizzar un claquement puis j'ai senti une odeur que je connais trés bien une odeur de l electronique qui crame dan le controleur jai directement pensé au driver du moteur Z.

effectivement c' est le circuit integré L6208N qui est le driver du moteur z qui a cramé, jai débranché le câble du moteur z, tout est en marche sur la carte commande y,x capteur broche etc, en ouvrant le boitier j ai constaté ce qui ce trouve dans la photo ci jointe le circuit integré L6208N a cramé

20220710_011939.jpg


20220710_012245.jpg
 
D

Doctor_itchy

Compagnon
aie , avant de changer le ic il serais bon de voir le moteur et cablage , peu etre un court circuit quelque part ! un ic ne crame pas tout seul , et les décrochage aurais du t'avertir , pour vérifier le bouzin !

vérifie les impédance bobine du moteur et leur isolation entre elle et par rapport au chassis (masse)

vérifie les cable si pas de cc ou résistance entre fil

le drivers est en effet dur a trouver ! , cela dit il sont commander en step/dir (clock et cw/ccw) et ce sont des bipolaire , donc moyennant un petit pcb d'adaptation tu pourrais posé un drv8825 (2.5A) ou A4988 (1.5A) en lieux et place qui serais bien plus performant :wink: les stepstick comme sur les imprimante 3d (penser a posé un radiateur sur l'ic ! ) MAIS a voir le courant nominal du moteur :) sinon un plus gros a base de tb6600 ça iras aussi :) , il y a d'autre type de stepstick bien sur mais comme ici tu doit etre en demis pas avec probablement 2 a 2.5A moteur un drv8825 avec un gros radiateur sur le ic devrais faire le taf et ça tu en trouve pour 2€ sur ebay :wink:
 
D

Doctor_itchy

Compagnon
ha il est aussi possible qu'il a lacher car il n'y avais pas de radiateur sur le IC ! , normalement il doit y en avoir un :)
 
D

Doctor_itchy

Compagnon
ps , vérifie quand meme la tension d'alim du 6208 car il peu allez jusque 60V mais les drv8825 c'est 35 ...

sinon en gros sur ton pcb tu soude quelque fil

enable
clock
cw/ccw
VDD+ (alim moteur donc "gros" fil)
VSS (la masse "gros" fil aussi )
A+
A-
B+
B- (les bobine moteur )
un VDD +5Vdc (ne branche PAS une entrée 5V sur l'alim moteur ! (au pire si ta max 35V une lm7805 sur la tension alim moteur vers les 5V ,ou un module stepdown )

et tu branche le moteur stepstick sur ses fils au bon endroit (c'est noté dessus)

tu regle le courant nominal moteur (le réglage est sur le stepetick)
tu choisis le mode de pas qui convient a ton controleur ( via les 3 borne ms1 ms2 ms3 , soit vers masse soit vers +5v )

bien sur tu vérife sur les datasheet le bon emplacement des pins :wink:

ça peu se faire avec des fil de 5cm en "volant" pour validé et par apres un pcb avec du "veroboard" :)

tant que a faire si ça marche tu fait tout les axes aussi :)

puis si coté soft c'est possible de modifier le nombre de pas par mm tu met les drivers en 1/32eme de pas et tu profite du microstepping et tu augemente virtuellement ta précision d'axe :) (sinon tu config comme est configuré les drivers d'origine ! )

et roule :)
 
K

karimosdaily

Nouveau
Merci pour vos réponses, Docteur_itchy il y avait un radiateur mais je l ai enlever a fin de pouvoir vérifier et puis photographier la trace de l'étincelle mais c est vrais que la ventilation manque cart un seul ventilateur pour tous le boitier ne suffit pas il faut peut-être comme tu a dit changer les radiateurs et faire des ventilateur sur chaque driver, je suis peut-être devant 4 solutions possible :

- faire appel au revendeur pour me réparer la carte et remplacer le driver et vérifier la cause qui a engendrer la panne

- demander au revendeur de commander une nouvelle carte entière et la remplacer

- reparer la carte chez un réparateur de circuit electronique industrielle

- basculer sur une autre carte CNC ( nc-studio) ou grbl ou mac3

Pour ce que tu as proposer d utiliser d autre driver plus performant et bien ventilé jai pas compris car les trois moteur sont commandés par 3 drivers intégrés et soudés sur une carte imprimé tous le system est piloté par un logiciel spécifique au constructeur Tchèques de la machine TDP PILOT 3D la marque de la machine est COMAGRAV MT PROFIT

J ai pas lu ton message récent Docteur_itchy
Je crois nous écrivant deux message au même moment,
 
D

Doctor_itchy

Compagnon
ma solution permet de garder la carte , tu vire juste les ic l6208n et tu les remplace par des step-stick , si la tension d'alim moteur est inférieur a 35Vdc des drv8825 ou A4988 irons très bien :)

donc si spécifique on ne sais sans doute pas changer la valeur des pas , mais ce n'est pas grave les stepstick on 3 pin pour configurer les pas , il suffit de les configuré en demis pas (1/2 pas ) vu que les l6208n sont soit pas entier soit demis pas :) et métonnerais que ce soit en pas entier :wink: , tu peu rétrofiter aussi ça enleve tout les soucis d'origine pour passer sur un truc simple et ou tu a enormément de tuto et d'info (grbl donc ) qui fonctionne relativement bien si correctement configuré et câbler :)

la cause c'est soit le moteur malade , soit un court circuit , soit un mauvais contact entre la carte et le moteur , et le fait que tu a continuer a bosser avec alors que le drivers se mettais en sécurité , et il a fini par lacher :wink:

par contre faire réparé a l'origine vu la difficulté a trouver le composant tu risque de payer cher et vilain , et j'imagine que chez le fabricant ce n'est plus sous garentie .... , il vont surement balancer un tarif qui te donnera envie d'acheté neuf !

chez un réparateur , plutot un petit réparateur , ceux pour l'industrie la aussi il vont te demander 10x le cout du ic au minimum !

si tu le fait toi meme , le stepstick 2 a 4€ , quelque fil , un fer a soudé , un testeur de continuité et de la patience pour ne pas se tromper de fil et tu le répare toi meme :)

je pourrais te le faire rapidement mais je suis en Belgique :) (et je doit avoir des stepstick qui traine ^^ )
 
K

karimosdaily

Nouveau
☺merci infiniment pour tes conseil precieuse Docteur_itchy.
Je suis tenté par la solution du stepstick j ai même penser à s investire a un peut de matériel de réparation électronique et amélioré ma machine cnc au lieu de payer cher une reparation pour garder un système qui peut ne pas être stable ou qu il retombe encore une fois, je joint une photo du moteur de l axe Z en question avec son datasheet

20220611_230137.jpg
 

Fichiers joints

  • SL23.pdf
    55 KB · Affichages: 12
D

Doctor_itchy

Compagnon
le pdf ne correspond pas au moteur :)

ton moteur en photo fait 0.7A bobine en série ou 1.4A en // , c'est un moteur 4 bobine il doit avoir 8 fil normalement ! a voir comment il est brancher ( en serie pour de grande vitesse et en parallel pour du couple , en général il sont mis en // ) ce qui donnerais 1.4A nominal a réglé sur le stepstick , reste a connaitre la tension d'alim c'est surtout elle qui va déterminé si un stepstick est possible ou pas

:wink:

pour connaitre le courant , moteur débrancher tu mesure entre deux fil (coté connecteur pret de la carte de commande en // tu doit avoir +- 2.5ohm , et en serie 10ohm :)
bon apres la réparation toi meme est a tes risque :) , si vraiment tu le sens pas , tu fait faire comme greg le demande , donne ta localisation pour voir qui serais le plus pret pour éventuellement t'aider "irl" ,voir faire le job :)
 
K

karimosdaily

Nouveau
Bon pour le pdf tu as raisons il ne correspond pas au moteur,
J ai trouver le bon et tu as raison concernant l amperage et la tension c exactement comme tu as dit voir piece jointe et capture d ecran jai mis en cercle rouge ce qui confirme ce que tu as dit concernant l amperage et la tension, pour la proposition de greg je le remercie bien c est gentil de ça part pense à ça, je prend par rapport à ça un peut de recule jusqu au voir pour quelle solution je vais opter

20220712_015148.jpg


20220712_015148.jpg


La tension d alientation est de 35v comme indiqu é sur les condensateurs, j ai constaté que le câble du moteur est abîmé(photo jointe), j ai attaché aussi une vu generale du boitier

20220712_021814.jpg


20220712_022004.jpg


20220712_022108.jpg


Une photo du moteur oui je confirme c est du 8 fils, est il possible que les colier de serrage peuvent causer un court circuit ?

20220712_024648.jpg


20220712_024710.jpg
 

Fichiers joints

  • 6973241 (1) (1).pdf
    790.4 KB · Affichages: 7
D

Doctor_itchy

Compagnon
pour la tension , si capa de 35V on doit etre dans les 24Vdc , a vérifier au testeur ! (capa toujours 1/3 en plus de la tension au minimum :) )

mais un testeur au borne d'alim des drivers l6208 donneras la bonne tension ( pas faire de court jus avec les pin du testeur ! )

donc a prioris rien n'empeche le stepstick :)

le connecteur db25 c'est le blindage un peu abimé , si il n'y a aucune pin en court circuit ce n'est pas bien grave :)

wow cablage pas tres pro :o , possible que les cosse soit mal sertie et faux contact ou un fil a toucher la masse (chassis) faut vérifier que tout est bien isoler :) et vérifier les resistance des bobine du moteur entre elle , et l'isolation entre bobine et bobine/masse , tu doit avoir que l'impédance bobine et toute les meme :)
 
greg_elec

greg_elec

Compagnon
Pour le cablage je trouve @Doctor_itchy un peu dur .
Moi non plus je n'aime pas ces cosses mais d'apres les marques de pince sur les cosses c'est la bonne pince qui à été utilisée et le fait de mettre des colliers comme cela me fait pensé à de l'industriel plutot que du bricolo.
@karimosdaily tu ne nous à toujours pas dit ou tu habitais ?
 
K

karimosdaily

Nouveau
Je commence par répondre d abord @greg_elec , j habite à Tunis capital de la Tunisie, j ai cru que mon profile sur usinage.fr affiche quelque part ma localisation ce n est pas le cas puisque tu as demandé.
En ce qu concerne la tension d limentation
J ai attaché une capture d une rubrique dans le pdf qui contient une indication sur la tension d limentation du moteur.

Je doute d'une chose encore qui peut être à l'origine du court circuit ou de retour de courant de masse vers la CI:

J ai constaté que le capteur d origine machine Z:

Qui est imbibée d huile de glissière verticale du chariot Z et je me souvient que le phénomène de décrochage a commencer après une séance de nettoyage et de maintenance avec de la graisse sur les visse abeille et du l'huile sur les glissieres

et j espere ne pas compliquer les chose

aujourd'hui

Jai consulté trois gros fournisseurs,
la CI L6208N n'existe pas en tunisie, la DVR8825 existait mais maintenant en rupture de stock

Je suis coincé, je ne sait plus quoi faire
 
D

Doctor_itchy

Compagnon
ha tunisie ça fait un peu loin ^^

possible que l'huile ou le nettoyage a provoquer un soucis , court jus , pas avec de l'huile , peu etre une crasse metallique qui a toucher deux fil OU , simplement quand tu a nettoyer une crasse est allée se loger dans les guidages a bille , vis a bille , et ça a coincer l'axe , forçément le moteur décroche/coince , il faudrais démonté le moteur de l'axe et tourné la vis a la mains , ça doit etre façile a tourné sans point dur sur toute la course , si c'est pas le cas il faut démonté et nettoyer a l'alcool isopropylique (et faire gaffe de pas perdre des bille en démontant et c'est assez "chiant" a remonté , a ne faire que si vraiment y a une crasse DANS la noix a bille ou DANS le guidage a billes ! )

pour les cosse , sur une machine pro ce genre de connection moteur ce fait avec un connecteur 4 ou 8 pin car la si on démonte il faut etre sur de remetre dans le bon sens , et ça fait vachement plus propre ! sur des machine de ce tarif mettre des cosse au moteur pas a pas fait "bricolo" :)

pour le voltage ne te fie pas au datasheet , ou alors tu n'as pas regarder le bon condo , il y en a un second derriere celui que tu a regarder , meme tension ? car normalement si capa de 35V on est a 24V réel , mais ça il faut un petit testeur de tension DC et regarder la tension au borne VDD et VSS du l6808n :) et tu sera fixer sur la vraie tension :wink:

apres si c'est réellement 35V le drv8825 iras ( limite mais iras ) si tu ne le trouve pas dans ton pays regarde si tu ne trouve pas de A4988 !

sinon il faudras partir sur des module plus gros

style ceci



ou encore plus gros (mais baser sur la meme puce que celui au dessus )


mais aucune idée des disponibilité dans ton pays :/
 
K

karimosdaily

Nouveau
Merci encore une fois @Doctor_itchy pour ton implication à mon problème tu répond comme ci tu est en train de le faire pour toi-même

j'apprécie beaucoup ton attitude bienveillante

En même ton je me demande est ce que ce genre de dépannage ou retrofit comme tu as dit qui théoriquement se tien debout d après ton description quelqu un la déjà fait dans la pratique? et est ce que je ne risque rien si je teste ça

Il se peut que intuitivement cette idée est venu à toi pour trouver une solution a ce problème mais personne ne la déjà fait dans la pratique
 
D

Doctor_itchy

Compagnon
pas de soucis le forum est la pour l'entre aide :)

alors le rétrofit ( mot qui veut dire , de partir sur une base existante pour la mettre a neuf ou au norme ) on le fait par ici et un par de tout le monde (sans doute nommer autrement dans certaine partie du globe ? ) l'idée etant de viré totalement l'éléctronique d'origine (trop ancienne , en panne , ou totalement incompatible avec des soft récent ) ainsi que les moteur , pour repartir sur du "neuf" coté moteur , coté éléctronique , mais cela impose que la commande la machine soit changée elle aussi , dans bien des cas on utilise "grbl" qui est un "firmware" que l'ont programme dans un arduino (un nano peu géré 3 axe correctement , mais si on veut etre "fiable" il faut une mega2560 , ce firmware est donc sur ce microcontrolleur , qui lui est posé sur une carte et sur cette carte on y pose des "stepstick" de sont choix , il faut un soft compatible GRBL pour le commander , et cela via le port USB d'un pc (un pc sous winxp minimum ou linux ) le soft sera soit le soft crée pour le firmware , soit un soft plus complexe , style Bcnc , mais il en existe d'autre ! ou si la machine a une application propre faire le soft toi meme sous phyton (language de programation ) mais ça deviens complexe :)

le retrofit prendra du temps et tu risque de ne pas avoir une machine utilisable rapidement ! a toi de voir tes compétence , et bien se renseigné avant de se lancer la dessus :)
 
K

karimosdaily

Nouveau
Bonjour,

Hier jai procédé à quelque test, j ai branché le moteur Z sur le driver y il marche trés bien sans problème, jai lancé le palpage automatique du z il marche en virtuelle, j ai essayer de situé le problème et la cause, il est sans doute dans le driver L6208N du Z,

je doute d ' un retour de courant de fuite a travers la masse car il se peut qu un problème de mise a la terre mal fait ou absent car un léger courant circule dans les piece métallique du bati (problème d isolation aussi probable)

Les deux etincelles ont eu lieu entre les pin (VsA et GND) et (VsB et GND) comme sur la photo jointe

20220716_101403.jpg
 
D

Doctor_itchy

Compagnon
normalement les bobine moteur sont isolée de la partie métalique du moteur , donc un retour de terre ne peu pas faire cela (tu a vérifier l'isolation des bobine moteur vers le chassis moteur ? )

VSa et VSb sont les arrivée de courant d'alim positive du moteur (alim des deux demis pont en H séparée ) , gnd est forcément le négatif de l'alim

ça sa sans doute surchauffer et les pont interne ont brulé sur VSa et VSb , ou un "copeau" ses mis sur les 4 fil

dans tout les cas il faut changer le chips :)

tu a trouver un composant livrable par chez toi ?
 
K

karimosdaily

Nouveau
Oui Hamdou le Allah( merci à dieu),

aujourd'hui je me suis déplacé a un boutique d electronique que je connais depuis longtemps au centre ville j ai trouver la L6208N une dernière dans le stock

Maintenant je dois désouder l ancienne et remplacer la CI

Avant tous je doit penser à la sécurité contre les courant de fuite et au point suivant:

- est ce que d apres la photo que jai envoyer tous les pin sont soudé? si non je peut utiliser un loupe pour voir les pine souder sur les deux faces et comparer avec les autre driver xy

- doit je vérifier d autre composante avant de souder comme les diode zener ou autre

- pour le moteur il est intacte je lais testé j esper que la panne est juste au niveau de la Cl L6208N

Qu est ce que tu me conseil de faire comme plan pour réussir ce dépannage
 
D

Doctor_itchy

Compagnon
tu va etre obliger de faire comme cela , sinon tu risque d'abimé le pcb en chauffant et en rechauffant pour tout défaire !
 
K

karimosdaily

Nouveau
@Doctor_itchy , jai pensé aussi a souder un support pour la ci et éviter de la chauffer avec l etain ca me permet aussi de changer facilement en cas de panne
 
f6exb

f6exb

Compagnon
@Doctor_itchy , jai pensé aussi a souder un support pour la ci et éviter de la chauffer avec l etain ca me permet aussi de changer facilement en cas de panne
Sans vouloir être oiseau de mauvaise augure, est-ce utile ? :mrgreen:
(Non, pas taper !)

aujourd'hui je me suis déplacé a un boutique d electronique que je connais depuis longtemps au centre ville j ai trouver la L6208N une dernière dans le stock
 
greg_elec

greg_elec

Compagnon
Evite les supports c'est un nid à problèmes surtout que le L6208N chauffe donc surtout pas de support !!!
 
D

Doctor_itchy

Compagnon
non pas de support , trop de courant par les pattes ça risque de chauffer et bruler encore , puis avec le radiateur posé dessus ça va posé des soucis d'ordre "mécanique" :)
 
K

karimosdaily

Nouveau
Bonjour , j hesite toujours avant d entamé le remplacement de la CI L6208N car je suis mal équipée et je me demande est ce que tous simplement il suffit de désouder les 24 pattes de la CI est de soudé la nouvelle c.a.d les 24 pattes de la nouvelle CI

Ou dois je soudé des deux face
Ou soudés certaine pattes des deux faces

J ai remarqué que le carte imprimé est multicouche donc les trous sont métallisés
avec des vias
20220724_180826.jpg
 
M

metalux

Compagnon
Oui c est une méthode @f6exb je vais faire comme ça peut-être,
peut être?? vu la surface du plan de masse tu n'as pas le choix, ce n'est pas a la tresse a dessouder ou un simple fer a souder et pompinette que tu vas y arriver si les pattes du composant sont toujours en place,
Tu coupes a ras (avec la pince adéquat) tu chauffes la pate et tu l'extrais avec une pince, c'est seulement a partir de là que tu pourras déboucher les trous aisément sans tout foirer (piste qui se décolle entre autre) .

multicouches ou double face?? quoi qu'il en soit les trous sont métallisés donc tu ne soudes que sur une seule face et par capillarité la soudure va migrer sur l'autre face

te l'aurai bien fait, mais ça fait loin..
 
Dernière édition:
Haut