Carte commande PAP chinoises à base de TB6560 : ATTENTION!!!

  • Auteur de la discussion ewidance
  • Date de début
ewidance
ewidance
Ouvrier
4 Oct 2010
268
Montpellier
  • Auteur de la discussion
  • #1
Bonjour à tous.

J'ai acheté sur un grand site d'enchères en ligne un contrôleur Pas à Pas chinois 4 axes à base de TB6560 de Toshiba. Elle ressemble à ceci :

tb6560_4axis.jpg



Sur le papier, elle est en effet très intéressante :

- Contrôle de 3 à 6 axes selon la version
- Jusqu'à 3.5A par axe (36V max, 24V nominal)
- Fait les micropas jusqu'au 16e de pas
- Une seule tension d'alimentation, les 12V et 5V sont générées directement sur la carte à partir du 24V.
- Entrées / sorties entièrement sur opto coupleurs pour protéger le port parallèle du PC
- Led de contrôle d'activité sur les axes
- Relais de commande de broche intégré[/list]

Malheureusement, j'ai découvert lors des essais sur table que cette carte a un défaut majeur de conception. Pour ceux que cela intéresse, j'ai fait une synthèse des modifications à réaliser (partiellement de CNCZone, partiellement de mon cru) à l'aide d'un tutorial que j'ai mis en ligne ici :
http://www.civade.com/tag/cnc


J'espère que cela aidera ceux qui comme moi on failli se retrouver avec une carte inutilisable....
 
phil916
phil916
Compagnon
22 Août 2007
5 603
Le pays du Comté
Bonjour et bienvenue,

tu fais très fort pour un premier message, merci de ta participation active avec ce tutoriel :-D
Je suis au courant du sujet cnczone que tu cites car j'ai une TB6560 3axes et me suis donc renseigné avant de la brancher,
heureusement car sous 36V elle aurait vite fait pufffffffffffffffffffffff :roll:

En fait la mienne fonctionne bien hormis un bruit "de cigale" important.
J'arrive à des vitesses de 500mm/m sur mon petit tour, tu trouveras le
sujet avec deux vidéos ici.
On peut voir qu'entre la première et la deuxième j'ai trouvé les bons réglages :-D
donc pour moi pas de soucis, elle a fonctionné dès le branchement et sans modif, coup de bol ?

Avant de la monter définitivement je regarderais pour booster le signal clock et améliorer ce qui peut l'être cela dit...

Phil
PS: Sur ton site le lien "la mienne" donne une page 404
 
ewidance
ewidance
Ouvrier
4 Oct 2010
268
Montpellier
  • Auteur de la discussion
  • #3
Merci Phil pour ta réaction et pour le compliment.

J'ai une 4 axes et non la 3 axes. La différence est peut être là..

Apparemment, il est possible de corriger partiellement par logiciel, en augmentant la taille des impulsions de STEP . Peut être justement as tu des impulsions plus larges que sur mon soft?

J'ai vu sur ton post que tu bosses sous Mach3. Je suis personnellement sur EMC2 avec les réglages de largeur d'impulsion par défaut.

J'ai préféré la modification hardware, car pour avoir mis un oscilloscope dessus, le signal a réellement un drôle de tête... et après modif, il est 'beau' (encore faut il est sensible à la beauté des signaux :) ). Mais vu comment cela fonctionne, il est possible que la qualité du port // ait une influence (ex: sortie sur un vrai 5V et non un 3.3V), ainsi que la fréquence de commande. Souvent sur les portables, les signaux sont moins boostés (U < 5V), ce qui peut avoir un impact.

Mais le principal problème reste un manque d'immunité au bruit. Et ca, malheureusement, on le le découvre que dans un environnement parasité....

Ceci dit, sur ta première vidéo, à la seconde 51 (et pendant 6/8 secondes), on entend des irrégularités dans les harmoniques, qui sont exactement ce que j'ai constaté sur ma carte, mais beaucoup plus souvent. Peut être dans ton cas est-ce un bruit mécanique, mais dans le mien cela n'en était pas (les moteurs n'étant pas montés).

A noter que l'axe X dans mon cas marchait à peu près, mais que la catastrophe était avec l'axe Y et suivants...

Mais peut être as tu une carte dont le schéma est différent du mien ? Peux tu passer une photo des deux coté de la cartes? J'ai vu sur ta première vidéo que ta carte a l'air identique à la mienne (hormis le nombre d'axes) mais voir les CMS à cette distance est un exercice de style :) .

PS : J'ai corrigé le lien, merci..
 
D
denys_w
Nouveau
19 Sept 2010
36
Liège (Belgique)
bonjour,
J'ai acheté récemment un kit moteur et carte, en connaissance de cause puisque jouer du fer à souder ne me fait pas trop peur, par contre en regardant de plus près ma carte je constate une petite différence dans la valeur des composants.
Sur ma carte, les 4 résitances à déplacer ne sont pas de 10k mais bien des 4.7k, je voulais les enlever et acheter 6 résistance de 10k (je ne recycle pas les anciennes résistances) mais n'étant pas électronicien, je voudrai avoir vos lumières.
Je joint la photo de ma cartes, j'ai fait des trais devant les 4 résistances que je pense déplacer et 4 traits là où je pense qu'il faut les souder.
img_3844.jpg
 
M
mikomatik
Nouveau
12 Sept 2009
24
20km Est d'Orléans
Bonjour,

Tu ne peux pas changer de valeur de résistances "au hasard", simplement parce que la carte d'un autre membre n'a pas les mêmes.
Il faut d'abord analyser les fonction des signaux qui passent par ces résistances ainsi que les caractéristiques statiques et dynamiques des composants auxquels ils sont reliés avant de modifier à la volée.
Donc impossible de t'aider sans au minimum un schéma nomenclaturé ...

De plus en observant la photo de la carte, je ne suis pas convaincu que celle-ci passe les tests CEM au vu du routage (2 couches ?) compte tenu des commutations en courants forts qui y circulent.
Pour avoir une bonne immunité sur ce genre de matos l'idéal est un plan de masse complet (entre autre), ce qui induit du 4 couches.
Je doute fort que ce soit le cas de ces cartes grand public "made in PRC".
D'ailleurs y a-t-il un n° de certification CEM imprimé sur la doc ou simplement une estampille CE ?
Ne soyons donc pas étonnés que certains appareils travaillant à courants et tensions faibles soient perturbés par ce genre de carte sans avoir mis en place certaines précautions de blindage et câblages (et encore ...).
Au final le fabricant aura tiré son PR un max vers le bas, trompant l'utilisateur qui pensait faire une bonne affaire mais se retrouve souvent confronté à des dysfonctionnements aléatoires.
Vaste et récurrent problème de production de masse à l'économie.
 
phil916
phil916
Compagnon
22 Août 2007
5 603
Le pays du Comté
ewidance a dit:
...

Mais peut être as tu une carte dont le schéma est différent du mien ? Peux tu passer une photo des deux coté de la cartes? J'ai vu sur ta première vidéo que ta carte a l'air identique à la mienne (hormis le nombre d'axes) mais voir les CMS à cette distance est un exercice de style :) .
...
Bonjour,

oups mes plates excuses je n'ai pas eu d'alerte de réponse :shock: et ai raté ta question :oops:

voilà quelques tentatives de photos macros de ma carte.
Il y a des choses assez étonnantes comme des valeur indiquées dans le masque de circuit et des composants soudés de valeur différente...

à bientôt
Phil

macro8.jpg


macro7.jpg


macro6.jpg


macro5.jpg


macro3.jpg


macro2.jpg
 
E
Edge540
Apprenti
1 Oct 2010
203
Metz 57
Bonjour, pour ma part j'ai une carte 5 axe très similaire et les résistance cms 10K marquée sur le circuit sont également comme denys plus haut des 472 dont 4,7 K...??

Comme la modifications proposées lconsiste à les enlever, est'il possible de réaliser cette ajout du circuit 74HC14 dans le post. Je ne suis pas spécialiste en électronique non plus et hésite donc à me lancer, la modification n'étant cependant pas très complexe..

Votre avis??
 
D
denys_w
Nouveau
19 Sept 2010
36
Liège (Belgique)
chose bizard, en regardant de plus près ma carte, il fait écrit 4,7k pour les résistance par contre sur les résistance elles même, il fait inscrit 103 donc je présume que c'est des 10k :???:
Donc à priori il n'y a pas de problème :?:
 
E
Edge540
Apprenti
1 Oct 2010
203
Metz 57
C'est fait j'ai modifié la carte selon les conseils du post; Sur la 5 axes cela fonctionne également sans problème.
Encore merci à Ewidence pour les liens et le tutorial
 
E
Edge540
Apprenti
1 Oct 2010
203
Metz 57
Voila des photos de la modification de la carte 5 axes.

La carte additionnelle comporte le montage du buffer , des résistance et du condensateur comme indiqué sur le lien civade

P1070704.JPG


P1070699.JPG


P1070706.JPG
 
phil916
phil916
Compagnon
22 Août 2007
5 603
Le pays du Comté
Merci et tu remarques une grosse différence ?

à+
Phil
 
E
Edge540
Apprenti
1 Oct 2010
203
Metz 57
Le fonctionnement est amélioré. Plus de pertes de pas , et vitesses /accélérations plus performantes.
Ceci étant pas de miracle non plus. Mais cela fonctionne mieux.
 
E
e_kimmu
Nouveau
12 Déc 2010
6
Une fois retirées les résistances de controle de courant, n'est il pas plus simple de retirer les optos qui commandent les step et relier la br2 des supports à la br4 car là ou sont placés les optos, ils ne servent pas à grand chose.
les 7414 en entrée protègent déjà le port // du pc et on est déjà en niveau TTL. De plus les sorties du 7414 sont protégées par la resistance de 150ohms
 
ellogo67
ellogo67
Compagnon
14 Avr 2010
2 209
Soufflenheim - Alsace
Bonjours :-D

connaissant les risques, je viens tout juste de commander une carte 4 axes du même gabarit pour 60€. :)
Les coups de soudures ne me font pas peur. 8-)

Je ferai des essais sans modifications.

Si cela ne me convient pas aux essais, je ferai les modifications.

Bien entendu, je vous tiendrai au courant des évolutions de la chose. :wink:


:wavey:
 
M
mictor
Apprenti
3 Mar 2008
93
BOURGES CHER
bonjour

Ellogo67 : quelle carte avez vous commandée et sur quel site car il y beaucoup fournisseurs surtout sur ebay

cordialement

mictor
 
ellogo67
ellogo67
Compagnon
14 Avr 2010
2 209
Soufflenheim - Alsace
Bonjour mictor :-D

Voici la carte que j'ai commandé.

Par rapport aux autres, le port est gratuit, ce qui fait un ensemble pas trop chère. :wink:


:wavey:
 
M
mictor
Apprenti
3 Mar 2008
93
BOURGES CHER
bonjour

Merci Ellogo67

votre avis sur la boutique (delais et com ) et sur la carte bien sur quand vous l'aurais reçu.

cordialement

mictor
 
T
tourniquet
Ouvrier
14 Déc 2008
497
Le port n'est pas gratuit chez lui.

Quand on fait défiler ses nombreux produits on trouve le produit gratuit et le même produit avec frais de port en plus.

Pour ceux ou le port est gratuit, il est simplement majoré du montant du port.

Arnaque apparemment courante sur Ebay.
 
ellogo67
ellogo67
Compagnon
14 Avr 2010
2 209
Soufflenheim - Alsace
Bonsoir :-D
pour le cas de l'article que j'ai acheté, celui-ci est encore moins chère quand tu lui enlèves la majoration par rapport au produit non majoré et dont le port est indiqué. :wink:

Peut être un coup de pub. :-D ou j'ai eu de la chance. 8-)

Ou que je vais recevoir juste le carton d'emballage. :rirecla:



:wavey:
 
ellogo67
ellogo67
Compagnon
14 Avr 2010
2 209
Soufflenheim - Alsace
Bonsoir ewidance :-D

excellent ton petit reportage. :)

Des montages électroniques comme je les aime. :wink:

As-tu fait des essais de l'ensemble ?
Doit-tu renforcer un peu la ventilation interne ?

Encore bravo. 8-)


:wavey:
 
phil916
phil916
Compagnon
22 Août 2007
5 603
Le pays du Comté
Bonsoir,

j'ai commandé une télécommande pour aller avec ma carte 3 axes voir ici



quand elle arrivera (15 jours)
je vous dirais si ça vaut le prix demandé...
 
ellogo67
ellogo67
Compagnon
14 Avr 2010
2 209
Soufflenheim - Alsace
Bonsoir :-D

à ce propos, ce serait intéressant de connaitre le rôle de chaque pin de la DB15 ( prise accessoires ).

Je ne pense pas que cela va être marquer sur la doc, s'il y en a une, bien sûr ... :P

Comme cela, on pourrait se construire une interface pour diriger la broche ... :wink:


:wavey:
 
G
gralo
Compagnon
20 Jan 2010
507
31 et 46
c'est marrant ça!

Ce week end je me suis fabriqué un début de télécommande:

-Un bouton poussoir marche moteur.
-un commutateur marche avant /marche arrière
-Un potar pour la vitesse des moteurs.
-Un commutateur pour le choix de l'axe.

Les problèmes que j'ai rencontré pour ma carte:

-Impossible d'identifier toute les pins, aucune doc ne correspond au pin de ma carte.Il me manque la pin d'arrêt d'urgence, et les pins directions y, z.

-Pas possible de faire fonctionner la télécommande sans avoir mach3 de connecter pour la simulation de l'arrêt d'urgence.

En fait le probléme que la valeur de déplacement ne se reporte pas dans mach3 m'a fait abandonner le projet.

Mais si quelqu'un est motivé pour en faire une...le montage est très simple
 
J
jmspaggi
Ouvrier
22 Oct 2010
438
Canada
As-tu un lien pour la télécommande?

C'est quoi son schéma de principe? Un bouton par fil? Ça m’intéresse pour mon montage...

JM
 
ewidance
ewidance
Ouvrier
4 Oct 2010
268
Montpellier
  • Auteur de la discussion
  • #26
A ellogo67 : Non je n'ai pas renforcé la ventilation interne pour le moment, le boitier étant perforé, l'alim et les drivers étant ventilés, et le courant dont j'ai besoin étant = 2.5 A. Ce qui pèche le plus, c'est la température de fonctionnement des régulateurs 12V et 5V, les radiateurs étant un peu petits.. Mais cela reste acceptable (45/50 degrés).

J'ai fait des essais de l'ensemble et les performances sont correctes (après modification bien sur). Je ne publie pas encore l'article sur la modification de la fraiseuse KT150+BFB2000 car les modifications mécaniques ne sont pas encore satisfaisantes. Par contre, la Proxxon KT150 est terminée. Je pense faire un article une fois les fêtes terminées.

Concernant le câblage de la prise accessoire, si, c'est marqué sur la doc.. En 4 axes, elle est ici: http://www.civade.com/images/cnc/TB6560 ... iver-1.doc

P1 Z/C empty
P2 C Step
P3 Z Step
P4 X Dir
P5 X Empty
P6 Y empty
P7 Y Dir
P8 Z Dir
P9 C Dir
P10 Spindle motor
P11 Y Step
P12 X Step
P13 STOP
P14 GND
P15 5V/vdd

A Gralo : L'arrêt d'urgence est en P13...
A jmspaggi : Je pense qu'il faut réaliser une interface avec des boutons ET un peu d'électronique pour éviter les rebonds et générer les trains d'impulsions. Je ne serai pas surpris que l'on trouve un micro-contrôleur dans l'interface commandée par phil916...

Mais en fait j'ai peur que l'ergonomie laisse à désirer. Manque de précision, petits boutons, etc...

J'ai fait un autre choix en mettant un joystick USB et l'intégrant à EMC2. Avec joyhandle.comp, il est possible de régler les courbes de transfert de façon à avoir un déplacement hyper précis sur les petits mouvements de joystick (par exemple jusqu'à mi course des manettes) puis ensuite envoyer les watts. Plus d'infos ici : http://wiki.linuxcnc.org/cgi-bin/emcinf ... _With_EMC2

J'espère que cela pourra aider...
 
ellogo67
ellogo67
Compagnon
14 Avr 2010
2 209
Soufflenheim - Alsace
Bonsoir :-D

super bonne nouvelle.
On va pouvoir étudier la chose. :wink:


:wavey:
 
G
gralo
Compagnon
20 Jan 2010
507
31 et 46
En fait je travaille sur la sœur jumelle de la TB6560, ma carte est a base de TA8435H, et les pins ne sont pas identiques.

Le principe de la télécommande pour ma part est a basse d'un oscillateur 555. la fréquence d'oscillation est régler par un potar qui gère la fréquence des impulsions et donc la vitesse des moteurs.

Montage très simple car le 555 n'a besoin que de deux résistances et d'un ou deux condos ( prix d'un 555 =0.50€)

Sans titre.JPG
 
ellogo67
ellogo67
Compagnon
14 Avr 2010
2 209
Soufflenheim - Alsace
Bonsoir :-D

oui, le principe est là. :wink:


Mais je pense qu'une gestion par PIC serait bien plus intéressante de par les capacités de ceux-ci. :)
La structure du circuit en serait largement simplifié. 8-)

La seule difficulté pour certains serait la programmation du PIC pour celui qui ne détient pas de programmateur.

Si le projet aboutit à quelque chose de concret et de fait fonctionnel, je suis prêt à programmer le PIC des personnes qui le désirent. :wink:

Mais avant, pour ma part, je dois terminer ma CNC et la rendre opérationnelle à 100%. :P


:wavey:
 
Y
yoplai
Nouveau
28 Déc 2010
37
bonjours, je suis ce post et me demande si y a une personne a pansé a contacter sont revendeur.voir meme le fabricant de cet carte pour l avertir de ce defaut. pour qu il rectifi cet erreur de conception.
 
Haut