1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Solidcam Probleme degagement Z

Discussion dans 'Autres' créé par Pascal76, 13 Mars 2014.

  1. Pascal76

    Pascal76 Nouveau

    Messages:
    23
    Inscrit:
    6 Mai 2010
    Solidcam Probleme degagement Z
    Bonjour à tous

    Voila je désire usiner une poche en plein milieu d'une pièce en alu avec solidcam et j'ai des petits soucis avec le Z dans le GCode destiné a Mach3
    En effet solidcam envoi le tête de la fraiseuse au milieu de la poche a usiner avec le Z au niveau 0 puis le monte au niveau de dégagement.

    Voici un bout du GCode généré
    O5000 (PATTE ECHAPP 25_10-50_110)
    N5 G0 G40 G49 G80 G21 (Initialisation)
    N10 G0 G53 Z0 (Retour aux origines machine)
    N15 G0 G53 X0 Y0
    N20 (Outil n° 2 - Diametre 5.87 D2 H2)
    N25 T2 M6 D2 H2
    N30 S1000 M4
    N35 M8
    N40 (F-contour-poche-vis)
    N45 G0 G54 X15.865 Y12.5
    N50 G43 H2 Z10.

    J'aimerais bien pouvoir d'intervertir N45 et N50 dans solidcam, je le fait actuellement avec le bloc note.

    J'utilise "Ajouter une opération de fraisage / poche " dans solidcam
    Je dois passer à coté de quelque chose car je n'arrive pas a trouver la solution

    Cordialement Pascal
     
  2. Hervé Philibien

    Hervé Philibien Nouveau

    Messages:
    9
    Inscrit:
    1 Février 2011
    Solidcam Probleme degagement Z
    Bonjour Pascal,

    L'édition des Post-Processeurs dans SolidCAM est assez simple.

    Ouvrez le fichier .GPP de votre Post-Processeur avec le bloc note.
    Recherchez "G0 G54 " (correspondant à la ligne N45) et "G43 H" (correspondant à la ligne N50)
    Intervertissez les lignes, et enregistrez le fichier. La modification sera effective à chaque génération du code. Vous aurez donc ce que vous recherchez.

    Sinon envoyez moi le fichier .GPP et .MAC (ou .PRP et .VMID si vous utilisez une version récente) Je jetterai un coup d'oeil.

    Cordialement
     
  3. pcng

    pcng Apprenti

    Messages:
    165
    Inscrit:
    15 Août 2013
    Localité:
    braine le comte
    Solidcam Probleme degagement Z
    Bonjour Hervé je vois que vous pouvez m’aider sur le post processeur de solidCam Jai un post pro 5 axe ou je n’arrive pas à faire du fraisage multiaxe avec solidCam et sella fait 3mois que je recherche le problème mai je commence a désespérai de trouver voilà mon gord problème si d’autre personne savez aider vous ait le bienvenu.
    En espèrent trouver une âme charitable

    Post Processeur Num760 5Axe
    Voir la pièce jointe Num 760_5axe.rar
     
Chargement...
Articles en relation
  1. dsmx
    Réponses:
    0
    Affichages:
    568
  2. nicoyote
    Réponses:
    1
    Affichages:
    475
  3. pcng
    Réponses:
    0
    Affichages:
    849
  4. pcng
    Réponses:
    0
    Affichages:
    596
  5. pcng
    Réponses:
    0
    Affichages:
    476

Partager cette page