1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Résolu ! Carte breadboard 5 axes problème

Discussion dans 'Mach' créé par Uriel, 6 Juin 2014.

  1. Uriel

    Uriel Nouveau

    Messages:
    43
    Inscrit:
    13 Juin 2013
    Résolu ! Carte breadboard 5 axes problème
    Bonjour à tous !

    Comme j'ai une difficulté pourtant de type "simple" et que je n'arrive pas à trouver la solution, je fait appelle à ceux qui ont plus d'expérience !!

    J'ai cette carte très répandue que j'utilise (enfin j’essaie !) avec mach3 :

    [​IMG]


    Et donc, à chaque fois que je fait avancer le moteur manuellement avec les touches ou bien avec du Gcode, la diode rouge situé vers "X axis control" (par exemple) s'allume une seule fois en une brève impulsion, puis les tensions restent à 5V (je les mesure) et donc, le moteur n'avance pas; mais il fait un bruit différent, car il a reçu une impulsion (enfin, je suppose !)
    Quand je retourne en marche arrière, rien ne se passe, puis quand je repasse à l'avant, de nouveau une impulsion et la DEL reste éteinte ensuite.

    C'est vraiment moche, je ne comprend pas pourquoi j'ai ça...

    Si vous avez une idée...

    Merci bien !!
     
  2. bequet gilles

    bequet gilles Compagnon

    Messages:
    778
    Inscrit:
    21 Mai 2012
    Localité:
    Cergy Pontoise
    Résolu ! Carte breadboard 5 axes problème
    Re: Carte breadboard 5 axes problème

    bonjour

    qu' as tu mis comme driver ,et comme moteur tu parles de 5 volts ? comment alimente tu ta carte par l' uSB ou alim ?

    a+ gilles
     
  3. Uriel

    Uriel Nouveau

    Messages:
    43
    Inscrit:
    13 Juin 2013
    Résolu ! Carte breadboard 5 axes problème
    Re: Carte breadboard 5 axes problème

    ça y est !! :-D 8-) :wink:

    J'ai trouvé ! C'est une carte dont l'ordre des broches du port DB25 est très différent de la logique numérique croissante !!
    J'ai tâtonné et lors de la configuration, à Motor Outputs, j'ai retrouvé les valeurs :

    [​IMG]


    Et donc là ça marche !
    Ensuite, avec ses résultats, j'ai pu trouver une doc de la carte ici http://www.savebase.com/infobase/do..._Driver/User_Manual_5_axis_Breakout_board.pdf

    Bon voilà, tout est en ordre !
    Merci gilles pour ta contribution, (c'était bien sur la carte et son pilotage par PC que j’essayais de concentrer l'attention, pas sur le reste qui n'interférait pas !)

    J'espère que ces valeurs pourront aider quelques personnes ! :-D :lol:

    A bientôt !
    Uriel
     
  4. bequet gilles

    bequet gilles Compagnon

    Messages:
    778
    Inscrit:
    21 Mai 2012
    Localité:
    Cergy Pontoise
    Résolu ! Carte breadboard 5 axes problème
    re

    je m' en doutais j' ai ramé aussi un certain avant de trouver il y a même des choses curieuses j' ai eu un cas ou 2(step) 14(dir) pour l' axe X fonctionnait

    mais pas 14(step) 2(dir) ? en plus mon axe A était naze sur une carte neuve en ce moment je cherche une carte pour avoir un 2eme port LPT2 mon vieux

    PC n' a pas de port PCI.

    bon courage

    a+ gilles
     
  5. Uriel

    Uriel Nouveau

    Messages:
    43
    Inscrit:
    13 Juin 2013
    Résolu ! Carte breadboard 5 axes problème
    Merci !
    Ha ces chinois, ils nous en feront voir de toutes les couleurs !!!

    Sur un PC de bureau, il me semble que tu peux facilement rajouter un port parallèle , c'est quelques euros sur ebay...
    Bon courage !!

    A bientôt !
     
Chargement...

Partager cette page