1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

[Résolu] Backlash?

Discussion dans 'Discussions générales sur la conception' créé par dexerit, 1 Novembre 2012.

  1. dexerit

    dexerit Apprenti

    Messages:
    181
    Inscrit:
    6 Mars 2010
    [Résolu] Backlash?
    Bonjour,

    Après plusieurs tentatives d'usinages de plusieurs fichiers avec de nombreux cercles, je me retrouve avec des usinages avec défauts car il y a un décalage en +Y.

    J'ai tenté de configurer le backlash sous mach3 sans résultat probant.

    J'ai lancé une série de tests.
    J'ai fixé un pied à coulisse numérique sur le martyr, positionné ma broche en conséquence, et lancé une série de déplacements comme suit:
    Y-5
    Y0
    y-5
    y0
    y-5
    etc..

    Au bout d'une dizaine d'aller retours j'ai un décalage de -0.18 en +Y

    J'ai fait l'expérience de mesurer de l'autre coté de la broche. Après test j'ai un décalage en +Y de +0.18.
    Le décalage se fait toujours dans le même sens. Pour imager le truc, si je fais une serie de mouvements aller-retour, au final le chariot avance quand même...

    J'avoue avoir du mal à comprendre... J'ai baissé les accélérations pourtant sans succès.

    Avez vous une idée?

    Merci a vous!
     
  2. dexerit

    dexerit Apprenti

    Messages:
    181
    Inscrit:
    6 Mars 2010
    [Résolu] Backlash?
    Re: Backlash?

    Oups je viens de constater que je me suis trompé de section, si un gentil modo peut déplacer le topic svp...

    Merci et désolé :wink:
     
  3. antoinebeniste

    antoinebeniste Ouvrier

    Messages:
    498
    Inscrit:
    14 Novembre 2009
    Localité:
    33
    [Résolu] Backlash?
    Re: Backlash?

    Salut, a quelle vitesse fais tu tourner les vis? Perso Je ferai ce test a 1000mm/min pour voir si c'est pas une perte de pas. Un jeu de 0,18 c'est quand même énorme comme backlash même pour une vab chinoise. Si ce n'est pas une perte de pas, ça passera surement par un réglage a faire dans ton logiciel de contrôle d'axes.
    Antoine
     
  4. dexerit

    dexerit Apprenti

    Messages:
    181
    Inscrit:
    6 Mars 2010
    [Résolu] Backlash?
    Re: Backlash?

    Salut Antoine! :wink:

    Je vais tester cette piste, mais ce backlash de 0.18 est apres 10 aller retours de 5mm. pas en une seule fois!
    Je suis sous Mach3 avec licence, et en déplacement max de 2500mm/min.

    Je teste demain à 1000mm/min.
    Mais je trouve ça étonnant que cela se produise uniquement sur le Y et que dans un sens...

    Merci! :wink:
     
  5. pascalp

    pascalp Compagnon

    Messages:
    939
    Inscrit:
    30 Août 2007
    Localité:
    Agen, Sud-Ouest
    [Résolu] Backlash?
    Re: Backlash?

    Pour mes mesures de backlash, je fais des trajets: -5 , 0 , 50 , 55 , 50 , 0 , -5 , 0 , ...
    les parties 0 , -5 , 0 et 50 , 55 , 50 me donnent le backlash en + et en -
    les 0, 50 et 50 , 0 me permettent de vérifier la justesse de déplacement sans backlash (enchainement de deux déplacements dans le même sens).
     
  6. antoinebeniste

    antoinebeniste Ouvrier

    Messages:
    498
    Inscrit:
    14 Novembre 2009
    Localité:
    33
    [Résolu] Backlash?
    Re: Backlash?

    Hello,
    2500mm/min est une forte vitesse d'avance et tu n'usineras quasiment jamais a cette vitesse, il me semble que tu es sous 36v, ça fait un peu juste pour maintenir cette vitesse avec couple. Mais bon bizarre que la perte soit régulière donc je me dit que c'est peut être autre chose.
    Pour être sur que ce n'est pas un problème de backlasch, colles un cercle en papier au scotch (ou au pistolet a colle thermique) sur la vab sur lequel tu fais un repère qui coïncide précisément avec ce que tu veux, tu mets X0 Y0.Tu lances un usinage et en fin de programme, tu reviens sur X0 Y0 et tu vérifies si tu retombes sur ton repère, si tu retombes dessus c'est en effet un pb de backlash, si non c'est une perte de pas.
    Tu peux aussi vérifier que tu as bien cette valeur en step par mm (200/5)X microstep
    Est ce que j'ma suis bin fait comprende?
    Antoine
     
  7. antoinebeniste

    antoinebeniste Ouvrier

    Messages:
    498
    Inscrit:
    14 Novembre 2009
    Localité:
    33
  8. dexerit

    dexerit Apprenti

    Messages:
    181
    Inscrit:
    6 Mars 2010
    [Résolu] Backlash?
    Re: Backlash?

    Bonsoir Antoine,

    Non je n'ai vraiment pas trouvé le temps ces derniers jours, mais crois bien je te tiendrais informé dès que je ferai les tests...!
     
  9. dexerit

    dexerit Apprenti

    Messages:
    181
    Inscrit:
    6 Mars 2010
    [Résolu] Backlash?
    Re: Backlash?

    Salut Antoine, Je viens de réaliser le test en baissant la vitesse hors matière à 1000mm/min et en reduisant le nombre de pas à 1/2 micro step (80 dans les paramètres mach3)

    La fraise ne revient pas en X0 Y0...
    J'avoue avoir du mal à saisir...
     
  10. antoinebeniste

    antoinebeniste Ouvrier

    Messages:
    498
    Inscrit:
    14 Novembre 2009
    Localité:
    33
  11. antoinebeniste

    antoinebeniste Ouvrier

    Messages:
    498
    Inscrit:
    14 Novembre 2009
    Localité:
    33
    [Résolu] Backlash?
    Re: Backlash?

    L’accélération peut être source de problème aussi, essais de la diminuer.
    Et autre chose, certaines cartes, il me semble, perde un pas au changement de direction et il faut cocher "step low active" dans port and pin, motor outputs.
     
  12. dexerit

    dexerit Apprenti

    Messages:
    181
    Inscrit:
    6 Mars 2010
    [Résolu] Backlash?
    Re: Backlash?

    Bon je viens de faire les essais que tu m'as décris et le marqueur revient bien à sa position d'origine.

    J'ai aussi testé sous RP-FMS et là je n'ai aucun soucis.
    Les seules différences sont les vitesses de déplacement au niveau configuration.
     
  13. antoinebeniste

    antoinebeniste Ouvrier

    Messages:
    498
    Inscrit:
    14 Novembre 2009
    Localité:
    33
  14. dexerit

    dexerit Apprenti

    Messages:
    181
    Inscrit:
    6 Mars 2010
    [Résolu] Backlash?
    Re: Backlash?

    non je n'ai pas réglé le problème, je te confirme juste que je retombe sur le repère, mais c'est pas super précis comme méthode...
    Par contre avec un autre logiciel le problème semble résolu.

    Je vais me pencher sur ton histoire de "step low active"!
     
  15. antoinebeniste

    antoinebeniste Ouvrier

    Messages:
    498
    Inscrit:
    14 Novembre 2009
    Localité:
    33
    [Résolu] Backlash?
    Re: Backlash?

    Tout dépend de la taille du cercle, pour la précision du test, c'est comme ça que j'ai testé mes moteurs au début.
    J'espere que c'est le step low active sinon après je ne saurai quoi te conseiller.
     
Chargement...

Partager cette page