1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Problème G33 filetage sur num 1040T

Discussion dans 'Num' créé par Lowvolt, 12 Mai 2012.

  1. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Problème G33 filetage sur num 1040T
    Bonsoir à tous !

    j'ai récemment fait l'acquisition d'un tour manurhin KMX T80, cousin germain de l'EMCO turn 120.
    J'ai un soucis concernant le filetage.

    Lorsque je suis le manuel de programmation de num pour réaliser un filetage M12, le cycle fonctionne, mais le résultat final n'est pas probant : j'ai l'impression que le filetage n'est pas fini, et j'ai plus une vis trapézoïdale qu'une vis à pas iso (sommet de filets "plats"), et lorsque j'essaie d'enfiler un écrou, il ne mort même pas au début de filet car filetage pas assez profond.

    Il faut au final que je modifie la jauge de mon outil de 0.5mm en négatif pour que mon écrou rentre.
    Si mes lignes de code sont biens écrites, je ne vois que la façon dont je règle ma plaquette de filetage qui n'est pas bonne : je viens tangenter ma plaquette sur diam. 12 de la zone à fileter et rentre la valeur en X à 12.
    J'ai également essayé de réaliser un M12 sur un autre tour avec CN différente, et le résultat n'est pas meilleur ...


    Quelqu'un pourrait me donner les écritures pour réalisation de ce M12 afin que je teste ?

    Une explication sur vos façon de régler l'outil de filetage serait bénéfique :) (on apprend tous les jours)

    Merci !
     
  2. Nono.60

    Nono.60 Apprenti

    Messages:
    213
    Inscrit:
    30 Avril 2010
    Localité:
    Meru (60)
    Problème G33 filetage sur num 1040T
    Bonsoir,
    Voila ce que j'ai trouver sur le forum,

    CYCLE DE FILETAGE G33
    Cette fonction définit un cycle complet de filetages : cylindriques, coniques, frontaux, à pas constant et profondeur de passe dégressive à section de copeau constante.

    La syntaxe du bloc d'appel est la suivante :
    G33 X... Z... K... EA... EB... R... P... Q... F... S...

    avec :
    X Z : coordonnées de la fin de filetage;
    K : pas du filetage;
    EA : EA=0 pour filetage cylindrique, A=90 pour filetage frontal;
    EB : angle de pénétration, B=0 pour pénétration droite;
    R : longueur du cône de dégagement;
    P : profondeur totale du filet, P=0.613K;
    Q : profondeur de la dernière passe;
    F : nombre de filets (maximum F9, par défaut F1);
    S : nombre de passes S > 20P/3 (passe de finition non comprise).

    je regarderai je doit avoir un tableau Num pour les filetages
    Cordialement,
     
  3. rh03

    rh03 Apprenti

    Messages:
    126
    Inscrit:
    2 Août 2009
    Problème G33 filetage sur num 1040T
    Essaie ton m12 avec g33 x12 Z.. Ea0. K1,75 p1.073 q0.069 eb0 s7 ,pour ce qui est de la jauge moi je tourne un diametre , le mesure au micrometre et vient poser mon outil a fileter sur le diametre etalon en intercalant un morceau de papier entre piece et outil et je rajoute un dixieme a mon diametre etalon(epaisseur feuille type imprimante aproximativement un dixieme)
     
  4. Dodore

    Dodore Compagnon

    Messages:
    6 648
    Inscrit:
    27 Octobre 2008
    Localité:
    F-69400 villefranche sur saone
    Problème G33 filetage sur num 1040T
    bjr
    bizarre j'ai dit bizarre si tes jauges sont bonne....
    si ta machine fait correctement le filetage
    et si en plus c'est le même problème sur une autre machine ..... bizarre
    est ce que tu as essayé de vérifier la jauge en IMD
    pour vérifier si ton outil viens bien tangenter du ton diamètre?
     
  5. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Problème G33 filetage sur num 1040T
    Bonjour !!!

    Merci beaucoup pour vos réponses !

    Alors pour le réglage de mon outil de filetage, je suis bon, c'est déjà ça !

    Pour les codes, j'ai ça :

    N50 T03 D03 M6
    N60 G97 S1000 M3
    N70 G0 X24.2 Z2.

    N80 (TH-contour2)

    N90 M8
    N100 G97 S1000
    N110 X24.2 Z2.
    N120 Z1.5
    N130 X16.
    N140 G33 X12. Z-11.854 K1.75 EA0 EB30 R0. P1.073 Q0. S25
    N150 G0 X24.2
    N160 Z2.
    N170 M9

    Je note donc dans la ligne générée plusieurs points qui ne collent pas :

    G33 X12. Z-11.854 K1.75 EA0 -> jusque là, tout va bien.

    => EB30 : c'est déjà un problème, maintenant, quel effet ça a sur le résultat ? le filetage est conique avec pointe du cône au début (Z0) ou à la fin (Z-11.854)

    => R0. OK
    => P1.073 OK valeur prise sur un "filetor"
    => Q0 : est-il obligatoire d'avoir une passe de finition ?
    => F : n'est pas généré par mon post-processeur (je vais faire corriger ça dès lundi matin), il m'arrive d'avoir à faire des triples ou quadruples filetages/taraudages (j'y arrivais en faisant plusieurs essais avec correction de la jauge d'outil)
    => S25 : j'ai mis 25 pour un bel aspect du filetage, mais est-ce vraiment nécessaire ?
     
  6. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Problème G33 filetage sur num 1040T
    J'ai en effet vérifier à plusieurs reprises la jauge de mon outil en IMD et même en semi-auto en demandant à mon outil de revenir à X12 après un déplacement quelconque, et toujours OK.
     
  7. Nono.60

    Nono.60 Apprenti

    Messages:
    213
    Inscrit:
    30 Avril 2010
    Localité:
    Meru (60)
    Problème G33 filetage sur num 1040T
    Bonjour,
    Voila la Doc que j'ai retrouver pour les filetages NUM
    avec des exemples, si ça peu vous etre utile
    [​IMG]

    Cdlt,
     
  8. Chrisp54

    Chrisp54 Apprenti

    Messages:
    208
    Inscrit:
    28 Octobre 2008
    Localité:
    F-54640
    Problème G33 filetage sur num 1040T
    Bonjour,

    As-tu vérifié la plaquette ?
    La pièce en porte à faux ?

    Bizarre...

    Christian
     
  9. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Problème G33 filetage sur num 1040T
    merci Nono.60 pour le tableau, je vais le garder précieusement ! :wink:

    Chrisp54 : la plaquette est neuve et est bien en 60°, la pièce n'est pas en porte à faux :Ø12mm sur 15mm de long, matière Alu 7075.

    Si je peux, je fais un test cet après-midi et reviens vous donner les résultats.

    En attendant, la famille m'attend pour l'apéro !!! :drinkers: et le barbecue !
     
  10. Dodore

    Dodore Compagnon

    Messages:
    6 648
    Inscrit:
    27 Octobre 2008
    Localité:
    F-69400 villefranche sur saone
    Problème G33 filetage sur num 1040T
    Il y à certain paramètres qui ne sont pas obligatoire
    EA si il n’est pas marqué EA=0
    EB ---------------------------EB=0
    R------------------------------R= 0
    Q------------------------------pas de passe de finition
    F------------------------------filetage à un filet

    Fait un essai uniquement avec les paramètres obligatoire
    Il me semble que la pénétration à 30° est un peu exagérée, pour que l’outil coupe un peu sur l’autre flanc, il faudrait mettre plutôt 20 ou 25° ,pour ma part je n’en mettais pas je faisais une pénétration droite, par contre, je n'ai jamais fais de l'alu donc je ne connait pas le résultat si il n'y a pas d'angle de pénétration
    Je ne mettais aucun des paramètre de cette liste sauf les paramètres Q et S
    parce que si S n'est pas marqué S=1
    J’avais remarqué que le nombre de passes est environ égal au pas multiplié par 4
    il me semble que S= 20 est vraiment exagéré, si tu prends de trop petite passe l'outil fait un copeau trop fin et donc mauvaise finition et usure prématuré de l'outil
    je ne pense pas que ton problème vienne de là mais il faut une garde, en Z suffisante, pour que la machine est le temps de synchroniser les mouvements , si je me rappelle il faut 3 fois le pas
     
  11. Dodore

    Dodore Compagnon

    Messages:
    6 648
    Inscrit:
    27 Octobre 2008
    Localité:
    F-69400 villefranche sur saone
    Problème G33 filetage sur num 1040T
    Il m'est venu une idée: est-ce que tu as bien la bonne plaquette? Est-ce que ce ne serait pas une plaquette à 55°?
     
  12. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
  13. bilbil

    bilbil Compagnon

    Messages:
    839
    Inscrit:
    5 Janvier 2010
    Localité:
    Ain
    Problème G33 filetage sur num 1040T
    bonsoir,

    pour ma part je me sert du G38 qui permet de faire passe par passe plus pratique que le cycle G33.

    G0 X..... Z.....
    X........ 1 PASSE
    G38 Z-....... K......
    G0 X.......
    Z........
    X...... 2 PASSES

    bonne soirée.
     
  14. Dodore

    Dodore Compagnon

    Messages:
    6 648
    Inscrit:
    27 Octobre 2008
    Localité:
    F-69400 villefranche sur saone
    Problème G33 filetage sur num 1040T
    desolé je ne peux pas résister :
    "pourquoi faire simple quand on peux faire compliqué"

    d'autre part tu peux le faire avec un G77 ou un G79 qui te permettra d’écrire moins de blocs
     
  15. Lowvolt

    Lowvolt Apprenti

    Messages:
    176
    Inscrit:
    22 Novembre 2010
    Problème G33 filetage sur num 1040T
    de retour !

    désolé pour le temps sans nouvelles, j'avais quelques petites galères à régler.

    Je commence donc aujourd'hui avec un filetage M6, et voici ce qui sort :

    N100 G97 S1000
    N110 X26. Z0.6
    N120 Z-0.5
    N130 X7.
    N140 G33 X6. Z-9.25 K1. EA0 EB30 R0. P0.613 Q0.065 S4

    Je vais faire le test dans la 1/2 heure et vous donne les news
     
Chargement...
Articles en relation
  1. ilyeskt
    Réponses:
    2
    Affichages:
    147
  2. atefahmed
    Réponses:
    2
    Affichages:
    210
  3. carpat
    Réponses:
    2
    Affichages:
    276
  4. ilyeskt
    Réponses:
    4
    Affichages:
    588
  5. jéjé
    Réponses:
    6
    Affichages:
    444

Partager cette page